WinRT crashes Cubase 12

I thought I’d give WinRT a try to solve the problem of Cubase being confused about the two MicroMonsta 2s I have here.

I switched WinRT on, named all the ports I could (many of them just reading ‘MIDI’, so thought I’d just number those and do a bit of trial and error to narrow them down later). I could still only see one MicroMonsta 2, so it looks like the claim that it can sort this type of problem out is dubious.

As soon as I tried to return to the Arrange window - bang! Cubase throws up a ‘Serious Error’ message.

I tried again with the same result.

That’s the last WinRT will see of me.

Anyone using it successfully?

Yes, WinRT works fine here with Cubase 12 and other software on lots of devices, physical and virtual. WinRT is able to drive certain MIDI devices which the legacy MME interface cannot, such as Bluetooth MIDI, so MME is almost certainly on the way out when enough programs are updated for it.

Are you using any third-party MIDI device drivers? Might be worth seeing if there are updated versions of those, but most USB-MIDI devices use the USB class compliant driver included with Windows 10/11 and that works fine.

If you have more than one MicroMonsta 2, you ought to see it as two devices, one ending in [0] and one ending in [1] in the Device Manager.

You could try uninstalling all your MIDI devices from the Device Manager, rebooting, and then plugging them all in again.

A serious error message usually shows the name and path of a dmp file. Can you please upload this file?

Message has long since gone, and I don’t want to go back in and risk worse, so unless the dump is still there and easy to find I can’t upload it.

No, I didn’t see two MicroMonstas - only one.

I already decided to live with things as they are. The last thing I need is sorting out stuff like the ridiculous Korg drivers (ugh!). Just glad to know others are having success with this new option. I’ll now leave it be until maybe a new PC arrives.

You can find them in Documents\Steinberg\CrashDumps under your user login in Windows.

It looks like you are using VSTConnect and that is blocking somehow. Two of your dump files show that this process seems to get through the eLicenser process (SYNSOACC) and then goes into sleep.


The other files show something similar when launching VSTTransit


Do you need VSTConnect? Can you try to disable it (I’m not using it) and run without?

Never use it - never will.

Thanks for the help, but I’m leaving well alone.