Wireless Headsets not being picked up as a device (Tried all common fixes already)


I’m running cubase 12, the computer specs themselves don’t really matter for this issue (i’ll explain shortly) :

Cubase seems to have an insanely hard time handling audio drivers and headsets, upgraded from Hyperx Cloud 2 wired headset (was quite a hassle to figure out how to get it working, after coming from different daws where it was not an issue at all, eventually worked by going into studio setup → devices → setting generic low latency asio driver → control panel → selecting wired headset as output - i suggest most of you who are having issues check if this works for you, it did while i was using the wired headset).

Now i have the wireless Cloud 3 headset, and the program doesn’t recognize it as an audio device in any way, not in control panel, nor otherwise… tried other DAWs (Free version of FL studio) and it recognized it just fine, without having to mess with audio drivers when switching windows or reset anything either

Is there a way to fix this and get it to pick up on the wireless headphones?
currently it just has output set as my studio monitors, which means i can’t record with audio active using these headsets… an upgrade of my gear somehow became a downgrade.

i’m very new to cubase but i’m already getting fed up with how primitive it feels at doing basic things like just switching output to a headset or switching from the DAW window to a video without messing things up.

also just to be clear, i’ve searched all over for a fix for this and couldn’t find anything, seems it’s been a running issue for years with different versions of cubase, i’m not sure why it wasn’t fixed yet seeing as how having outputs working smoothly is kind of basic for a music production program.

I can’t even get in touch with steinberg because they don’t seem to offer any support here, and if i contact the ‘local distributor’ that steinberg refers me to in their support ticket menu, i get redirected to steinberg, then told they can’t help me, so ya’ll are my last hope on this issue as i’ve tried everything i could think of.

Hardly. But you have to know how it works a little bit.

Cubase primitive? That’s one weird sentiment.

As you know, Cubase requires devices that provide ASIO drivers. You should try the well-known asio4all as a substitute.

Contrary to what you said, your OS info is needed.

1 Like

Specs do always matter, at least the platform is required, since Mac and Win handle audio devices differently.

1 Like

Fair enough, Mac isn’t really a thing over here (very rare) so didn’t even cross my mind as an option, i’m running windows 10.

Any other info needed?

I don’t see that as an option in the program, the asio4all thing i mean.

OS is windows 10, mac’s not really a thing people use over here (for anything beyond programming etc, their prices are just through the roof so they’re rarely used)
Any other info needed? like specific pieces of the hardware or anything

and as for the asio4all, i saw it as an option back when i used FL studio, but here it just does not show up at all, not sure if its something that’s supposed to come with the program download or if its external or what’s the deal.


just searched it up, seems asio4all causes issues with the scarlett interfaces from focusrite, so it’s not really a solution, i appreciate the attempt though