WL 10,0,30 update Bugs/broken info

Hi PG and forum

I just updated to 10,0,30 on Win 10 yesterday, and have found some more plugins not working

I use jBridge to bridge a few 32 bit plugins over to 64bit- and these now do not load at all- previous versions of WL all was fine- could we please have a fix for this?

TDR plugins- all was working fine in 10,0,10 and below (9,5 and 10,0) Nova doesn’t work in conjunction with other plugs in the Montage since 10,0,20- was hoping for a fix in 10,0,30


I don’t use TDR plugs much but I just tested Kotelnikov GE and it seems to be working fine (and with other plugs DMG Sonnox Voxengo) What aspect doesn’t work for you?

Kotelnikov GE is great! only Nova/Nova GE is broken , and only in the Montage…

Some TDR plugins are very crashy. Nothing WaveLab can do about that. The guys from TDR should test that.

I can confirm that with the 10.0.30 update ALL my jbridged plugins ARE NOT WORKING

i get an error message each time i load them from the master section

could you please fix this?? is really really annoying

Hi Philippe

this may be true, but why would they work without any problems at all on previous WL versions,and then, since 10,0,20 TDR Nova doesn’t work in the Montage, and since 10,0,30 the JBridge wrapper doesn’t work at all, when the BOTH worked not only in 9.5, but 10,0,10 also?

Sincerely …

Are you sure jbridged does not stop to work because of the latest Windows 10 update?
Anyway: WaveLab is a 64 bit application using 64 bit plugins: jbridged has never meant to be supported by WaveLab. Maybe it used to work, but this independent from WaveLab. I never ever installed and tried jbridged.
On a side node: what 32 bit plugin is so good that there is no 64 bit equivalence?

I have already seen TDR Nova crash logs. I don’t know why they could work in a past version; maybe some new option was used by WaveLab recently. Anyhow, please forward the problem to TDR, because the crashes happen deeply inside these plugins.

I’ve been emailing pretty closely with TDR about some crashes. They are responsive. The more info you can provide to them, the sooner and better they can fix it.

Kotelnikov seems solid, but Nova GE was causing me some serious playback crashes, while Limiter 6 GE seems to cause a crash if you quit WaveLab when a montage is open that has Limiter 6 GE loaded.

This has been the great mystery since I started using WaveLab. I truly think that Steinberg needs to create a SOLID plugin testing tool for plugin developers because there is clearly some misunderstanding somewhere.

In providing crash and bug reports to numerous plugin developers, more than a few have said that VST3 has been challenging to code for and I’ve noticed that generally speaking, VST2 plugins seems more stable, despite being older and less efficient behind the scenes.

One big clue is that UAD, who seem to have a very high standard of quality with their software and hardware, STILL haven’t released VST3 versions. They are clearly taking their time launching VST3 versions to get it right.

Other relatively solid plugin developers such as TDR and Sonnox have only recently finally released VST3.

I think a robust testing tool that gets into the weeds of why WaveLab is so sensitive to 3rd party plugins compared to Cubase/Nuendo would be a good thing. I’ve seen people leave, or demo but not buy WaveLab because of how unstable their usual plugins behave in WaveLab.

PG listen,
it’s not related to the latest Windws 10 update.
In Wavelab 9.5.50 all the Jbridged plugins work like a charm.

I think i’m free to use any kind of plugin i want right?

So it’s a wavelab fault with the latest release.Something that for sure has not been checked during the beta testing process (if any has taken place)

I guess you should fix it


When I spent a whack of money on a few plugins a few years ago, why shouldn’t I still use them, or why should I be forced to buy another plugin because it’s now not working in WL 10.0.30, when it’s working fine in Cubase 10.5.12?

Nothing to do with the windows update- this morning I re installed WL 10.0.20 , Montages in the session are working with Jbridge- Update to 10.0.30, get the plugin errors as described in this thread- just to be sure, closed all , rebooted machine, opened WL, opened a different .wav, tried to insert a jBridged plugin , and i get error msg.

Was the same process for me when I ‘upgraded’ to 10.0.20 from 10.0.10- TDR Nova does not work in 10.0.20 Montages- 64bit VST2- not even talking about VST3

For updates, would it not be possible at least to have total separate programs, as in 9.5 and 10 at the same time on the same machine?
We read thru the ‘bug fixes’ and really look forward to trying things that should be ‘fixed’ and other things pop up

i use a Lynx Hilo via USB- had crashes this morning accessing the audio routing panel. got thru eventually, but now seeing spikes on the plugin meter- hmmm

Some things ,like changing sample rate between montages or files seems definitely more solid to me.


would it not be possible at least to have total separate programs, as in 9.5 and 10 at the same time on the same machine?

You mean several 10.0 versions? Yes it is possible.
Duplicate the folder:
WaveLab Pro 10.0
WaveLab Pro 10.0.20

Then reinstall to get 10.0.30 inside the 10.0 folder.

There is no limit to that. But only one version can run at a time, and settings are shared.

hi there,

i do have a lot more crashes and GUI-problems (for ex.: GUIs freezing - div. softube -, or getting grey - leapwing-audio stuff - when i click in another part of the timeline, or bypass/un-bypass, etc.) with diverse plugins under 10.0.3.
and: the loop-function in the transport doesn’t work anymore. have been using this for ages, so no clue…
i’m on mac (two machines, 10.13.6 and 10.14.5).
working with certain plugins has always been a kind of gambling with wavelab, but this seems to escalate here.


This is a crazy read. In the year 2020 I’m amazed to see anybody here using 32 bit plugins with jbridge. The architecture of plugins has come a long way in 20 years. I can understand a devotion to money spent but there comes a time when - if a company is not able to produce even a 64bit VST2.4 version of their product - then they are way more committed to the past than they should be (or are they out of business?). I have a plugin, SIR3, an IR program created by a one man company, and SIR3 is 64bit VST3. This man is certainly brilliant, but he doesn’t have a big wallet. How is it that he can move his former SIR2(64bit VST2.4) plugin to VST3 capability and these other companies cannot? And they can’t even produce 64bit VST2.4 plugins? I don’t get this.

If you’re this committed to the old tech, maybe you need to have jBridge Co. create a better product? Too, if PG wants to draw a line I totally get this, in 2020 you can’t expect to run even a 20 ppl restaurant business using WinXP.

As to the performance of 10.0.30 running 5 VST2.4 (64bit) and maybe 90 VST3 (64bit) plugins, WL is a beast. I have never had such fast loading or closing of montage projects - the tip of the iceberg I think. Thanks, PG!

Nail on the head! my pet love is Spitfish…!

I think the point is though, why is Wavelab breaking perfectly working plugins? recall of projects are not possible- is this the new ‘norm’?

I hope there is a fix soon

TX @PG on the duplicate folder idea!


Where do you get off telling people how to use their software? Who on earth do you think you are?

I have evaluated Wavelab 10 on the basis that it works with Jbridge, which I use for certain 32bit plugins. And for your information, what precisely they may be is NONE of your business.

If this functionality is no longer working it is a deal breaker for me. It is that simple


I think Philippe said it very clearly: “WaveLab is a 64 bit application using 64 bit plugins: jbridged has never meant to be supported by WaveLab. Maybe it used to work, but this independent from WaveLab. I never ever installed and tried jbridged.”

This is far from new in 10.0.30: I can’t recall 100%, but it was years ago that Steinberg (not only WL) went completely 64-bit. If your VST2 plugs kept working with Jbridge, you simply were lucky and now it’s done. Nobody ever said WL was compatible with Jbridge as mentioned above so there is no ‘functionality [that] is no longer working’.



+1. It would be great if there was a testing tool common to all steinberg software.

But IMO the reasons why some plugins don’t work is a real jungle. As you say developing VST3 versions might be more difficult for some developers but regardless, if developers want to survive beyond 2020 they’re probably now obliged to produce 64-bit VST3 versions or they’ll soon be left behind. As a side note, there are also issues with some plugins in Nuendo and Cubase.