WL 11.0.3 clip effects not rendering [SOLVED]

We have 2 identical Macs with 2 identical installations of WL 11.0.3. On one of the machines, we just noticed that when rendering a whole montage where each clip has clip FX plug-ins applied, the plug-ins are only rendered on the first clip in the montage. The rest of the clips don’t get their Clip plug-in processing applied.

If we open this same montage and run the same render on the other Mac, all plug-ins are applied as expected. Everything is normal and correct.

I’ve spent quite a bit of time ensuring that all the WL Preferences are the same between the 2 Macs. Maybe I missed something? What am I missing? What should I be looking for? What could be happening?

thanks for any assistance,
bob

Never heard about a similar case. What plugins are you using?

What kind of rendering are you doing?
image

Yes. Whole Montage.

So far I’ve tried different combinations of FabFilter C2, Waves Abbey Road TG Mastering Chain, Softube Weiss DS1-MK3. Same plug on all songs. Different plug on each song, Different combinations.

I just tried it with no plugs on clip 1. Plugs on the rest of the clips. No plugs are applied during render.

Only clip 1 seems to render a clip plug in with this set up currently.

Now working correctly with all sonnox plugs. More testing with different plugs to come.

For testing I have a short 3 song montage. If I put the same plug-in on all 3 songs as clip FX, the results for different plugs are:

Works correctly as expected (applied to all 3 songs when Whole Montage rendered):
Sonnox EQ
Izotope Ozone 9 EQ
Steinberg StudioEQ
TDR Nova EQ

FX are only applied to clip 1 when Whole Montage rendered:
FF Pro Q3
FF Pro C2
Soothe
Softube Weiss DS1-Mk3
Waves Abbey Rd Mastering Chain

These are all VST3 plugs.

I can report that I had a similar issue in WL 11.0.10 Windows 10 Pro (then current build).

In 11.0.10 maybe 3-4 times (so rare and completely random) I rendered a montage (output effects only) and it seemed to take the expected time for the plugin chain.

However, post render the file is ‘partially un-rendered’. This was along the lines of the render issues currently being reported amongst Sequ*ia users.

The fix was to exit WL, relaunch it and re-render.

For me the simple plugin chain I use does not change much so I thought it unlikely to be the cause. To allay any doubt, this plug in chain has been stable and consistently OK over many versions of WL (DMG Track Gain, DMG Equilibrium, Sonnox Limiter, Voxengo Elephant or Limitless). Very well coded stuff. I’m pretty much always working at 32 bit float 96 kHz.

There was also another random issue and the combination of these things was confidence destroying. I didn’t have time to go deeply into it … I simply went back to 9.5 for a time.

11.0.3 seems OK.

Do you mean when either of these plugins is used, or all are used?
I did a quick test using the Q3 only, without a problem.
I have seen several bug reports concerning Soothe and Softube Weiss plugins in the past. Try without them.

I assume you use WaveLab 11.0.30 ?

If I apply only ProQ3 to all the clips in a montage, and then do a Whole Montage render, the ProQ3 is only applied to the first clip.

If I apply only ProC2 to all the clips in a montage, and then do a Whole Montage render, the ProC2 is only applied to the first clip.

If I apply only Soothe to all the clips in a montage, and then do a Whole Montage render, the Soothe is only applied to the first clip.

etc.

This is with the official release of WL 11.0.30.

BUT, the most interesting thing to me is that we have 4 Macs all running the same version of WL with all the same versions of all these plug-ins. But this problem is only happening on one machine. On the other 3 machines, all plug-ins are rendering correctly during a Whole Montage render.

So I guess there is a problem with only this installation of WL, or this system somehow. What is the best way to fix this?

Reinstall everything? The OS?

Is there a way to completely uninstall WL and all preferences and other WL related files? And then do a fresh clean install? How do I wipe out everything and start clean on this machine? And is that what you think I should do? Or what do you recommend?

Thanks,
bob

What procedure do you follow to do so?

I have a stereo 96kHz Montage containing 3 clips. In the Clips inspector, I use the drop down to instantiate one instance of ProQ3 on the first clip. I adjust the ProQ3 settings.

Then I select the second clip in the montage, go to the clips inspector, use the drop down to instantiate one instance of ProQ3 on the second clip. I adjust the settings for that clip’s ProQ3.

Then I select the third clip in the montage, go to the clips inspector, use the drop down to instantiate one instance of ProQ3 on the third clip. I adjust the settings for that clip’s ProQ3.

My Montage has a ProL2 already instantiated on the Track output. I adjust its settings.

I then render the whole montage to a 96/32F wav (using the settings shown in the screenshot at the top of this thread.)

In the resulting rendered Montage and wav file, the EQ has only been applied to clip 1. The Tracks limiter has been applied to the entire Montage.

This is crazy.

Also, I have made a basic 96k audio montage for rendering testing. It contains a 1k tone at -20 and the montage is split up into 10 album tracks that are each 1 min long, staggered on two lanes of a single track:

https://www.dropbox.com/s/pe20iu90opy910l/JP-Plugin-Render-Test-Start.zip?dl=1

There are no plugins inserted yet.

If you play the montage there is no disruption in the test tone as it changes from track to track so this makes for a good starting point to test the rendering performance of plugins and WaveLab.

This is what I will use to do some additional testing of plugin rendering.

I will be doing some extensive testing tonight.

Since this is only happening on one of my machines, I still wonder if only this WL installation or this machine is somehow corrupted?

I must say I scratch my head.
I will add some logging in a future update, to better understand this kind of case.

The first and easy thing you can do is to remove the WaveLab preference folder, to start from a clean situation. /Users/YourName/Library/Preferences/WaveLab Pro 11/

This being said, when I have a strange case, I try two procedures to reproduce (or stop reproducing the error):

  • stepping from A to Z, until the problem occurs. That is, start with an empty montage (not from a template). Add a clip, ok? Add a clip plugin, ok? Add a second clip, ok? Add a plugin to this second clip, ok? etc… Sometimes, save and close the plugin, still ok?

  • stepping from Z to A. That is, starting from the montage with the problem. Remove plugin. ok now? Remove Clip, ok now? etc… until the problem disappears.

And also, try to check the result in different ways: audible, meters (WaveLab + Supervision), and visually (waveform).

OK. Will try some more things. Thanks.

is there an “uninstaller”?

Not on Mac, but this would not help to remove the preferences.

Isn’t “AppCleaner” for OS X good enough ?
Using this for 10 years!

https://freemacsoft.net/appcleaner/

regards S-EH