WL 11 vs. Monterey

Has anyone been brave (or foolish) enough to try and run WL 11 on Mac OS Monterey? I would like to hear how it works if it works.

I have a new M1 Max laptop coming next week. I have a feeling Monterey will be installed on it. I’ll be sure to post my findings when I try to do some basic things but my laptop (as of now) is never my primary workstation where I’d be more likely to discover any less obvious issues.

Looking forward to hearing about your experiences with WL 11 on Monterey. That M1 Max laptop appeared to be a hugely capable computer with ample performance reserves.

Right. Aside from just being a nice laptop, I’m going to experiment with it being my mobile rig for serious use if/when needed.

Right now, my fairly powerful MacBook Pro from a couple years ago can somewhat easily get overloaded with 96k montages mastering all “in the box” so I’m curious if this new one will be able to handle bigger plugin chains at 96k and allow me to work remotely without compromise.

I have WL 11 and installed Monterey on my iMac (24", M1, 2021) on Monday. I’m on a learning curve with WL so I can’t do anything particularly fancy or intense with it yet. So far it seems to behave pretty much as with Big Sur. Same as with SpectraLayers 8 Pro, BTW.


Hey Justin, Any update on your M1 Max laptop and Wavelab?

Unfortunately not yet. When the laptop arrived the Magsafe charger would only work to power or charge the computer when I was logged out.

Apple made me send to a special place for them to analyze that issue and I’m back in line for a new one that arrives late December. Hopefully I’ll know more then.

Hi, there will be an official statement regarding OS 12 Monterey- compatibilty very soon.

I updated my computer today to Monterey. So far I only opened the previous project which opened fine. When playing back there was at first a glitch each time the playhead advanced to the rightmost corner and the wave file view needed to be refreshed. After zooming out and then zooming in again the glitches were gone.

Decided to see how the Softube Tape plugin behaves in Monterey because previously it has worked somewhat sluggishly but got better with Wavelab 11. Well, adding Tape causes an immediate crash of Wavelab (it seems that Softube plugins are not yet compatible with Monterey, checked their website).

It turned out that I had outdated versions of Softube plugins installed. It seems that they have dropped the support for Gobbler app (well never liked Gobbler much anyhow). I had checked in Gobbler once in awhile and all plugins seemed to be uptodate but were in fact not.

After installing the Softube Central and updating the Softube plugins to the latest versions, also Tape works again in Monterey and does not crash Wavelab.

1 Like

Im working since last week on new Macbook pro M1 Pro/Monterey. and all is working fine.
I’m making some test at home and studio . At studio inserting my analog gear with external FX and no problems .At home right now mastering ITB session @88.2khz Using Weiss suite and other bigger plugins even with oversampling @16x on Fabfilter limiter as final plugin. ( I cannot use oversampling in my old MacBook Pro 2015@ 48 kHz projects ).
I recommend to upgrade to 11.0.20. At least in my MacBook Pro this version works much better than previous 11.010.
Good performance considering that most of Softube and Wavelab are still not M1 chip full optimized