WL 9.5.15 pro - masterrig & audio stutterring

Hi. Windows 10 64bit. Just installed WL 9.5.15. As soon as i load the Masterrig, basic setup with only EQ active, my audio signal stutters. Without it no problems, like f.i with Ozone …

Are there any Windows 10 graphics updates necessary? I updated to the latest AMD Radeon drivers, BASIC only, and also those for my RME USB audio interface. I used to work with WL 9.1 and ASIO latency as low as 64 samples. Now even 512 won’t do the job. Cubase 9 runs fine BTW, 64 sample latency. -F

you should use a latency or at least 256 samples.

Hello Philippe. Thanks for your quick reply. Even set at 1024, rebooted, (and also at 512) the same stuttering happens, but only with Masterrig open. I checked again for AMD Radeon driver updates, windows updates, and directx (v12.) It must be some graphics issue, or with Visual basic (?). As said Cubase 9, wavelab 9.1, and lots of other stuff like Adobe premiere runs fine at 64 samples ASIO latency. In my RME there is an option “enable MMCSS” active, i always left that activated, and switched off: far worse stuttering also there without the Masterrig page open.
Info: https://www.forum.rme-audio.de/viewtopic.php?id=17575.

PS Just tried MME, works OK with Masterrig open, but with an 1.5 second annoying startup playback delay. Unless i address my audio interface (RME- speakers output routing) via MME; then the same stuttering as above …
BTW i just installed another programs’ update that only seems to be happy with WAS audio drivers (and MME), not ASIO anymore. I was told there has been a change in the graphics GUI coding causing that.

Further testing: ASIO4ALL 2.14 is useless, BUT Wavelab 9.1 with Masterrig page open runs smoothly, ASIO selected, and 64 samples latency with my RME UFXii audiointerface (USB) !!!

  • Regards, F

BUMP !

If I follow you, the only problem you have is with MasterRig 9.5.15? Right?
This is a CPU demanding plugin. Have you activated many modules? What is your CPU?

I guess so, as WL loads a lot at first installation, and most for WL unneeded ones even. Thus only with masterrig open and with only one standard (EQ?) module active in Wavelab 9.5.15;
Closing Masterrig, and then playback keeps stuttering.
However with WL9.1 masterrig and 4 sub-modules running loads and plays without problems. Intel I7 5930K, 32GB ram, Asus Pro USB 3.1 x99 mainboard, Freslogic USB 3.0 PCIe card extra with separate controlles for each USB port, one reserved for RME USB only. Regards, F

I don’t know what you mean with “Closing Masterrig”, but just closing the plugin window is not enough. You have to remove it from the MasterSection slot. Did you do this?

I will look in to that … i worked with WL 9.1 on a project, as 9.5 bugs me a little, so i had no time yet to suss out more. Will let you know later …

Maybe it’ll make no difference for you at all, but if you think it might be graphic related and it happens at all latency settings, have you tried changing MasterRig to Generic interface in the main Plug-in Preferences Gen column? No idea if that will change anything, but just a thought.

Hello Bob99. That worked, but without the GUI interface it’s not really an option. However after re-activating masterrigs’ interface again, back to stuttering, and loading more complex presets into Masterrig worsen things … A Q to Philippe: can it be that some Visual basic file is corrupted? For now i’ll be using WL 9.1 -F

I will transmit your case to the person that is responsible for this plugin.

Thnx

Hello Philippe, any news yet? Just reinstalled an older Win10 backup, updated all graphics stuff BTW. Still the same. Once Masterrig is loaded in WL 9.5 stuttering starts, and increases to total full stops. An then when you quit WL the stuttering stays with other playback; Windows media player, VLC, Cubase, Youtube even. My PC Needs a reboot. (Intel i7-5930K, latest BIOS, no acceleration, x99 Chipset, 32GB RAM, Radeon R370 GPU). Running WL 9.5 with Ozone mastering is fin BTW. regs -F

when you quit WL the stuttering stays with other playback; Windows media player, VLC, Cubase, Youtube even.
My PC Needs a reboot.

Your case if pretty strange.
In today OSes, applications are isolated from one another, but at the driver level. This means, if the problem exists after quitting WaveLab, then the problem is in the audio driver. This could mean, the driver “suffers” at some point of a lack of samples (streaming not fast enough, eg. because of a slow plugin). And then has problem to recover from this situation. Well, just a guess… as this is very surprising, as RME drivers are solid.

But something sure, if the problem exists after quitting WaveLab, the problem exists out of WaveLab.

I would recommend addressing this issue to RME tech support, well stating that the problem persists after quitting WaveLab.

I doubt if they’d do anything … the weird thing is that it’s only with masterrig in WL 9.5, and not with WL 9.1 and masterrig. And not with any other software on my system.

So IMO it must be graphics - driver related. Thus DirectX v12 & AMD Radeon drivers and the GPU load from Masterrig.

I kept checking for firmware and drivers from RME almost weekly to see if there are changes. Nothing for a while now. With older Radeon drivers i had a similar situation last September after some windows update. That was gone after installing AMD’s latest updates, seemingly all DirectX 12 related.

For now I’d rather expect something to do with (in-correct ?) programming regarding the masterrig plugin’s GUI in WL 9.5, to do with my hardware maybe. Something that sets acceleration active or some gamer’s mode in relation to USB? This as RME suggests for USB audio that one should switch off all gaming stuff etc. and use basic drivers only, thus in relation to USB audio stuttering. Seems worse with NVDIA hardware. I just did a windows cleanup, and cleared all AMD drivers before a reinstall of the newest (again).

PS i run Cubase pro 9.0.30 (as 9.5 seemingly has GUI problems too according the Cubase forum here), at 64 samples latency and with a load of plugins with no problems. Regards, F.

I doubt if they’d do anything

but maybe they can suggest something.

OK i will mail them, thnx F. PS i PM-d a copy of my mail to RME.

Hi fiddler2007,

does the problem still exist, when you

  1. deactivate the EQ module in MasterRig (click on the little cross in the top right corner of the Equalizer A module tab), so that no module in MasterRig is loaded

  2. with loaded EQ module deactivate drawing the EQ-curve and/or deactivate drawing the frequency spectrum in the settings window of MasterRig
    (click on the gear wheel icon above the display in MasterRig)

before you playback anything in Wavelab ?

Regards,
Andreas

Hello Andreas.

Started wavelab 9.5 with Mastering, the default 4 modules active.
WL played back OK for about 2 minutes, then slight dropouts started with an interval of around 8 seconds.

Then i tried your suggestion. 1) No difference. 2) Without the drawing functions it seemingly improved a little, less dropouts.
Switced off all modules clicking on x. Still stuttering.


But then when i reloaded Mastering with the 4 modules back on, stuttering increased.

Then after activating 2 channel drawing, the stuttering was all of a sudden full blow, as experienced before.

Pieces of audio of about .20 sec duration alternating with about 1.5 seconds silence. The audio file plays back from the place from the stopped position.
I begin to think more and more that there’s some WL related code from Masterrig interfering with Windows graphics or audio processing, and destructive in memory.
This as i then have to reboot my PC to get rid of the problem, as all other audio software stutters in the same way after closing Wavelab 9.5:
Cubase, Windows media player, VLC, anything.

Thus THIS ONLY HAPPENS WHEN WL 9.5 with Masterrig had been loaded first.

Normally on my system Cubase 9.0.30 works OK with a lot of plugins and an (RME) latency of 64 samples only. The same for WL 9.1 with Masterrig loaded.

regards, F

Thanks for trying this out.

The default of MasterRig is only Equalizer A. May be you saved your own preset as default.

Could you please try the two options, I wrote above, after a fresh start and NO playback before making the settings.

Andreas