WL does now show whole audio when multiple files are open

In “Audio File editing preferences -> Editing” I have “Whole Audio File” checked. If I open single audio file, it is displayed entirely as expected. However if I open several files at once, only the first audio file is shown in this “View all” ratio. I consider this to be a bug - if not, how can I make WL to always display whole audio file(s) on first opening?

I think it works fine, but there is a setting that has precedence over the overview option: the zooming of each file that was open in the past, is restored.
If you don’t want this, uncheck the option “save view settings in companion file” (care: when this is off, master section preset per audio file, is not saved either).

The “Save view settings in companion file” option works fine e.g. if I re-open audio file (which I previously opened and zoomed to some particular ratio), the zoom ratio stays as intended.
The problem is with new fresh files which I open for the very first time (in my original post I mentioned “first opening”) - in such a case only the first audio file is zoomed to full - all the others are not.

I will do more tests on tomorrow, but from my laptop here, no problem.

Just tried again - happens all the time (both for drag & drop and Open file menu).
To clarify the only correctly zoomed file is actually the LAST one (not the first one) in other words the one which is displayed once the process of opening is finished.

(contrary to your notebook scenario I have dual monitor setup - just an idea)

All is fine here. I open 7 large files, 7 tabs open. Each time I select one tab, the peak overview is rebuilt and the whole audio file is displayed.
As mentionned before, if the “Save view settings in companion file” is checked, as below, the old zoom is restored. Trying unchecking this option to see if that make a difference. Maybe you opened these files a long time ago.
Another test you could do, is to copy your file in a new folder, without any companion file (in that way, old settings won’t be restored).
2012-01-02_07-34-23.png

Unchecking “Save view settings in companion file” (keeping Whole Audio File checked) does not make any difference for first opening of files - still only the first one is zoomed to full (well almost - hitting CTRL+DOWN shrinks it a little bit) and the others are zoomed out way too much (see the screenshots - I tested with 3 files of the same length). This is the very same behaviour I get with companion files enabled (on first opening).
01.jpg
02.jpg
03.jpg

I see what you mean now. WaveLab makes sure that the zooms shows at least the whole wave. But apparently, it can show too much after the whole wave. I note to fix this in the future.

Good, thank you.

One more thing I observed. I enabled the companion files back again and as I can see WaveLab does not remember the exact zoom state of all files. I opened these 3 example files, hit CTRL+DOWN on all of them so they looked like this:
01 zoomed to full.jpg
02 zoomed to full.jpg
03 zoomed to full.jpg

Now if I close the files (Tabs -> Close All) and drag & drop them back to WaveLab, only the 2nd file preserves its zoom ratio (file 1 is zoomed in, file 3 is zoomed out). Kind of weird, isn’t it…
01 re-open.jpg
02 re-open.jpg
03 re-open.jpg