WL Elements 8.0.4 WON'T EVEN START in Win 8.1 64bit Asus


Windows 8.1 64 bit, Asus laptop AKG55 with Intel Core i7-3610QM CPU @ 2.30 Ghz, RAM 8 GB, SSD hard disk. Windows is Finnish language version.

Wavelab Elements 8.0.4
Problem: The WL Elements software won’t even start. Timeglass spins awhile, then dies away, then happens nothing.

Did this:

Created a restore point. (Call it intuition…)

Then installed said WL Elements 8.0.4, registered it with that software key thingie (so licence resides on hard disk, not in a plastic usb-stick.)

Did the moves that should make Steinberg and the licence controlling software and the WL Elements software and everybody and their uncle aware of each other and of the proper licence code’s existence.

Then double clicked the desktop icon to run the program.

Waiting, waiting, timeglass spins, then just dies away.

Then tried to run the program from its original location. Same difference. Not starting - meaning nothing else than sta timeglass is visible at any given point, no Steinberg logo, nothing.

Read a lot of forums. Someone somewhere seemed to have had an identical issue which he solved with friends’ help - alas he did not tell how.

As I had other stuff to install and did not want to have a non-working Wavelab Elements issue residing “on the bottom” I restored the laptop to its pre-Wavelab Elements state. That is where I am now. So to be clear: WL Elements is not installed now.

Could someone who really might know what this is about, give me a hand. Before being any wiser on the issue I am not too keen just installing the software and then messing with half the registry following someone’s guesses what might or might not work - without myself understanding anything about Windows registry. And I know more about African clicking languages than I do about Windows registry.

So help from Steinberg, or someone having clearly solved same issue or knowing otherwise what this is about, or having a pretty good educated guess would be greatly appreciated.

I can, of course, provide the relevant program keys via email to Steinberg support if that is needed. FWIW, the PC has an SSD, not a “regular” hard disk.

Thank you for even a little bit of help, even if you can’t just solve it outright in an instant.


You must remember that this is a user-to-user forum and not Steinberg support, who you should contact directly.

That being said, while I can’t offer a solution, if it’s any help I can tell you that I have WLE 8.0.4 working perfectly on a Windows 8.1 laptop, but in 32-bit rather than 64-bit. The only problems I’ve ever encountered with any Steinberg products not running have been to do with the eLicenser software, so make sure you always have the latest version installed, rather than the version that comes packaged with the software. Any time I install a product or a product update, I always then go to eLicenser.net to download and install the latest version.


I think I have done that, updated the eLicence to its latest version, when or after registering the product.

I have Wavelab elements installed in Mac and working there just fine.

Installed it earlier than tried the Windows installation which failed. (And which was removed via the restore point thingie.)

And I have a right to have Wavelab Elements installed in two machines.


When I look at my licences in My Steinberg, I see only one registered licence for Wavelab Elements, but oddly enough the registration date is that of the Windows machine - which was later than my (fully working) installation in Mac. So the fully working Mac installation date does not show at all in the registration list. Figure that.

I thought this was Steinberg support.

I suppose its address is on Steinberg pages, have to go there tomorrow, now need to hit the hay as cant keep me eyes open.

Thank you for the hint to check the eLicence version, though!


Were you able to get your Wavelab Elements to start on Windows 8 64 bit. If so, what did you do to make it work. I put a support request into Steinberg last week sometime, but still have heard nothing from them. Any help would be appreciated.

No. This is a user forum where we are lucky enough to have the developer contributing.


SOLVED: The Steinberg support team was able to provide a special download for a version of the 64 bit Wavelab Elements 8 that installs correctly after uninstalling the other version. Thanks for the help in diagnosing this.