WL not remembering path of last opened montage file

In the recent past, when I went to open a montage, the browser within Wavelab would start at the last place I opened a montage from which is ideal to me.

Now when I go to open a montage, WL always starts at the “Documents” folder on my OS disk and doesn’t remember the last place I opened a file from which is usually one of my external SSD disks connected via Thunderbolt.

Is there a setting I’m overlooking so that WL will always start at the last used path when opening a montage, or maybe a preference file I can delete and start fresh (without losing my important prefs)?

This isn’t a big deal for a one time opening, but some workflows require that I quickly open and close over 20 montages and having the WL browser revert to the “Documents” folder each time means lots of extra mouse clicks.

OSX 10.10.3

Look in menu Options > Folder.
Independent settings in wave and montage.

Thanks. I remember setting these some time ago but maybe the setting is broken because even though I think I have it set correctly, when I try to open a montage, Wavelab still just goes to the “Documents” folder. The behavior is the same on both the edit and montage side.

I’ll attach my settings and what happens after I choose “open”:
Folder Setting.png
Open Command Results.png

What you show on the picture, is the setting to open montages, not waves.

Yes, my original question was about opening montage files.

In the past, I would open a montage and close it when I’m done. Then when I press “command+O” to open another montage, the WL browser would already be set to that same folder as the last montage I opened so I could open the next montage folder in line.

Now when I press “command+O”, the WL browser goes to the “Documents” folder on the main OS drive.

My goal is to have WL remember the path of the last opened montage when I press “command+O” to open a montage. I am quite sure it was possible before.

This only happens to me on Windows when the last montage or soundfile I opened, I opened from a “recent” shortcut or menu. Otherwise it works as expected. Is this on Yosemite?

This is on Yosemite. I’m not sure if it’s Yosemite related but up until recently, my settings were set so if I went to open a montage using File>Open, Wavelab was already looking in the last folder I opened a montage from which is usually ideal. Much more ideal than the “Documents” folder which is not even on the same hard drive as all my audio projects/montages etc.

Also before, if I went to “replace audio file…” in a montage, Wavelab would know the folder path I last used, making it quick and easy to replace say 12 files in a montage as I had to do to populate instrumental versions of a mastered album in a new save as… montage.

Now, there is so much extra navigating and clicking because for open montage and replace audio file… Wavelab always starts at the documents folder on the OS drive.

Changing the settings yesterday seems to have altered behavior slightly but it’s still not like it used to be.

So here is a weird thing.

This morning I had to replace 10 songs in a montage with updated files. When I first went to replace a file, the WL browser opened the folder I was in yesterday which seemed normal. I just had to find the folder for the new project and carry on.

I started replacing audio files in this other montage and after doing the first song, Wavelab browser kept defaulting to opening the “Documents” folder (annoying), so I did 2 or 3 songs and closed Wavelab.

After reopening Wavelab and continued doing what I was doing, then it worked as expected. Selecting “Replace Audio File…” kept opening the correct folder right away, the one that was last used.

I thought this might work because it seemed that closing Wavelab yesterday caused it to remember the last folder I was in rather the the “Documents” folder.

I’m surprised that someone else on Yosemite hasn’t corroborated this yet. But since it’s kind of an obscure thing that someone might not notice, and it doesn’t happen 100% of the time (?), maybe that’s the reason. Does seem like you’re getting obscure new issues in Yosemite you didn’t have in Mavericks with WL 8.5.20 (??) I’m still afraid to upgrade to Yosemite but maybe I’ll just take the plunge to see what I get.

Generally speaking Yosemite has been pretty stable and enjoyable. It’s nice having my personal laptop and studio machine on the same OS version so I can take advantage of some of the newer non-audio related features.

It’s mostly smaller things that I’ve noticed. That and the GUI for WL 8.5 if you use the “OS Version” is a little goofy compared to what it was in 10.9 and earlier. Mainly the check boxes to see if plugins are active or not is sometimes whited out so it may appear that it’s not checked unless you highlight the plugin name and double check. See screenshots.

I’d say definitely no major problems, just small stuff. No more or less than I dealt with on 10.9, just different stuff.
Good.png
Bad.png

Also, this seems to be a global problem in Wavelab. I just added some artwork to a montage. Then I had to add it to another montage and again, Wavelab just opens the Documents folder rather than the last opened or saved folder.

These are my settings:
Screen Shot 2015-05-29 at 3.29.38 PM.png

This is like if you preferences could not be saved at all. Please verify that your preference folder is not read-only.

Philippe

My preferences folder is set to read & write. I’m able to save plugin chain presets to that folder no problem.

Please show me the 4 pages of your folder preferences:
save montage
open montage
save audio file
open audio file

Hi PG,

I believe the attached images are what you are asking for:
Audio File Open.png
Audio File Save.png

Continued…
Audio Montage Save.png
Audio Montage Open.png

I just tested again and for the “Replace Audio File…” process, WL always goes back to the “Documents” folder on my OS drive.

BUT, if I replace a few files in a montage from a certain folder on my audio drive, close Wavelab and reopen Wavelab, then Wavelab recalls the last place I replaced an audio file from on m audio drive as I would expect, and how it normally did before.

So, it’s like that path isn’t getting updated in Wavelab’s memory until Wavelab quits, and then it finally knows the last used path.

Also, likely related to this, I’m finding that Save As… montage files are not staying in the folder the original montage file is located.

In the past, if I did a Save As… it would always default to the same folder as the original montage.

Now my Save As… default folder is sometimes the last used folder.

Something just doesn’t seem right with the folder/path memory for me in WL.

jperkinski, don’t want to get in the way of your progress with PG, but if you haven’t repaired permissions in Disk Utility, you might want to try that. Also since I think you had a write permission problem at one point, you might want to try this home folder permission repair, which I didn’t know about:
http://www.macobserver.com/tmo/article/os-x-repair-home-folder-permissions
Unless it’s too risky or someone had a bad experience with it. I’ve read it doesn’t reset password unless you specifically change the password in the dialog. Maybe PG has an opinion about it.

Hi Bob,

Thanks for the info. I do repair disk permissions regularly but maybe I’ll try the home folder repair.

I just did a fresh OS X install and things are running great other than this, so I’m hesitant to do anything major that might cause other issues but perhaps it’s worth a try.

I’ll wait for PG to offer any input.