WL sample header gain mangling

I used to have this problem with WL7 all the time, but I though it was fixed in WL10 - until today. All I did was adjust a loop in WL10 and save the file. The file is a 24/44.1 AIFF file. When I loaded it into Halion and hit the keyboard, I was greeted with one of the most insanely loud sounds I’ve ever heard. I have no idea how my speakers are still working. At first I thought the file had simply gotten corrupted, but it didn’t sound like a burst of noise and it still worked fine in WL. I loaded the file up in Myriad to see if it also played the file alright and immediately saw the problem. The gain field in the header had been changed from 0dB to 115dB! So, I looked at the Sample Attributes in WL and – there is no field for Gain. Huh? Why not? I loaded the file into Halion again and sure enough, it had added 96dB of gain (probably its upper limit) to that sample.

This is ridiculously dangerous. How can it be that a Steinberg wave editor that has features for sample editing doesn’t work correctly with Steinberg’s sampler? The Gain attribute is one of the things that Halion saves and reads. If I export a sample from Halion to WL for editing, I expect that Gain setting to be exactly as it was when the sample was loaded into WL when it comes back from WL. Otherwise, my sample levels are changed. And under no circumstances should a wave editor be making changes to the header sample attributes unless I change them myself.

I attached the original file and the one WL made with the 115dB gain setting so we can hopefully get this fixed. I’m still trying to find what’s left of my hair…
Piano WL gain mangle.zip (1.69 MB)

I will look at your sample soon. But I recommend you to avoid .aif file and use .wav instead, which has a wider support and compatibility. Do you meet the same problem when using .wav? And what is the motivation of using .aif?

This project is for Yamaha, your parent company. They want the samples in .aif format, so I need a wave editor that is reliable with .aif files. If you can talk them into using .wav files, I’m good with that. But, wait a minute - are you saying that the Gain parameter is available as a sample attribute in .wav files in WL? That would be helpful.

Very possible that you know that already, but by opening the “Import Samples” via the context menu in the program tree you can decide (select/de-select) if metadata like loop-, tune-, gain-, … settings should be imported or not.
Not the best workaround but at least there is one.

best regards

The problem has now been identified and fixed for 10.0.30

Thanks Gerrit. Yes, I know this, but in the case where I’m using WL to edit a sample, I’m usually using the Replace Sample command to put the edited sample in place of the pre-edited version. Still, thanks for reminding me that this workaround is possible.

Great! I thought this would probably be an easy fix. Thanks PG!