WL10 resource-hungry ?

Not a good start with WL10 for me. It can’t play audio montages from WL9: massive glitching, even with ASIO Guard set to maximum. Audio Processing Load is maxed out at 100% with the montages open, even when all FX disabled :open_mouth:
Despite the issues I raised 18 months ago on this thread https://www.steinberg.net/forums/viewtopic.php?f=244&t=119729&p=738883#p738883 I was able to work with montages in WL9 as long as I solo’d the track, but in WL10 that doesn’t make any difference. Not usable for me right now unfortunately.

Try to change your audio card asio block size to 512 or 256, but don’t change the ASIO Guard setting.

It’s already at 512

The performances have been measured better than in 9. Are you observing the opposite?
What audio device?

Yes, much worse: it’s unusable. I’m running RME HDSPe AIO. Use Cubase 10 on same machine daily without any problems.

How many tracks, what plugins, what sample rate?

24/48, 8 tracks but only one playing at a time. Each track has about 8 TrackFX on it and then there are two plugins on the master bus. I’ve disabled all FX everywhere and it still won’t play properly - meter is amost permanently at 100% even without any FX

Hi Richard
I use the same card with 512 buffersize and Asio guard set on 10 ms.
Works here flawlessly.
I dont have release driver enabled


Steven

But are you using it the same way as me ? I can play a single file, for example, no problem. But the performance for Audio Montage is much worse than 9.5, to the point where I can’t use it

I use it mostly in multitrack setting with several plugins. No problem at all

I did try what you suggest, Steven, and it did reduce the CPU load. Which is surprising to me because WL is partnered with Cubase. Here I am saying that the two programs need to compliment each other and, releasing the ASIO driver from WaveLab and returning to Cubase is something that happens quite a bit in my process. Your suggestion does improve the CPU usage, but I still have to ask why, suddenly, should this driver release create a problem when it has always worked before? Too, come to think about it, why should this feature even exist if it cannot be used?

I have since sorted my issues by turning off the Resampling function in the Master section. CPU is minimal with all my plugins and the visual jumping of the cursor and wave files during ‘play’ has stopped. I also was able to click on the ‘Release driver when WL is in the background’, something I have always done before.

To me in C10 and Wl9.5 (maybe also Wl10) the Asio Guard jumped in too quicky to protect.
Consider in preferences to tame it down a bit, and you might have way more asio room and less stuttering.

I have noticed that the plugins cause a great deal of resource usage. Once I have rendered, I remove the plugins and the gauge drops significantly.
LP

I’ve been playing around with WL10 (on a Mohave 10.14.6 system) the past days a lot and could sort out a couple of plugins that drew considerable amounts of cpu. One of the worst is the MAAT DR Meter MkII (v1.6.12), which is parked on my master section and has been a reliable source of information all things loudness to me. All is fine in both Logic and WL 9.5, but in 10.0 it’s a serious hog. The all new processing-load meter unfortunately was not much help sorting that out.

PG - I’m the original OP of this thread and haven’t managed to get WL10 to play the same Montages that worked in WL9. What do you suggest - should I open a tech support ticket at MySteinberg ? Maybe sending the Montage files would prove helpful.

Some stuff has already been improved for 10.0.10
But I would be interested to know what plugins are used in your montage and where, clip, tracks…

I’ll try 10.0.10 when it’s out and see if it’s an improvement for me.

For now, all my plugins are at the track level and are mostly Plugin Alliance VST3’s

Now on 10.0.40 and WL10 is still dreadful performance for me. Even at 512 samples just a couple of tracks with plugins on each causes 100% audio use and constant glitching. This is with an i9 7900x and RME HDSPe AIO. I tried the built-in audio card and it was the same level of performance.
At least in WL9.5 I could solo the track I was working on and that would lower the CPU use, but in WL10 soloing makes no difference!! Now you have to mute every single track to get the same release of CPU usage as you used to be able to get by just soloing the track you were listening to in WL9.5.

The basic problem is the same one I have been complaining about here for literally years: if you have an Audio Montage with plugins on each track, WL processes all plugins on all tracks all the time even when there is no audio file on those tracks. This is with VST3 plugins as well.

So it’s unusable for me right now and I need to get to the bottom of this. What can I send you so that you can take a better look at this ?

I also sense that something isn’t optimized correctly for WaveLab 10 and MacOS. It’s hard to gauge because at my studio where my pretty powerful iMac Pro is, I don’t push the CPU as hard because I’m mostly relying on REAPER and analog gear, and the WaveLab montage has very little plugins running when I use WaveLab. So everything seems fine there.

At my home setup, I rely 100% on plugins and it’s quite easy to overload the maxed out 2018 Mac Mini that I have when using WaveLab at 96k. I had to get an eGPU to make it usable. I don’t think the lack of proper GPU on the mini is the source of the problem, I think that it’s something with WaveLab but offloading the graphics to the eGPU makes WaveLab choke less easily. So for now, that is the fix.

It’s to the point where I’m about to get a new Mac Pro for the main studio and move my iMac Pro to the home setup because I can’t handle the fan noise of the eGPU, and putting it in an enclosure makes it get really hot, and even then, the Mini chokes a little easier than I’d expect.