WL11 Issue - Waves plugins not scanned correctly - SOLVED


I have to renew this issue that was part of this earlier topic:
[WL11 - Missing Supervision plugin]

I still have problems in WL11 when scanning Waves plugins.

I just did a clean uninstall and reinstall based on input from Waves technical support and WL 10 and WL 11 automatically scanned the newly installed plugins.
I got these results - WL10 is okay but WL11 is missing the same plugins all the time:

image image

It has been the same result for all plugin detection I have performed the last couple of days.
All Waves plugins are V12 plugins, and I have ignored VST2 plugin folders in the settings, which seems to work okay for both versions.

What I did notice however was that during the detection scan I could see the detection window display all the names correctly of the plugins detected by WL 10, BUT for WL 11 they where never displayed (as far as I could see anyway).
Therefore it seemed that they were not scanned correctly!!

I also forced a full rescan of all plugins and got a sligthly different, but still not correct, result!


  • Is the scan of the Waveshell performed by WL or by Waves applications/code?
  • Is there anything different i plugin detection between WL10 and WL11?
    Any changes in code or functionality that may be the problem?
  • Any other clues what could be the problem?
  • Is it possible that this will be corrected in WL 11.0.10?

I have contact with Waves technical support regarding this as well!



I have just fixed this issue with the help of Waves support!

Apparently when updating a DAW or software version, the Waves Redistributables might get corrupted and the plugins are not scanned properly. So repairing the Redistributables installations solved the issue.

So so for anyone else having same/similar problems this is what I did:

  1. Navigate to:
    C:\Program Files\Waves Central\resources\res\external\Redistributables
  2. Select the folder 2005 and run all the vcredist files appear. In the prompted window, click Repair.
  3. Select the folder 2008 and run all the vcredist files appear. In the prompted window, click Repair.
  4. Select the folder 2012 and run all the vcredist files appear. In the prompted window, click Repair.
    If the option to Restart your computer prompts, don’t do it at this stage.
  5. Select the folder 2013 and run all the vcredist files appear.
  6. Select the folder 2015andUP and run all the VC_redist files appear.
  7. Now, restart your computer.
  8. Launch WaveLab and rescan for the plugins.

In my case I could perform repair on some of the Redistributables, and for some (in 2015anUP) I got installation error, so these were not correctly repaired.
But it seemed to solve the problem anyway!!

So now everything looks okay in both WL 10 and WL 11!


1 Like