WL11 PRO - Audio Connections not remembering selected Audio Device when restarting

Every time I start WaveLab Pro 11 it defaults to the built-in audio and I have to re-select my interface. This has been happening in both 11 and 11.0.10

Does not happen to me in 10.

What audio device? What operating system?

Weiss AF1 and macOS 11.6

This could mean the preferences can not be written, because the folder has no write access.
Preferences are written there, for the audio connections:
/Users/YourName/Library/Preferences/WaveLab Pro 11/Presets/Audio Connections/
Check it, and also, try erasing this folder.

Says the folder has read and write permissions but I also tried deleting that folder. The issue still persists.

Weiss AF1 is FireWIre right? I wonder if somehow the connection of this gets lost with this legacy format.

It would be interesting if you had another interface to at least test this with.

AF1 is FireWire, yes.

Just tested with an Apogee Groove (USB) and had the same result.

Interesting. I wish I could help but in my 10+ years of using WaveLab, I’ve not had this happen before.

Both of my Macs are on 11.6 using both the RME AES card, as well as a MUTEC USB to AES interface.

FWIW. I had an issue where some plugins would not let me save presets and while it wasn’t the direct folder that had read/write issues…I think it might have been an upstream folder that didn’t have full permissions.

It’s a long shot but you might want to make sure any parent folders are not set to read-only.

Everything looks good in the permissions above. And the permissions match my WaveLab Pro 10.0 folder permissions. I’ve even given WaveLab full disk access to no avail.

None of the settings in that Audio Connections panel are being saved upon reopening.

Hi!

This must be a configuration/setting when closing WL 11 then
Why?
I have RME Fireface 800 Firewire over Thunderbolt
working fine with WL 10/11 with OSX Catalina
some settings in the Audio Connections perhaps or!?
I just close WL 10/11 and start again then next time I’m back where I was before…

regards S-EH

Open WaveLab, do your audio config then quit.
Now look inside the folder
/Users/YourName/Library/Preferences/WaveLab Pro 11/Presets/Audio Connections/
(and also make sure the Finder is set to show invisible files).
Do you see a file named “.last” ? This is the file that should hold your settings.

Also, do you have this so:

I have it set to “Independent for Each User” and there are currently three “.last” files in the Audio Connections folder.

What are the exact name?
Are their date recent, like the last time you have quit WaveLab?

Looks normal :roll_eyes:
Once you have set the correct config, and that you play once. If you come back to the audio connection config, do you see the correct settings again? And after closing, can you playback ok?

Yes, the settings seem to stay the same as long as I haven’t closed the app. After I close and re-open the app, everything is back to the original defaults and I have to re-load the correct interface again.

BTW, do you convert your FireWire device to a converter? FireWire is not found on Mac hardware for a while.

Maybe we can try some more advanced diagnostic…

  • launch WaveLab
  • While pressing the Alternate key (press first and maintain), select “Global preferences” from the WaveLab menu with the mouse. In that case, there is a new tab called “Diagnostics”. There you can activate several functions.
  • set it exactly as follows
  • Open the log window
    image

Now :

  • go to the Audio Connection configs, set the stuff you need
  • quit WaveLab
  • relaunch WaveLab
  • Copy the log windows contents, and send it to me

Hi!

Have you made some settings in the Audio Connections
saved this settings and then closed WL ?
What happens now when WL is re-started ?

regards S-EH

Yes, I use a FireWire to USB-C adapter provided by Apple. Works flawlessly in every app, including WaveLab Pro 9 and 10. This issue also happens with a USB portable audio DAC (Apogee Groove) and both of these devices work perfectly and load as default in both previous major versions of WaveLab.

Log contents:

[ 0.104 / 2177676 I default] *** Logging Rules ***
[ 0.104 / 2177676 I default] “LogAudioConnections=true”
[ 0.104 / 2177676 I default] “Log.SystemInfo=true”
[ 0.104 / 2177676 I default] “.warning=true"
[ 0.104 / 2177676 I default] "
.critical=true”
[ 0.104 / 2177676 I default] ".debug=false"
[ 0.245 / 2177676 I default] WaveLab Pro 11.0.10 (build 51)
[ 0.245 / 2177676 I default] Operating System: “macOS 11.0.6”
[ 0.245 / 2177676 I Log.SystemInfo] "
** SYSTEM INFO *** "
[ 0.245 / 2177676 I Log.SystemInfo] "macOS 11.0.6 "
[ 0.245 / 2177676 I Log.SystemInfo] "Cache Line Size: 64 "
[ 0.245 / 2177676 I Log.SystemInfo] "Physical Cores: 8 "
[ 0.245 / 2177676 I Log.SystemInfo] "Logical Cores: 16 "
[ 0.245 / 2177676 I Log.SystemInfo] "CPU Packages: 1 "
[ 0.245 / 2177676 I Log.SystemInfo] "RAM: 32 GB "
[ 0.245 / 2177676 I Log.SystemInfo] DSP Performance Index: 1.96585
[ 0.245 / 2177676 I Log.SystemInfo] "*** SCREEN INFO *** "
[ 0.245 / 2177676 I Log.SystemInfo] "Num. Screens: 1 "
[ 0.245 / 2177676 I Log.SystemInfo] "Virtual Desktop: false "
[ 0.245 / 2177676 I Log.SystemInfo] "Primary Screen Index: 0 "
[ 0.245 / 2177676 I Log.SystemInfo] "HDPI Var option: true "
[ 0.245 / 2177676 I Log.SystemInfo] "*** SCREEN # 1 "
[ 0.245 / 2177676 I Log.SystemInfo] "Name “Color LCD” "
[ 0.245 / 2177676 I Log.SystemInfo] "Physical Size QSizeF(345.26, 214.837) mm "
[ 0.245 / 2177676 I Log.SystemInfo] "Refresh Rate 59.9404 "
[ 0.245 / 2177676 I Log.SystemInfo] "Pixel Ratio 2 "
[ 0.245 / 2177676 I Log.SystemInfo] "Logical DPI 72 "
[ 0.245 / 2177676 I Log.SystemInfo] "Physical DPI 113.25 "
[ 0.245 / 2177676 I Log.SystemInfo] "Geometry QRect(0,0 1536x960) "
[ 0.245 / 2177676 I Log.SystemInfo] "Avail geometry QRect(0,25 1536x935) "
[ 0.245 / 2177676 I Log.SystemInfo] "Virtual desktop including it QRect(0,25 1536x935) "
Warning: [ 2.244 / 2177676 W qt.qpa.fonts] QCoreTextFontDatabase: Found no matching fonts for family “Rex Bold”