WL12 Batch Convert Dual Mono to Stereo (Not Working)

Hi there. Apologies for bringing up an old topic, but…

Upon importing files into WaveLab’s Batch Conversion utility, it doesn’t convert Dual Mono files to Stereo.

File names:
OH 01_L.wav
OH 01_R.wav
OH 02_L.wav
OH 02_R.wav
OH 03_L.wav
OH 03_R.wav
OH 04_L.wav
OH 04_R.wav

My settings are:
Type: Wave (Microsoft)
File ext.: wav
Audio Format: PCM (uncompressed)
Channels: Stereo
Sample Rate: 48 000 Hz
Bit Depth: 24 bit
Meta-data: Inherit from Source File

Do I have a setting incorrect? Help would be greatly appreciated, as I have a lot of files to go through and don’t want to have to reinstall an old version of Audition 3.0 to do it manually. That process is slow as heck!

Thanks, Jim.

Did you check this? It works here (WaveLab 12.0.20).

image

Hi Philippe,

I think I may be using the incorrect window. I’m trying to convert using the “Batch Conversion” utility which doesn’t have this option. I can’t find the window you have up there.

Cheers.

The option to open dual mono is enabled:
image

And this is what it shows upon importing files with _L and _R suffix:

I presume they should show something like “OH 01_L.wav | OH 01_R.wav” on each line instead of having them all separate?

Ah, I’ve just discovered the “Batch Processor” window! My bad. I had no idea this even existed. Apologies for the post!

Thanks again for your help Philippe. Really appreciate it.

1 Like

Just a quick followup, now I’m processing files.

First issue:
Some files do not detect as dual mono. i.e. Raum_01_L.wav and Raum_01_R.wav do not detect. All others (02, 03, 04) detect as dual mono and show correctly in the list. It’s ok. I used an old version of Audition 3.0 to sort these ones, so no big deal. I don’t know what the bug is, though. Perhaps something to do with dual mono file name detection.

Second issue:
When files are run through the batch processor and the output is set as 48000 24bit Stereo, the resulting files are stereo interleaved but the audio in them is monoaural. It appears the Left and Right audio isn’t being merged correctly. Perhaps it’s only using the Left audio and just copying it to the right to make a “stereo” file but with no stereo information in it.

I have taken two mono files and renamed them what you describe, and there is no problem.
Maybe a typo in one of your file names?

Hmm, yes I can reproduce. But this is less serious than originally thought because there is a work around: have this option checked (the bug is that this option should not affect, on or off, the batch processor.