WL6 crashes when Level Meters in Record dialog have run back

Hi Philippe Goutier,
hi WaveLab R&D team,
hi everybody,

I found out that the Record Dialog within Wave Lab 6.1 (at least 6.10 (build 340)) causes a total crash reproducible under the following circumstances (software+hardware see signature):

  1. The VU meter in the Record Dialog --> Level Settings --> VU-Meter --> Ballistics --> RESOLUTION is set to a short time, e.g. 10ms or 20ms - as it is by default in the original standard settings.
  2. The Recording is made through a DIGITAL input (e.g. RME HDSP AES-32 AES/EBU input or RME HDSPe AIO S/PDIF optical or coaxial input).
    For the problem described below it makes no difference whether you use ASIO or MME-WDM inputs and outputs (always the lastest stable drivers for ASIO or MME-WDM)!!
  3. The Peak and VU meters in the Record dialog are enabled and are excited at least once by any short or long audio signals.
  4. Then the digital SOURCE is stopped or at least paused for a while or it just delivers no audio signal for a longer time - but it still delivers stable sync signal at the same sampling rate as before! [two of my DAT recorders also send mute flag then but not all of my digital sources do and this is NOT relevant to the problem described below].
  5. WaveLab’s recording process is not stopped directly (neither by manual click on stop button nor automatically) but is still running straight ahead and the Peak and the VU meters finally run down to negative infinite dB…

… THEN Wave Lab 6 (at least 6.10 build 340) crashes consistently! The program quits without any error message and even delivers no obvious errors if the crash is watched by Process/File Monitor from Sysinternals, the recorded wav file is not written properly.

What I particularly found out is: The crash will always occur under the conditions no. 2-5, even at much longer VU resolution times! The time WHEN the crash will occur is directly dependant on the time set for the VU meter resolution: If this is set to 10 ms the crash comes immediately, if the VU resolution is set to 100 ms the crash occurs after about 15 seconds, if it is set to 200 ms the crash occurs after about 30 seconds, if it is set to 1 s the crash occurs after about 2’30" and so on. This seems to be a bug!

The error does not occur when the level metering is deactivated in the Record Dialog.

Having the level metering activated it seems as if the crash is NOT directly dependant on the VISIBLE Peak/VU condition but on the INTERNAL LEVEL MEASURING PROCESS BEHIND IT - it seems that the crash occurs when this internal process gets the information that the Peak and the VU have finally “reached” or negative infinite dB - or let’s say a “no audio signal here” status or digital mute status.

The uncomfortable WORKAROUNDs are:

  • to disable metering in the Record dialog (it’s really not what I expect from a professional audio software),
  • to set high VU Resolution Times >1seconds AND to BE PRESENT to stop the recording by clicking the STOP button before the crash comes up,
  • to calculate the length of the recorded audio with an exactness narrower than usually practicable and to preset the duration when the recording shall stop.
    The problem occurs very often when I copy DAT tapes and Mini Discs from our broadcast archives: For the DATs I don’t have the time to check their length before. And sometimes they contain longer passages with sync but empty audio so that the stopping-by-timer and the stopping-by-level lead into either crashed or incomplete recordings. I’m always present during the copy actions
    So this bug really and strongly impedes my daily work!

This behaviour shows at least under all my Windows XP versions (two computers with XP Pro SP3 and and one older P4 machine with XP Pro SP1).
Considering the posts mentioned below this crash scenario seems to occur also under Vista or Windows 7!!

MY URGENT QUESTIONs to Philippe Goutier and the R&D team:

  1. Can you reproduce this behaviour? (I could at least on three different PCs, some other users seem to have the same problem, see links below)
  2. Could you PLEASE still fix it for 6.10 or 6.11? Or have you perhaps already fixed it in 6.11?
    (I hesitate to install this version on my XP-Pro-SP3 systems because WL 6.11 is not fully supported!)
    Or does WL 6.11 work reliably under XP-Pro SP3 by now?

I would be very happy to get good news from you soon!


This issue or the problem was mentioned in these topics, too:
http://forum.cubase.net/phpbb2/viewtopic.php?t=85213 see post of bob99 Sun Aug 09, 2009 7:07 am
I decided to post a new topic because the subject lines were much too general.

WaveLab 7.00 (build 506)
WaveLab 6.10 (build 340)
Cubase 5.1.1 (Nov 23 2009)
Windows XP Professional SP3 (PC 1+2), Windows XP Professional SP1 (PC 3)
All Windows settings carefully tuned for pro audio. All drivers carefully selected.
Audio hardware:
RME HDSP AES-32 (PC1), RME HDSPe AIO (PC1 and 2), RME HDSP 9632 (PC3)
PC hardware (three computers):
Mainboards: MSI P55-GD65 (PC1+2), ASUS P4C800-E Deluxe (PC3), each with most stable BIOS
CPUs: intel Core i5-760 / i5-750 / Pentium 4, 2.8 GHz
Memory: Kingston 4GB RAM, models exactly as recommended by MSI/ASUS
Graphics cards: ASUS Radeon 4350 (PC1+2), ATI Radeon 9600 (PC3)
Power supplies: Enermax Pro87+ 500W (PC1), bequiet BQT7 350W
Hard disk drives: Samsung HD103UJ, HD103SI

Still no ideas, fixes? :frowning: