WL7 Elements 7.2.1 doesn't work with CC121

Hi,

although the CC121 is visible and active (under options/remote controller), there is no response in WL7 Elements when hitting a key (i.e. Start) on the controller. No matter how the CC121 is connected (directly to USB or via active hub), there is no response anyway.

With Cubase 6.0.5, the CC121 works fine (both directly connected or via active hub). I have already read some postings about this issue, but didn´t find an answer. And yes, I tried to reboot the system and started WL7E directly without using any other applications. No impact at all.

Used setup:

  • Tools for CC121 version 1.7.2 x64 (with Yamaha USB-Midi-Driver (WDM) 3.1.2 x64)
  • WL Elements 7.2.1 (build 600) 32bit
  • Cubase 6.0.5 (build 357) 32bit

Does anybody has an idea about this issue?
Somewhere in the specs, Steinberg said that WL7 Elements has only “limited” support for the CC121. What are the limitations? I do not assume that “limited” support means “no” support or am I wrong?

Thanks in advance
Ulli

Did you set up your device in menu Options > Remote control devices… ?

Hi Philippe,

yes, the CC121 has been (automatically) selected under options/remote control devices for both input and output with port No.1. That matches with the setting in the driver config window. Of course, the controller has also been activated. All mapping details are visible. But nothing happens when you press a key or turn a knob or move the slider.

Ulli

Just in case, please attach a screen shot of your Remote Control Dialog.

I have WL 7.2.1 and i cant get the cc121 to work either. Description exactly as stated in these posts.

I have no problem setting up a Mackie midi controller but CC121 does nothing and does not respond to setup screens

Sean

Hi,

as requested by Philippe, please find attached a screenshot of the CC121 config dialog showing the selected controller/port and some of the mappings.

Ulli
WL7E_CC121_config.JPG

All looks normal. I must say I have no clue.
Maybe you could clear, even temporarily, your WaveLab settings: quit WaveLab, and erase the following folder:
AppData\Roaming\Steinberg\WaveLab Elements 7\

I renamed the mentioned folder with the WL7 settings. As expected, a new folder has been created by WL during startup. The remote control dialog shows the CC121 as active, but still no response at all.

Maybe there are some WL-problems with the 32/64-bit setup as described in the first posting? But it works fine with Cubase and I guess it should be ok for WL.

If no one here in the forum has any further ideas, I´d like open a support request.

Ulli

Is the CC-121 firmware up to date?

PG

Thanks. Problem sorted.

Sean

I can confirm. After firmware update to v1.50 everything works fine. Thanks to Philippe.

Ulli