WL8.5 (64 bit) and VST2 plugins

My apologies if this has already been covered in an FAQ or other area, a quick search of this forum didn’t uncover it having been addressed here already ?

I have WL8.5 (32 bit) and (64 bit) versions installed in my Windows 7 Professional (64 bit) laptop. The 32 bit version of WL8.5 has installed my large collection of VST2 32 bit plugins (Waves Diamond Bundle, from 2004, and others) and they all open and function well.

The 64 bit version of WL 8.5 will scan the same directories and locates and evaluates these same VST2 plugins, but refuses to load them, and adds them to its “ignore” list.

So… is it simply the case that if I want to use these old VST2 32 bit plugins I can only do so in the 32 bit version of WL8.5 ? I have tried many instances of “Force plugin detection at next launch” as well as listing the directories where these are located (‘Additional VST plugin folders…Wavelab specific’), and while it scans through the listing of the Waves plugins, it won’t load them. In both 32 and 64 bit versions of WL8.5 the VST3 plugins load and display without problem.

Thank you for your help

…and as a PS to the above query, if these 32 bit plugins (VST2) won’t open in WL8.5 (64 bit), is it possible to bridge them via this product: https://jstuff.wordpress.com/jbridge/

Is this known to be a successful way of bridging 32 > 64 bit plugins and allowing them to be used ?

Correct. The 64 bit version of WL REQUIRES native 64 bit plugins. There is no “bridge” or “converter” that magically takes a 32 bit plugin and makes it available for use in WL 64bit.

If you want use WL 64 bit - you have to go all the way with your plugins and leave the old timers behind. Or simply stay with WL 32 bit.

To be honest - there is zero benefit to “needing” the 64 bit version of WL unless you somehow need 10GB of ram for a editing session. I only use it because i only use 64 bit plugins exclusively.

NOTE: I use Waves Silver and few other Waves plugs - and they all have 64 bit versions. Not sure why you would not be able to load “Diamond” in as native 64 bit in WL 64bit.

VP

I thought that’s what Jbridge was for. 32 to 64. 64 to 32. 32 to 32 (for memory limitations). Does it not work in Wavelab? Coincidentally I was going to try it tomorrow.

Yep - correct. But I have never used JBridge - nor will I.

I was simply mentioning that some people automatically assume that every native 64 app out there has some built in ability to “allow” 32bit plugs to be used along side native ones. Like Cubase or Nuendo etc.

However - Wavelab and Studio One (my two main apps) are two of the 64 bit apps out there that do not allow 32 bit plugs to be used at all and require full 64 bit plugins end to end.

But considering almost every major plugin vendor I would ever buy from - has had pure 64 bit plugs as standard for several years now - I do not understand any point to JBridge these days.

I supposed if you have some funky old 32 bit plug that you just can’t live without (or is not available in 64 bit)?

I ditched all my 32 bit stuff several years ago (whether replacements were available or not) and made the move to all 64 bit.

VP

Got it. Thanks Bruce.

I’ll be interested to hear of your experiences Bob99, if your intended usage is similar to what I’ve outlined above ?

Ray, you’ve probably already resolved this, but I finally had time to try and buy JBridge. It seems to work fine, but after I couldn’t initially get it to work (Wavelab would put all the JBridge .64 files in the Ignore List and never load them), I found I had to run Wavelab as administrator, or turn off UAC in Win 7, in order for it to load the JBridge files.

I’m surprised Wavelab 64 scanned and Ignore Listed your 32 bit plugins, because I didn’t get that at all when I first opened Wavelab 64 bit (before JBridge). There was nothing in my Ignore list until I tried to use JBridge.