WL8.5 doesn't have my WL8 settings

Just installed WL8.5 and was expecting it to automatically import settings from WL8 - but it didn’t.

How do I import everything into WL8.5 ?

This update will be a non-event for me if this is true. Hoping there is a logical explanation to this…

VP

I’m afraid I can’t answer your question, but this was my fear as well. Has 8.5 installed itself side-by-side with your existing 8.0.x version? What OS are you on please?

When I installed 8.5 I a prompt appeared asking if I wanted to transfer my settings from a previous install/version. That’s not an exact quote but it was something along those lines.

As far as I can tell so far, all my settings and shortcuts transferred to 8.5 with no problem.

Whew - That’s what I usually see.

But since 8.5 is a new paid “baseline” update - I will assume you could install this as a “new” install - to run along side of an existing WL install - and therefore - you probably would not be prompted for any previous settings to import.

Maybe PG could chime in on the different install options?

VP

I can confirm that I had (and still have) 8.0.3 installed and it asked me to import/transfer settings when installing 8.5.

This on OSX 10.9.2

If WaveLab 8.5 did not propose you to import your old settings, you can do it manually, easily:

On Windows, copy this folder:
“C:\Users[YourName]\AppData\Roaming\Steinberg\WaveLab 8”
to
“C:\Users[YourName]\AppData\Roaming\Steinberg\WaveLab 8.5”

On Mac:
Copy this folder:
“/Users/YourName/Library/Preferences/WaveLab 8”
to
“/Users/YourName/Library/Preferences/WaveLab 8.5”

WL8.5 did not offer to copy settings on Windows 7x64 so I had to copy them manually, which seems to have worked.

Also on Win7x64 so looks like a bug in the installation of WL8.5

Starting to look like the Mac guys are good to go and us Windows guys are not…?

I have yet to install…hoping this goes well.

VP

On Windows 7/8, you can just type “%appdata%\Steinberg” into the search box and press enter, and it will bring you directly to the relevant folder. If you see a folder there called “WaveLab 8”, back it up, then install WaveLab 8.5 and run it once, and exit. Now you’ll have a folder called “WaveLab 8.5” as well. Copy the contents of the “WaveLab 8” folder into the “WaveLab 8.5” folder, overwriting anything found there. Start WaveLab 8.5 and you should now have all the settings inherited from WaveLab 8.

Thanks - but you would think that in the 6-8 months (Or maybe more?) that this update has been worked on - the ability to find and use existing settings would - you know - just happen?

How could testers - assuming at least a few of them were actually using the most popular OS in the world right now (Windows 7 x64) - not catch this?

We shouldn’t have to do a bunch of manual copying just to get our settings straight…

VP

I can now concur. Nothing happened on Win7x64. No prompts to use existing settings.

I was able to get everything back by copying the folders as PG suggests.

VP

the problem is with the installer, not WL8.5.

in this post…http://www.steinberg.net/forums/viewtopic.php?f=189&t=60794&p=365618#p365618
I mention the incomplete install message I got.
And yet WL 8.5 WAS installed. The problem is the installer does not get to the next phase asking if you want to copy settings from WL8.0 to WL8.5.

In the above link see Madsv response, interesting results.
If copying the prefs is the hardest thing I have to do all day…Bring it on.

Later,
Brain

The problem is the installer does not get to the next phase asking if you want to copy settings from WL8.0 to WL8.5.

No. The import setting is a procedure executed from WaveLab, the 1st time to run it. Not from the installer.
To know if something is to be installed, WaveLab looks for this file:

Windows:
C:\Users[UserName]\AppData\Roaming\Steinberg\WaveLab 8.5\Startup.ini
Apple:
/Users/YourName/Library/Preferences/WaveLab 8.5/Startup.plist

Deleting this file is a way to force WaveLab to ask you if you want to import the past settings, if WaveLab finds them. The limit of the system is that WaveLab needs to find the old settings at the default standard location. If you had your settings at a different location, the procedure is not proposed.

My 8.0 settings (AND the .ini file) are exactly where you indicate here - yet the 8.5 installer found nothing. This is a major bug.

VP

I wouldn’t think this is a major bug, but anyhow … here’s something interesting: I had backed up my original “WaveLab 8” settings folder before I installed. Just now, I deleted my “WaveLab 8.5” settings folder, restored the “WaveLab 8” folder, and started WaveLab 8.5 and voilá! It asks if I want to import the setting from the previous version, and it works! So there must be something different happening at the first run immediately after installation.

Well - to me - it’s a major bloody bug if every Windows user worldwide suddenly finds out that they have to manually futz around copying files etc - especially if they do not come here to find out what to do - like ever.

How the heck would Joe Average Wavelab guy ever know to copy these bizarre folder locations?

This should just work - and shows that the advance testing - as usual - is lacking.

VP

Bruce, you’re clearly upset, but all I can say is that, in my case, I’ve spent more time writing stuff on this forum thread that it took to fix the problem. “Joe Average” probably doesn’t use WaveLab, and if he did, he’d probably be on this forum, and would have found the step-by-step solution a few post up by now.

Yeah I guess I was a tad upset since there always seems to be “something” up with every update.

But I am over it now:) It’s Steinbergs problem to tackle.

VP