WL8.5 Lag on Mac OS X 10.8.5

Just upgraded to Wavelab 8.5 and am noticing a significant lag in response in the UI on a Mac OS X 10.8.5 system. Wavelab 8 is running fine.

Anyone have that same issue?

I allowed the installer to copy the WL8 settings, which may be something I need to start fresh with.

For example?

I haven’t been able to do much work in Wavelab today, but the little bit I tried 8.5, something does seem a bit more slower with the responsiveness when navigating and editing clips and regions.

Nothing extremely major, but definitely noticeable.

I’ll have to test more later. 10.9.2

Something has also changed with zooming. With 8.0.3 and earlier, I could easily zoom using command + scroll wheel (left for zoom in and right for zoom out) and the focused area would not change. I can still zoom with this command but it causes the entire timeline view to shift left or right as well as zooming, so when I zoom now it’s very chaotic and not very precise.

Basically, the timeline moves left to right as I zoom in and out. It’s difficult to use now.

I find when working in the montage that Wavelab seems to registe a mouse click even though I’m not clicking, this happens on a regular basis. Maybe this is why it’s scrolling and zooming at the same time.

This is definitely different behavior than 8.0.3 I’m using the same Apple Magic mouse I always use and did not experience thing behavior until 8.5 today.

I hope it turns out to be a setting to solve the problem because it’s now hard to do fast and precise editing in Wavelab.

***I have confirmed that if I do a quick zoom in using command + scroll wheel and then quickly move the cursor over window or tab, that tab becomes selected even though I clearly did not press the tab.

There is definitely some untended clicking happening for whatever reason. It’s almost like if you use the virtual scroll wheel of the mouse, the wheel is still spinning for extra time, and hovering over something in that extra time causes the mouse to click. I can recreate over windows/tabs and even plugin knobs.

Another way to explain is it’s like there are extra clicks left in the mouse cache and if you hover over something soon enough, it clicks it for you even if you didn’t press it.

I think this is causing erratic GUI things. I can no longer work quickly in Wavelab because zooming in and out with the scroll wheel causes simultaneous zooming and scrolling to the left and right.

WL 8.5 64-bit
OSX 10.9.2
Apple Magic Mouse
iMac 27" 32GB RAM

We shall investigate this and if we find anything, we’ll include the fix in 8.5.1.

Thank you, let me know if you need more info. I’m happy to test any beta of 8.5.1 to help see if it’s solved.

It’s bad enough for me that I think I have to go back to 8.0.3 to most editing work, because zooming with the scroll wheel causes the left/right view to scroll too and it is impossible to do editing with any quickness.

I hope this ends up being a setting so I don’t have to wait for a bug fix. I did transfer my settings from 8.0.3 to 8.5 using the prompt in the installer. Do you think a clean install would solve this?

I wonder if any others will see the same problem.

Hello,

I’m afraid this issue is really severe. I’m on OS X 10.9.3 (latest updates) on a quad core i7 15" Retina MacBook Pro with 16 GB RAM and discrete graphics, and the UI lag with the new WL 8.5 is so extreme that it’s virtually impossible to edit. Most of the time when I try to drag a clip edge in the montage, it selects a range instead, even when I wait half a second or so for it to react. Zooming, scrolling and all other UI elements are far slower than WL 8.

It does seem that switching the app to 64-bit mode (select app in Applications folder, cmd-i for info, uncheck “Open in 32-bit mode”) speeds things up, but the above comments refer to WL 8.5 already running in 64-bit mode.

The WL 8 UI was instantaneous, and 8.5 is so slow as to be nearly unusable. May I ask what happened? I love the new features in 8.5 but am afraid I’ll have to revert to 8 until this is fixed.


Kind regards,

Albert

I don’t experience any difference here, compared to 8.0.3.
But I don’t have a retina display. Can you see if some OSX settings could play a role?

Hi PG,

Thanks for your quick reply. I’ll be happy to test any settings. Could you let me know what settings might affect the UI in the update? I haven’t changed anything since WL 8.

Also, I could make a screencast if it would help you debug.


Kind regards,

Albert

P.S. Any update on Retina support for Steinberg software?

I did notice that WL 8.5 usually takes 100% of 1 CPU core, even when idling, whereas WL 8 required little CPU power when idle. Is there perhaps a new background process running that might also be slowing down the UI?

I don’t experience an unusual lag, but i have a very fast iMac and 32GB Ram so maybe that makes the lag hard to notice, something is a bit more choppy than 8.0.3 though I think.

As far as your comment of “selecting a range instead”, I have this problem too.

The best way I can describe it is that the mouse is detecting either extra clicking, or so slow to process the click that it ends up selecting a range, or even able to focus a tab or move a plugin setting. So for me, the clicks are either registering late, additional, or both. It’s most obviously annoying to me when I try to zoom in using the scroll wheel. It does zoom, but also moves the focus to the left or right, which I think is related to delayed or extra mouse input.

It does make it very hard to do most simple tasks that were no problem in 8.0.3

This is something that could be hard to notice if you work slowly, but for anybody that is doing quick or fast editing using Apple Magic Mouse (maybe all mice?) it seems to be a problem. I will try to test on my MacBook Pro tomorrow using both a Magic Mouse and the track pad.

My iMac doesn’t have retina (as far as I know it’s not an option yet on iMac) so I don’t think that’s a factor.

This behavior doesn’t exist in 8.0.3 and earlier.

About Retina, maybe change some options listed there:
http://support.apple.com/kb/ht5266
(just guessing)

For what it’s worth, I’m having similar lag problems and random mouse clicks on quad core mac with 16gb rm. Also when ever I click on a plugin it races to the top behind the tool bar so I can’t move it back manually. It happens with UAD and izotope and fabfilter. It sounds like another UI issue.
Thanks for your work!

Also experiencing the problem with plugin windows racing to to top of screen where they no longer can be moved because the top of the plugin window is inaccessible and cannot be grabbed by mouse. Pretty much unusable at this point so haven’t gone any further with testing. 10.8.5, 12gb ram, 8 core

I experienced the plugin window going out of bounds in 8.0.3 as well, but not very often and I don’t experience plugins racing to the top of the screen on an iMac running 10.9.2. I can’t get this to occur in 8.5 even if I try using a variety of plugins (UAD, Waves, Voxengo) so maybe it’s at least partially fixed.

I do think the lag/mouse click issue is a major concern. I have a new iMac with maxed out specs so the lag may be harder for me to detect but 8.5 does seem to have a slight jitter, very slight but again it could be the new computer hiding some of it.

The mouse click thing is a valid concern of mine and think the lag and mouse issue could be related. I get frequent false clicks (meaning I haven’t clicked but Wavelab clicks anyway) in the timeline when doing basic quick editing resulting in highlighting a selection range that I never actually clicked to select, and sometimes focusing a tab or adjusting a plugin parameter even though I haven’t click the mouse in that spot. It’s as if there are extra mouse clicks and scrolls that are delay or stored in a cache. You must move quick to see it but if I scroll with the mouse and then move over something, that something get clicked.

What’s most problematic for me is trying to zoom in and out using command + scroll wheel. Does anybody else get strange behavior in 8.5 when zooming in and out using command + scroll wheel? In 8.0.3 and earlier, I could do a direct zoom in right to the cursor using command + scroll wheel, but now I get a combination of zooming and horizontal scrolling making it impossible to zoom in close on anything without a lot of extra work.

Something is not quite right.

There’s some mouse problems here too… :frowning:
The pointer disappear some times… The solution is to change to another app and come back and it appear again…

I also had the cursor disappear 1 time since 8.5 but I can’t find a way to recreate the problem.

Yeah I’m also having zoom problems both with hotkeys and zoom wheel. My UAD plugin windows come up blank at times, but whats odd is that the plugin interface without the VST plugin window are sitting behind the blank one. Which means no access to presets. Bizarre

Also having problems with WL 8.5 and OS X 10.8.5.
Mac Pro 3.1.

Scrolling / Editing seems a bit slower but most obvious thing:

Very often while operating WL starts to mark regions (like an automatic mousecklick).
You have to click “again” to stop the selection.

So back to 8.0.3

@ctamp: what kind of mouse are you using?