WL8 Ogg encodes file click at beginning

I just took a wav file and tried to convert it into Ogg at various settings including:

Quality 6
Quality 7
Qualtiy 8
Quality 10
and Average Bit Rate 256.

Every Ogg created by Wavelab 8 has a click at the start of the file as if the audio was cut off at the begining.

The files also have a longer “pad” or “section of silence” at the begining of the file that isn’t there in the original wav and is also longer than Ogg’s made by SoundGrinder. Additionaly SoundGrinder can make the Oggs at the same settings without any click.

So, PG, I’m sorry to report that the Ogg encoding in Wavelab 8 is in need of a fix.


A few quick test don’t reveal any problem here.
What OS?
32 or 64 bit?
Do you have an example file I could try?

tested with a sine tone wav stereo 16 bit, encoded to Ogg format
no silence at the start and no click !
on OSX 32bit
check settings in the Render dialog

regards S-EH

OSX 10.8.3
WL opened in 32 bit mode
Source file = 16bit 48k MONO WAV

Wavelab adds a 20ms gap at the head of the file compared to the original fila dn also compared to Sound Grinder created Oggs at the same settings.

The click is there. Every time. How is this not a problem?

I’ll send a file when I can. RIght now these are proprietary assets so I’ve got to make a test asset for you.

So this gets more strange to diagnose.

My original file I can’t share as its a proprietary asset. It has the ogg issues I’ve described.

So I created a new test asset and it encoded correctly- no extra silence no click.

So I tried reencoding my source asset that originally caused me to start this thread. Again, the Wavelab Ogg encoded version added 20ms at the start and cuts of some of the audio so it starts with a click.

So I’m confused how to proceed. I’ve definetly got a file taht won’t encode properly with Wavelab’s OGG encoder but does encode properly with SoundGrinder. But I’ve also got a new test file that encodes correctly.

Trouble is, I have assets that don’t encode correctly and I don’t know why. PG, how can I help you research this. I can’t share the file that is causing the click as its a intellectual property issue.

Maybe the problem is in the Ogg version itself (different version between WaveLab and SoundGrinder, not given the same result, because the audio file has some special contents).
While experimenting, I have found a problem in WaveLab, though, but this has nothing to see: if I take a mono 48k file and try to encode to 256kbs CBR, this is not supported by Ogg, and WaveLab handles badly this situation, and crashes (under Mac only). I will correct this in 8.0.2.

Thanks for the follow up PG.

I will try to make a test file that I can share with you with the click I’ve encountered. And if I can’t recreate the extra silence and click I’ll report that too.