WL8 steals focus

I just upgraded to WL8 from 7, literally ONLY because the fact that the app steals focus after processing drives me nuts. I figured it would be fixed in WL8, but nope!

You know what I’m talking about, right PG? I’ll be processing a large file, then swing over to my email app and type a reply. The file finishes processing, and all the key presses from my latest sentence are stolen by WL8.

I can dig up the thread, but I know it’s come up before and I believe you said you’d address it. Please do!

I’m on Mavericks.

Brian.

RESONANCE MASTERING
http://www.resonancemastering.com
714-963-3696 (Mon-Fri 9am-6pm PST)

In wavelab 8, from the render dialog, you have the option NOT to open the rendered file. If you choose this, your problem should be solved, right?

That works, but I generally want the rendered file open so I can top and tail it. Opening up the file and bypassing the master section is more work than recovering from the stolen focus.

Is it currently working as intended?

Is it currently working as intended?

Yes. Though here the focus is not stolen when a file is reopened (OSX 10.9 and Windows).

Interesting!

I haven’t worked with any other DAW that will snap you over from the app you’re working in, and slide you over to another space or monitor, when it finishes rendering a file. I guess if that’s what people want, it’s a feature. I find it incredibly frustrating!

Honestly, I wish I’d just stuck with WL7, because there are no improvements or changes that I’ve seen to the way I work. I just figured what I thought was a bug would be fixed by now, and that bug was worth $99 to me, because I deal with it every day.

As always, I appreciate your quick response!

If I remember correctly, WL7 behaved the same way. It also drove me nuts, especially when trying to render many files at one time, especially short files that render quickly. I don’t see the benefits of WL showing each rendered file, that’s the whole point of a background task, stay in the background.

Awhile back I requested that PG to remove that behavior which he did with an option, but he took it one step farther so the rendered files don’t even open in the editor when you select that option. To me, this is better than having all rendered files automatically open and steal focus from whatever you may be doing but i should have been more clear that it’s ok that the rendered files open in edit mode, but Wavelab doesn’t need to show me automatically each time one is done.

Still, I would rather manually open rendered files as needed than have them all open and steal focus, and it helps that any rendered files that you don’t choose to open will still be in the recents list in your edit mode for quick access.

I suppose the ideal situation would be an option to have all rendered files open but not have Wavelab focus each rendered file as it’s finished.

Personally, I’d like the app to just never steal focus. I can’t think of another app that does that! I suppose Notification Center support would be ideal, but that’s a lot of work for a Mac-only feature.

Glad I’m not the only one bothered by this behavior. I just want to be able to render a file, work on something else while it processes, then come back and do fades at my convenience. :wink:

Yeah, I can’t think of another app that does that either. Personally, I do all my fades and edits in the montage so they’re editable and any rendered files are already exactly as I want. I just like to open rendered files occasionally to double check for errors and maybe a final listen without the distraction or temptation of plug-in settings.

I just keep mine set to NOT “open resulting audio file” in the render options and then just open anything manually in edit mode that I want to.

For singles, I just render to 16-bit and do the fades on the resulting file. But for anything with multiple tracks, I do it in the montage as well.

This is not optimal, as for optimum quality you will need to dither twice - once when rendering, and once when adding the fades.

Paul

True! I don’t do it on long fade-outs. Just a few ms at the top and tail.