Working with open time signatures

I have moved from 4/4 into an open time signature (X). When I finish inputting the note series, Dorico insists on adding a two-beat rest at the end. When the rest is removed via designating the last note as ‘ends voice’, playback still observes this time span, though silently, of course. Is there any way I can shorten the bar to end after my last inputted note?

I have a minim in the middle of this passage - the rest of which is in quavers. The minim is not centralised between the two sets of quavers - am I able to move it along a bit?

Thanks for your help.

Try Write > Trim Flow to get rid of the extra rests at the end.

To adjust the position of the minim rest, try using the Note Spacing tool in Engrave mode (though I expect Dorico has actually put it in the right place really!).

Thanks Daniel - this isn’t the end of the flow, though - I’m intending to move to a new time signature. I’ve attached an image of the situation - the problem is for the open bar to end after the last quaver. It’s as though Dorico thinks there should be more beats in the bar than I do! Additionally, in relation to the beaming of groups, is there a way to prevent breaking mid-group at the end of the first staff?


The only reason you have a rest there is because you added the 7/4 after a gap of two beats. If you don’t have anything more written after this, you can delete the 7/4, and re-input it at the right location.
If you only want to delete those two beats without affecting anything that comes later, you first need to make it a separate bar. Select the rest, open the bar popover (shift+b) and input “single”. Next, open the popover again and input -1.

For the second question, maybe you should untick Layout options (cmd+shift+L / ctrl+shift+L) > Staves and systems > Allow open bars to be split across system breaks. Alternatively, you can fix it manually by selecting the first and last note, and using “Make into system” in Engrave mode.

Fantastic, Anders - both problems solved. Thanks you! Interestingly, ‘Allow open bars to be split across system breaks’ is already unticked but the manual solution worked.

Yeah, I forgot the text right below the option which says “The first bar in a system is always allowed to split across a system break if it is too wide to fit within the frame. […]”.