Worksheet. Default Masterpage Without Music Frame

Hi, I am creating a worksheet. I would like to set up one extra page which looks like a default page - I need there flow number, flow name, page number - everything in the same style as all the previous pages. But I do not need there a music frame at all. I would like to put there a text frame instead. What ever I tried to do - create a custom master page based on a default master page and tried to edit it in editor and apply or create blank master page and try to edit as well - I was not able to work out how to do this. Would appreciate very much your step by step help…

Once you’ve created the relevant master page, you need to apply it to the relevant page in the layout – in this case, by inserting an extra page, applying the master page to it, then removing the override. (You can also just add the page using the master page’s template, but if you do this it remains an override and any subsequent changes you make to the master page don’t get reflected in the layout.)

Without a music frame the tokens for flowNumber and flowName will not work as there is no reference to extract the Flow information from. You can use flowxNumber, FlowxName, where x is the flow number, but that kind of makes a general purpose Master Page ineffective.

You might try adding a tiny Music Frame (too small to fit any actual music) but enough to get Flow info from. I have not tried this so I don’t know how it will work.
Edit: It doesn’t work. The Music frame always shows one system no matter how small the frame. I tried adding an empty-handed-player to the frame but then the Tacet indication shows. If you disable the showing of Tacets, then the Flow information can’t be extracted.

Dear Lillie, Craig, thank you very much for your answers. After 2 additional hours I still stuck with this task. I created an custom masterpage. If I try to apply it for the 20th Flow now called “My Issue”, Dorico doesn’t recognise a name and a number. If I write {@flow20Title@} instead {@flowTitle@}, it works, but still not a Flow number even with {@flow20number@}. OK, I could fake it probably writing a number manually, but what if I would like to change a Flow order later?

After I apply my own masterpage called “My”, I am not able to create any other Flows. They just doesn’t appear. If I remove page overrides, I lose what I tried to achieve. I do not still understand, why Dorico doesn’t show all the page numbers. There are at the moment no overrides at all. It seems that a concept to make FlowHeadings with a MusicFrame into one frame couses more problems than solutions.

I will try to formulate my task in one single sentence: I would like to write in Flow20 a text instead of writing music, be able to reorder all existing Flows and be able to create new Flows after this specific page.

Thank you in advanced for any information which could help. I am attaching this worksheet here as a .dorico file (646.2 KB)

I’m afraid without a Music Frame, you will have to manually write in the flow number and title.

The issue with adding Flows (I’m guessing here) was probably due to you using the default option of From This Page Onwards in the Master Page Chang dialog. If you select Current Page Only, then it should work.


You could try the following without the need of a new Template (master) Page:

  1. In set up mode, select the full score layout and uncheck the flow in question (number 20 in this case).
  2. In Engraving options>Tacets select “Do not show border”
  3. In Layout options>players>Tacets>Tacet text: Delete the text and leave this field empty.
  4. Insert the text frame you want, that will of course create an override but do not worry about it, you can swap or move the pages including the override in the Pages panel in Engrave mode. So if you, for example, insert a frame brake in the second system of the previous page, the frame text/page override remains in page 23 but you can easyly move it forwards or backwards.
    Tacets and overrides
1 Like

Good detective work @rafaelv. I didn’t dig deep enough into the Tacet display options. I also (I think) misinterpreted what he wanted. I tried to create an additional page with just text followed by a Flow 20 with Music. Anyway, I updated your project file mipi with rafaelv’s changes but used a Master Page rather than an override.

Noten 2.dorico (657.2 KB)

Wow! Thank you so much @rafaelv for solving it, taking time to explain and making such as beautiful gif. Thank you @Craig_F for your original post and additional ideas. Such great people and community! You made my day.

I am still considering, if it was a good idea to make flow headings and music frame into one frame. I never truly liked this change. Originally Dorico 1 had two separate frames and it was much more easy to create your own master page if needed. So we do not have any more a full control in a master page editor and there is not possible to adjust a gap between a flow heading and music frame without leaving a master page editor. And in my case - instead of easily deleting a music frame, there are so many tweaks needed in order to create a text page as a new flow. Any way, thank you so much for your help!

As you are “in material”, allow me please one minor question, which you probably overseen in my original post. I cannot find out why Dorico doesn’t show page numbers in this project. There are for some reasons just pages #4, #8 and #15. In my original file there are no overrides. Thank you in advance.

Layout options>Page setup>Flows>Page number in header
Select “Show above flow heading”

Thank you very much😊

You can still do this: hide Dorico’s automatic flow headings, and handle them manually yourself, as was necessary prior to the introduction of flow headings.

Adjusting the gap above/below flow headings is something you can handle on a per-layout or per-page basis, which is arguably more helpful than in the master page editor as you can’t see the music in the master page editor (only the frames, but of course how music fills that frame depends on the music).

Flow number tokens: these don’t work when you specify the flow number in the token, because if you’re going to the effort of manually specifying the flow number, you might as well just write the number (my own analysis); it’s not like the flow title token, which could conceivably relate to something other than the very number you’ve just typed.

Thank you Lillie for your answer. I didn’t come my self to this very logical idea to hide flow headings AND to create my own masterpage set separating them. Thank you for pointing that.