Workspaces problems with 2 monitors on Mac

I imagine that I’m not the only one with 2 monitors on my Mac Pro.
I want the mixer to be on the left monitor and the project on the right monitor (my main monitor a Apple Cinema Display).
So I create a workspace just that way and save it as a global workspace.
Next time I open Cubase 8 I find the project on my main monitor AND the mixer BEHIND the project, and nothing one the left monitor.
This is NOT the way the workspace was saved!!
Can anyone help me with that??

Unfortunately the whole workspace area in Nuendo and Cubase is quite buggy. For example sometimes the same default project is loaded with slight differences. The more monitors and the problem gets worse. On my other, smaller workplace I have a single 30" Cinema display and it works better.
What me annoys totally is the fact that saved Workspaces are never recalled correctly, no matter what, when I transfer e.g. a Cubase project from my smaller workplace to the other. Recalling a Workspace doesn’t load the correct mixer setting, including zoom settings, and connections at all. Manually I have to edit every time the mixer settings (visibility of channels, racks etc.), the connections of the I/O (have to restart Nuendo/Cubase, execute a script to reestablish the I/Os) and some other details. A total recall concept which isn’t total recall but a partial, manual recall. This situation is for years like this (I reported it) - nobody seems to care about the mess - makes me upset.

I have reported it again.
Thanks for your reply.

I have 3 monitors and my workspaces are recalled perfectly because I start all projects from templates I created. Left monitor is the project, middle monitor has a mixer with input channels only and the Steinberg EQ display and the right monitor displays a mixer view reflecting the project. Use templates. It’s best practice which means less headaches!

I too start my projects from a template and the workspaces doesn’t recall.

Three monitors here (30", 24" + TV for video playback) with my Mac Pro and only one 30" Cinema Display on a Mac Mini and no correct workspace recall - never. Position of the mixer and project windows are correct but not the channels displayed in the mixers. All mixers have all channel types visible after Workspace recall but I have mixers setup differently for inputs, outputs and tracks and saved this into Workspaces. The same goes for insert/sends etc. settings etc. The problem with lost external connections to outboard (I have dozens of hardware inserts) is confirmed by Steinberg but without a solution for many years (I use a self made script but have to restart Cubase or Nuendo). Because of both my Mac workplaces showing this problem, proofs that this is not bound to multiple monitors. The idea is to start a project on the small system and then mix it on the large one. But the extra time to set this up because of all the lost and changed settings is a drag. The same goes with older projects I reload and want to adapt to newer layouts. It is a mess and the same for Nuendo (which I also have on the Mac Pro).

Looks like everyone who has an issue with this is a Mac user. No issue here with PC.

Yes that crossed my mind too!
Let’s hope for Cubase 8.1, sure there are lots of improvement to be busy about :wink:

No problems with 2 monitors.
I have mine set up with the left monitor with the mixer on it & virtual synths & right monitor with the arrangment on it.
I use to expand Cubase from the right monitor to the left minimise the arrangement to the right which ment I could put the mixer on the left.

Strange but works for me.

Works OK for me too, I always start from the same template.
I’ve got 2 identical monitors, can’t remember off hand what bred, but they’re not the apple ones.

Nothing has happened in the mean time concerning the Workspace errors on the OSX side. While working on an important project I used my two work places and exchanged projects (Cubase Pro 8 and Nuendo 7). The time I need to reconstruct all the mixer settings is ridiculous, while there is a function implemented that should do it instantly but doesn’t work for many years. When will this be finally ironed out?

One thing that can mess up workspaces on a mac is if you make any adjustments to the Arrangement settings in System Prefs-Monitors. I have found that any small adjustment to the alignment between monitors there can result in windows stacking up behind the project arrangement window on my main screen for all project saved under a previous alignment. For me, this is easily solved by saving a new adjusted workspace and hitting it’s shortcut. Once the project is saved again it spreads out properly when opened.

Also, I’m not at my workstation right now, but I think there are two types of workspaces - global and project. It could be that your project workspace is overriding the global one you are setting. Maybe.

That is not the problem here. Mixer settings get messed up, like wrong channel type settings, what is hidden and what not, size of channels … everything. Placements of the mixers and windows are correct.

I must say: I simply doesn’t understand what you are saying.
This is what I do:
I create a workspace by moving the mixer window to my left monitor, maximize the window, and then I have the arrangements page on my Main display. Then I create a shortcut, workspace specific or global doesn’t matter and save the song. The next time I open the song the mixer window is hidden behind the arrangement window on my Main display, and I have to do all the same things again to have the mixer on the left display and the arrangement on my Main display.
Do you have any idea what could solve this?

Musicmind, are you responding to me? I guess I have to make little screen recording to show what I mean. Like probably everybody I have my mixers setup which channels to show, zoom factor of channels etc. I save this as Workspace settings but they are never ever recalled correctly!

Instead of maximizing your mixer window, try manually expanding it so that there is a little bit of desktop space around it. It may help if maximizing is making cubase think your mixer window belongs on the other monitor.

I have no maximized mixer windows …

I think we talk past each other, if it’s what it’s called in English :wink: My last post was a reply to you Ulesto. I will try to expand the windows without expand them full!

Well that did the trick: Don’t maximize the windows but make them the right size “by hand”.
So thank you Ulesto! :smiley:

You’re welcome. Glad it helped.