Wow-i may be new to all this but some simple things are not intuitive

i just installed cubase 12 and i have a section of one song (lead break) that is not in another version of the same song but different take.

i want to copy the lead solo from the song that has it to the song that doesn’t have it.
i just want to insert it from the spot i choose (cursor pos) and have it paste the solo part (insert it) and push the rest of the song to the right of where it gets inserted.
now before you tell me to use Paste After, Paste Time or any of those they were not selectable.
here is what i thought should work:
i imported both song versions (mixed downs) to separate tracks—
then

  1. make the selection from the version of the song i’m using. Use Ctrl-C to copy the selection (BTW when you use control C it shows NO indication that it worked Ctrl-X does)
  2. select the other song (imported to a different track)
    so i put the cursor where i want the audio from the other song (track) inserted
  3. when i paste nothing happens. i selected the selection tool and tried to past (instead of the cursor arrow) and it still doesnt paste.
    so i try the menus up top to paste and the “Paste” functions in any of the Edit dropdowns are not active to select.
    If i do a select (ctrl-c) and paste (ctrl-V) in the SAME PLACE in the song (where i want to copy the audio from - i used ctrl-X to see the cut and ctrl-V to watch the paste) it WORKS!
    so
    why can’t i use the paste options in the dropdowns after i make a selection
    how should i go about selecting a section of one song or track (not in the same “column”)
    and paste it (insert it) into another track/song?
    thanks,

Your attempt at a description is admirable but as you probably anticipate my response will be based on my best interpretation of it. Hopefully a bit of back and forth and you’ll be all good.

No feedback is the appropriate behavior for Ctrl-C copy in every application I know of (e.g. MS Word). So this is perfectly normal.

Are you selecting the Track (on the left of the Project Window) or the Event in the track (the main part of the Project Window)?

Cubase will Paste (CTRL-V) to the Selected Track at the cursor position - so you need to select the destination Track. Note that selecting the event doesn’t change Track Selection (I believe this is the default but it can be changed in preferences).

Something should obviously be happening, unless you pasted back to the Same track - which is I suspect is the problem as that is the only way I can get nothing to happen.

Hope that helps

answers below yours
Your attempt at a description is admirable but as you probably anticipate my response will be based on my best interpretation of it. Hopefully a bit of back and forth and you’ll be all good.

thanks!

No feedback is the appropriate behavior for Ctrl-C copy in every application I know of (e.g. MS Word). So this is perfectly normal.

my point here is that some indicator should show a copy has been successful - i nice little thing to see

Are you selecting the Track (on the left of the Project Window) or the Event in the track (the main part of the Project Window)?

i selected the right tracks. (there are only 2) so when i copy (ctrl-C) from the origin track, i select the destination track i want to copy to.
i select the track in the left side of the proj window. i tried selecting from the editor window (i would prefer to use that editor window since i can do things more precisely there)
and i also tried to paste in the project window (i see the selections happen in the project window, the overview space (enabled it) and the editor window area so selection is what i expect to see (how do you change the contrast of the selection?)

Cubase will Paste (CTRL-V) to the Selected Track at the cursor position - so you need to select the destination Track. ---- i did. but i think it does not necessarily acts like this.
there’s “paste relative to cursor” , “paste time” , “paste at origin”, “paste time at origin” etc.
(see attached screen shots-they serve multiple purposes for my answer)

Note that selecting the event doesn’t change Track Selection (I believe this is the default but it can be changed in preferences). ---- not sure what this means

Something should obviously be happening, unless you pasted back to the Same track - which is I suspect is the problem as that is the only way I can get nothing to happen

no i can cut (ctrl-x) and paste (ctrl-v) in place at the same spot in the same track (just did this to see if cut/paste worked like i thought) - and this worked it cut the audio and pasted it

you can see in my screenshots i have no “Paste” selections in the dropdowns active. i just tried to make a selection from the top track, do a ctrl-c, and put the cursor in the 2nd track and try to paste what i copied from the top track. nothing happened


wow i have been using this forum for a couple months and it just told me i’m a new user and cannot upload more than one file. smh
.

Try this:

1 Like

Why not using the manual? Just a bit…

1 Like

That waveform tho

3 Likes

manual not very clear and i looked at the “ratings” for the manual by topics. i agree with the ratings stars that are not 4 or 5.

i will. but when i am doing “simple” tasks i didn’t think i needed to go through training. i mean it looks like cut/paste should act like i expect it to. in fact, with 11 i did it fine but had to dicker around with it still to get it to work. then by the time i need to do it again, i forget what i did and have to dicker around again. this time i couldn’t get it to work because the “paste:” options are greyed out and not active on the dropdowns.
is there a sequence of things or prerequisites i must set before i do cut/paste so that i can reliably know how to cut/paste?
i will watch the video now.

1 Like

what about it? i used what they gave me and am doing what they want. on a mixed down audio file with too hot of levels. i cannot + the waveform any further to get a better look at the tops and bottoms of the waves.

Did you try to pull the little slider down on the right to see if the waveform tops become visible?

(Or maybe it was simply recorded that hot, and the top of the waveform is as displayed …)

yes it never clears the middle parts

What you think is simple, isn’t actually quite that simple, because where do you paste?

Illustrator and Photoshop have this same problem – which layer do you paste on? You have to select the right layer. (In fact, Word has this problem, too – which page do you paste on? But it has a simpler problem with time, because it’s not a non-linear editor,)

You select/put the insertion point where you want to paste, and then you paste. You do that same thing in Cubase – select the track and time location, and paste.

What Cubase doesn’t do is directly move the time marker when you click in the timeline.
For lots of precision tools (especially CAD tools and 3D content tools and video editor tools,) this is the standard, because if it did that, it’d be a right pain to use in many editing situations.
The less-direct insertion point metaphor is used in Premiere, Blender, Fusion 360, Unreal, Maya, Inventor, and a few other tools I’m forgetting right now :slight_smile:
So, Cubase follows the conventions of other typical content creation/media workstation tools here, and I think that’s the right choice.

Also: For good ideas about workflow when mixing-matching different takes and different snippets, I recommend searching youtube for something like “comping in cubase.” (“comping” is when you compose a single “good” track out of the best pieces of several different takes.)

what i do is linear inserts / pasting of audio. selections that i delete. (instead of overlaps) i prefer overlaps so i can have control of what to delete.

without going into the details why, i generalized the most common things i am currently doing in Cubase. After creating a project, i import a “target audio track and a source audio track”.
i select & copy pieces of audio from one track and need to insert it into the destination track.

i figure out what audio i want to put in the destination track by “looping” a section of audio in the source track - i move the range indicators and keep tweaking them until i hear what sequence i want to copy out and put in the destination track.
(i get familiar with the song first of course )

  • i “select in loop”
  • after selecting audio i usually copy it. (ctrl-c)
  • I then set up a loop on the second track usually what will be playing before I insert the audio from the source track. Sometimes it will be a loop after but usually it’s before since I got to match the end of what’s playing in
    the destination track seamlessly match the beginning of what I’m inserting from the source track.
  • all i want is paste time or paste relative the cursor I’m not sure - but most of the time i am inserting and want everything to the right (or later part of the song) to move down and play in sequence after my insertion.

This whole process saves calling all the musicians over re-recording a take and a lot of moving of equipment hooking things up excetera, via this editing process.

its not like I’m not reading. i did read up on stuff every time i find a task i need to do. i retain it that way.

but, this isn’t working according to my interpretation of what I read which I thought was accurate.

I think Cubase would be a lot more useful in this type of editing area if they had ways to manage several Selections in memory like several clipboards.

now, i still may want to EQ the inserted selection after
i listen to the assembled destination track (say the bass or mids get noticibly louder when the inserted selection plays etc).

So I would want to EQ that inserted audio without affecting the rest of the linear track EQ
example one thing among the many things I could do with that audio.

Right now it’s not that easy to do because I have not figured out how to EQ a selection and change levels to just that selection and not anything else in that track.

Does this have to be done in separate tracks? If that’s the case I’ll end up with a whole bunch of tracks with little Snippets in them which I think would be harder to manage. And then the destination track would not “open up a space” to allow what I want inserted into it to play.

What I do is go to where I want to paste my events, I select the number of bars I will paste and then go to the Edit menu, then Range, then Insert Silence.

Then I go to the tracks I want to copy and select the first one and then select all the events across multiple tracks I want to copy. Then use control+c. I also trim the events to make sure they do not run over my destination silence area.

Then go to where I inserted the silence, I make sure I have the correct first track selected to match where I copied from. I place the cursor at the start of the silence. Then I paste into the silent bars I have inserted earlier. Control+v.

But if your copying multiple events across multiple tracks the destination has to have the same tracks in the same order and you have to select the top track in your selection before pasting.

i need to be mote variable. i use time code in mins & seconds not bars/beats when i do this.

i shouldn’t have to worry about how much audio i am inserting. if i select accurately what i want in the source file, select the insertion point in destination track, then i only need it to insert without any extra steps.

i did this in Cubase 11 and it worked. but i had to play with it and eventually it would paste.

in 12, so far i can select/copy audio but when i go to paste, it acts like theres no audio in memory buffers and nothing happens.

that is why i think some sort of “indicator or something” should show when a successful selection is made. the way this is, i can’t tell if the ctrl-c didn’t work or if the insert into the destination track is not working. or even further, the clipboard is getting wiped out after a selection using ctrl-c!

I found it.

Go to Edit menu, then Range, then Paste Time.

Maybe in C11 you have a short cut set up for that but not the same one in C12.

But paste time pastes the events and the time is inserted too.

At the beginning of this thread, i said when I went to use that u described (see the images attached in that post)
those Paste options including “paste time” are greyed out and not selectable for use.

to me its like the ctrl-c is not working off the selection (why i would like to see some sort of clipboard indicator)
instead i do the more risky (imo) ctrl-x / ctrl-v to put back the audio i selected.

then i dont know how many times i can ctrl-v once i use the ctrl-c or ctrl-x.

Then it’s your control+c that doesn’t work.

I have tried all sorts of paste times in C12 and even if I select a midi track it still pasted the audio onto new tracks below. I cannot find a way to stop it pasting time. I even did a huge temp change to see of that would mess it up but it did not. It works in C12 alright.

So in your keyboard shortcut manager try adding control+c back in for paste. It will say of its being used somewhere else.

If you use control+c and then control+v it should paste over your audio and give that hash effect. You should see it that it has pasted.

So it sounds like the short cut for copy is messed up.

If that fails it’s log out and log in again.

even if it works ctrl-x / ctrl-v in the same track in place.(will have to check if ctrl-c does. this) i should end up with a duplicate copy.

Yes you should end up with a duplicate copy, that’s just to check control+c is working. Sounds like it is not. If it’s not the short cut then maybe the keyboard setting are messed up or something.

But always turn it off and on again before messing with the keyboard setting. Might be a glitch in the computer start up, one time thing :slight_smile: