Write enable struggles

This sits somewhere between a bug report and a feature suggestion, because I don’t know if it’s intended behaviour.

There are some little things in my workflow that going wrong when it comes to writing automation.
Let’s say I want to write some volume fader automation on an audio track using my CC121 fader.
I’ll usually use my mouse to click the write button on the track in the project window I want to automate. This however doesn’t select that track.
So if I move my fader after clicking write, I’ll be moving the fader of whichever track I have selected at that time. (and since there’s no undo there, that’s rather inconvenient!)
I only ever enable write on a track if I want to write automation on that track right away. So if clicking write would automatically select that track as well, that’d be grand. (option in preferences perhaps? It’s there for solo if I’m not mistaken)

I am fully aware of the fact that if I were to use my CC121 to select a track and enable write on it everything would be fine, but that simply isn’t always the fastest option.

Another related problem is with selecting automation lanes. If expand an audio track to show it’s volume automation lane, selecting that automation lane will NOT select the audio track it belongs to. This is really silly, because I could enable write on that track, select the volume automation lane I want to automate, but if I then move my fader it’ll still move the fader of whichever track I had selected before that. Please make it so selecting an automation lane will also select the audio track it belongs to. You could argue my first problem is my own fault because the project window clearly shows another track is selected, for this second problem that’s not the case. There is no indication whatsoever to suggest I’ll be changing another track than what is selected in the project window.

reproduction steps for both problems:
I’m in the project window for all of these steps

  1. Create 2 audio tracks, let’s call them audio 1 and audio 2.
  2. Expand audio 1 to see it’s volume automation lane in the project window.
  3. Select audio 2.
  4. Enable write on audio 1.
  5. Move the fader on your cc121.
    –> audio 2 fader moves (problem 1)
  6. Select the volume automation lane of audio 1
  7. Move the fader on your cc121.
    –> audio 2 fader moves (problem 2)
    Notice that at this point, audio 2 isn’t selected anymore, just the automation lane of audio 1!