Wrong MIDI automation when cycling (fixed in release 9.0.30)

Cubase Pro 9.0.20 on Mac
Using a Retrologue2 synth as a rack instrument and playing it using a MIDI track.
When using the following automation on the MIDI track:

the MIDI volume will be equal to 45 on the first cycle (which is correct) but will be equal to 90 upon subsequent cycles (INCORRECT).
So in this easy-to-reproduce example the perceived volume is:

  • bar#1 volume = 45
  • bar#2 volume = 45
  • bar#3 volume = 45
  • bar#2 volume = 90
  • bar#3 volume = 90
  • bar#2 volume = 90
  • etc.
    Note that the MIDI fader in the Main Mixer does not move (stays at 45), and no other fader moves either, but synth does sound louder (equivalent to whatever value I set in the last automation parameter, here 90). The same problem occurs with other controllers than MIDI volume (CC07).

I confirm this problem, and it’s sending a rogue value at the loop point, see my explanation in this other thread.


Anybody at Steinberg confirms the problem and that it will be fixed in a future release ?

Consider marking it as such in the topic title.