Wrong patch on midi channel

Cubase 12 Elements on Win 10
I’ve been building a template using Kontakt libraries with Instrument tracks but ran into a problem.
I completed the woodwinds section ( 7 midi channels under the one Vsti.
I started doing brass with a new Vsti, but when I added a patch to midi channel 2 it plays a patch from the Woodwind section, that is on channel 2 also.

I’ve tried deleting the brass stuff and starting over, still have the problem.

Anyone know what this issue could be?
Thanks in advance.

Are you using Instrument Tracks or MIDI Tracks (with rack instruments)?
Are you using one instance of Kontakt for each instrument or is one instance of Kontakt hosting several instruments?

I add an instance of kontakt as an instrument track, right click and then add some midi tracks.
One instance of Kontakt for several instruments. Thanks for your help!

Make sure the MIDI Track channel setting in Cubase matches the MIDI channel for each instance of Kontakt instrument.


Hi again and thanks…
Yes, I did that and all is okay but…On the far left in the inspector panel, that track that is the problem, Midi channel 2, is fixed showing an instrument from another instance of Kontakt. Every time I try to add a midi track number 2 to another instance of Kontakt, under a new instrument track, it defaults to that other instrument.

I’m going to try and delete that track now and leave midi channel 2 out and see what happens.

Perhaps a few screenshots would help explain your issue a bit better?

Thanks again. Yes, good idea but now things are worse. I didn’t delete yet but now half of my tracks have no sound at all. Anyway, I’ll play around a bit this morning, make some screen shots and get back to you later today. I appreciate your help greatly!

Okay, an update to say I have fixed the problem, but whether it stays fixed I shall see.
On the midi track/s, which as of today went from 1 track to 6, that was playing the wrong instrument, I opened up kontakt and selected another patch from the same library, then switched back to the original patch and it worked.

All my other instances of Kontakt VSTi are okay now.
However, I would like to know what or how the problem originated or if indeed it is a bug. I have read numerous posts that go back a few years saying that this happens randomly with Cubase.

Anyway, if the problem returns, so shall I.
Thanks again for your help!
Take Care,