Wrong playback of staccato

I have an example where fourths with staccato point are played back, but eighths points correctly as staccato. I enclos a short example. Does anybody have an idea?
Staccato.zip (587.0 KB)

On the Timing page of Playback Options, make sure Maximum duration for staccato playback technique is set to 1/4 note (crotchet), or is switched off.

Thank you, Daniel. But I had to set it to 1/2 note or switch it off.

I’ve often found the same as you. It doesn’t always seem to work just setting it to a crochet. Much depends on the actual tempo as I think has been discussed elsewhere.