X-fade Editor cancels local solo in audio part

NB: This is about audio within Parts - not Events in the Project Window.

Problem: In Audio Parts, opening the X-Fade Editor window causes Part Solo to fail, meaning you can’t hear it in isolation to check if it’s ok. In contrast, opening the regular Fade Editor window maintains the solo state correctly.

Repro: Pick a project that uses fades and cross-fades (Audio menu):

  • Open an audio part containing events with just a fade and just a X-fade (to clearly contrast behaviour).
  • Enable Solo in the part and loop it.
  • On an event containing a fade only, open the Fade Editor (Audio menu). Part remains soloed.
  • Close the Fade Editor.
  • On an event containing a X-fade only, open the (X-)Fade Editor. Backing track comes in, although the Part Solo button remains lit.
  • Close the X-Fade Editor. The backing track drops out again.

Can’t be right…

C6.0.7, Win7, all 64-bit.

Bump