X-Touch causes Cubase to hang

Really simple to reproduce using Behringers X-Touch (with latest firmware) all set up and generally working well with Cubase except for this event.

-Start Cubase.
-Open a new project and select, for example, the 16 channel recording template.
-Once opened, on the x-touch press Enter + one of the buttons next to “Global View” (Midi Tracks, Inputs…etc).

Expected behavior (according to the Steinberg Remote Control Devices - page 10) , is to “To apply a particular channel type directly to the channel set”.
Instead Cubase freezes. Open Task Manager and it shows Cubase Not Responding.

On the other hand, pressing one of the same buttons without Enter works correctly and one of the first 8 individual Channel Visibility Configurations is applied to the channel set.

Wonder if anyone else has come across this.

Hi,

Do you use X-Touch in Mackie Mode? Is it setup as Mackie in Cubase properly?

Hi Martin,

Yes, it is set up in Mackie. In fact I have both the main X-touch and the extender and they both are configured correctly and work well with Cubase.

I can control the faders,pan, EQ, and so forth. I can even apply my saved channel visibility configurations. Its only that one combination of keys that seems to cause a problem.

Hi,

Sorry, I don’t have X-Touch. What function should be triggered?

If you are on Windows, could you use Microsoft ProcDump utility to generate a DMP file, please?

Hi Martin,

I’ve created the dump file. Here is a link to it https://www.dropbox.com/s/kt983zjffjler9p/Cubase10.5.exe_200416_092535.dmp?dl=0

Regarding the function to be triggered: Here’s a snippet from the Steinberg Remote Control Devices - page 10):

To apply a particular channel type directly to the channel set, hold down SHIFT and press the corresponding button 1 to 8 in the right FADER BANKS section. This setting is not reflected in the MixConsole.
The following button combinations apply:
All channels: Hold down SHIFT and press button 1or button 8.
Audio channels: Hold down SHIFT and press button 2.
Groups: Hold down SHIFT and press button 3.
FX channels: Hold down SHIFT and press button 4.

Thanks for looking into this.

Hi,

Sorry, I don’t understand, what is the link to the “Steinberg Remote Control Devices” document, please? Where does this document come from? Could you send a link, please? Is it Steinberg document or Behringer?

Do you use Mackie mode on the X-Touch?

Here’s the Steinberg document http://download.steinberg.net/downloads_software/documentation/Remote_Control_Devices.pdf.

It states “To apply a particular channel type directly to the channel set, hold down SHIFT and press the corresponding button 1 to 8 in the right FADER BANKS section.” When I do that Cubase freezes.

And yes, x-touch is in Mackie mode and set up and working for all other functions.

Hi,

I see. I think I start to understand what’s going on here.

This is the original Mackie Control Universal hardware. This is Cubase/Nuendo template on it. As you can see the Shift button on the Cubase template is the Enter button on the Mackie Control Universal unit. So you have to send the MIDI message of the Enter key, not the one which is labeled as Shift.

So in your case, hold down Enter and press corresponding button 1 to 8 in the FADER BANKS section. Now, where can you find the Fader Banks section at your X-Touch? Again, if you have a look to the Cubase/Nuendo template, you can find out, which buttons are these on the original Mackie Control Universal unit. And as you can see, these buttons are originally named: MIDI Track, Inputs… User. So on the X-Touch these buttons are the 8 buttons above the Function F1 to F8 keys: MIDI Tracks (= Fader Bank 1) … User (= Fader Bank 8).

In your case:

  • Enter + MIDI Tracks = All Channels
  • Enter + Inputs = Audio Channels
  • Enter + Audio Tracks = Groups
  • Enter + Audio Inst = FX Channels
  • Enter + AUX = Instrument Channels
  • Enter + Buses = MIDI Channels
  • Enter + Outputs = I/O busses

I hope this will work for you.

Hi Martin,

Thanks for responding. Everything you mentioned I had come across when I was researching how to use the X-Touch (Behringer documentation is nearly zero). So I was aware of the Shift/Enter issues.

However the issue is still the same. Using the “Enter” key (labelled Shift on the device) with any of the 1-8 buttons causes a freeze in Cubase. Using the 1-8 buttons WITHOUT the “Enter” key works well and applies my own visibility configurations correctly,

Bottom line: What is causing Cubase to go “Not Responding”…? Did the dump file I linked indicate anything?

Thanks again for taking the time to look into this.

Hi,

You should use the key, which is labeled Enter on your device, which means Shift for Cubase. Please, press “Enter + Inputs” to show Audio Channels only, as I mentioned above.

Sorry, I forgot and at this moment, I have no the device, where I could resolve it again.

Yes, I am aware of the fact that the key labelled Enter on the X-Touch means Shift for Cubase. That’s exactly what I have been doing.

If anyone else has an X-Touch… could you try to reproduce this? Thanks.

Hi,

Could you please set the MIDI Input of the Mackie Control to Not Connected in Cubase, then add a MIDI track and add MIDI Monitor Insert plug-in to the MIDI track. Then press the Enter button. The press the Inputs button. What MIDI Messages did you get, please? Enter button should send MIDI Note A5 and Inputs button should send MIDI Note D#4 (if this is “Fader Bank 2”).

Hi,

The crash is completely out of Cubase:

STACK_TEXT:  
00000000`0014c9f8 00007ffe`5c61592e : 00000000`0014c8d0 00000000`0014ca10 00000000`00000000 00000000`00000000 : ntdll!NtDeviceIoControlFile+0x14
00000000`0014ca00 00000000`0014c8d0 : 00000000`0014ca10 00000000`00000000 00000000`00000000 00000000`0014cb30 : KERNELBASE+0x2592e
00000000`0014ca08 00000000`0014ca10 : 00000000`00000000 00000000`00000000 00000000`0014cb30 00000000`002f8013 : 0x14c8d0
00000000`0014ca10 00000000`00000000 : 00000000`00000000 00000000`0014cb30 00000000`002f8013 00000000`00000000 : 0x14ca10

Hi,

I did what you said: here are the results:
Enter button sends B4
Input button for Fader Bank 2 sends D#3

So I went looking for which buttons send the notes you were expecting:
A5 is sent by Transport Stop
D#4 is sent by Automation Write.

I found a Midi Implementation Chart for the MCU protocol on this page http://web.archive.org/web/20080126093602/http://members.aol.com/mhigrules/MCMap.htm which shows yet a different set of notes for these functions.

I am now officially lost.

Hi,

On the webpage you sent, you should have a look to the last column (in the red area). This is the default label on the surface. The 1st column is as labelled by the lexan overlay for Digital Performer.

So again, the last column Enter (= Shift for Cubase) is note A5. The F9-F16 from the default label (= Fader Banks 1-8 for Cubase), are MIDI Notes D4-A4. Do you should find, which buttons are sending these MIDI Notes (A5 and D4-A4). Thy couldn’t make it more messy in Behringer… Are you sure you are in the Mackie Control Mode?

B4 (your Enter) is an Option key at the default label.
D#3 is not specified for Mackie Control Protocol.