X-Touch causes Cubase to hang

Hi,

Are you on Mac or Windows, please?

Hi Martin, I’m on Windows 10 20H2,

Hi,

Generate a DMP file and share it via Dropbox or similar service, please.

Once Cubase becomes frozen, open the Task Manager, right-click to Cubase and click to Generate DMP file.

If this doesn’t work, use Microsoft ProcDump utility to generate a DMP file, please.

  1. Please download ProcDump64 from Microsoft (~650kB) and extract the archive to a local folder on your harddisk.

  2. Run Command Prompt (cmd) as administrator (right click and select “run as administrator”)

  3. Navigate (in the Command Prompt) to the folder with the extracted procdump file.
    For example:
    cd C:\ Users \ \ Downloads \ Procdump
    Note: the dmp file will be written into that folder.

  4. Launch Cubase/Nuendo. You can work as usual. At any time, change to the command prompt and start procdump, to monitor Cubase/Nuendo for unexpected behavior (see next step).

  5. Launch procdump64 via Command Prompt:
    Cubase 11:
    procdump64 -e -h -t Cubase11

Nuendo 11:
procdump64 -e -h -t Nuendo10

The -h option will write a dmp file in case of an application hang. This might kick in too early sometimes, in case some action takes a little longer. Feel free to skip the “-h” option, if you are only up for fetching crashes.
The option -e will catch exeptions and the option -t terminations of the application.

  1. Prodump is now monitoring the Cubase/Nuendo process and will write a crash log, in case Cubase/Nuendo crashes or hangs. Perform the action that causes Cubase/Nuendo to crash and send us the generated crash dmp.

ZIP and share the DMP file via Dropbox or similar service, please.

Hi Martin,

The create a crash duo feature is greyed out in Task manager. I’ll download Windows procdump and send you as per instruction. Thanks

Hi Martin,

I PM’d you the link to the DMP file. Thanks

Hi,

The crash seems to be related to the Direct Music driver(s). Actually it seems, there are multiple Direct Music drivers installed and maybe, they clash together. I can see 2 UR devices and one Universal Audio.

Could you please try to reinstall your Audio Device’s drivers? Make sure, you install the latest version and make sure you install the driver as an administrator, please.

Hi, thanks and will do.

No luck. Everything uninstalled and reinstalled and still have the same issues. Just running bare bones system the issue occurs. Just a reminder. Everything works fine with just one UF8 unit, its when the second one is added that the issue occurs. Thanks for the help thus far :slight_smile:

Hi Martin,

I have tested this on 4 systems (one of these was a colleagues PC, not one of my systems), 3x PC and 1x Mac (all up to date). All present the same issue. With 2x UF8 connected, Cubase or Nuendo latest versions, freeze when using the ‘fine/^’ and ‘send/plugin’ buttons for channel visibility. A single UF8 works as expected on all systems. In case it was a hardware issue, I borrowed a UF8 from the same colleague (I now had 3 to play with) and still get the same issue. At this point I’m at a loss as to what to try next. If anyone out there has come across anything similar and was able to resolve, please chime in :slight_smile:

Hi,

Do the devices have the same name in Cubase or do they differ?

Hi, different;

mackie control and mackie control2


Hi,

Could you, just for test, please, remove the other Remote Devices? CC121 and Yamaha KX. Is the result the same, please?

Hi Martin,

Thank you. I did this test yesterday and the issue still continues. Same test done on the mac with the same result.

Hi,

I have just tried with my Mackie SW emulation. Same as you, I’m using 2 MIDI ports, so I emulate Mackie Control and Mackie Control extender. I have bank of 16 channels. If I send the MIDI Note 47 [Bank >], Cubase switches the bank and I can control the next bank. If I send MIDI Note 46 [Bank <], Cubase switches to the previous bank and I can control the previous bank. No hang. Tested on macOS 10.15, macOS 11, Windows 10.

In your case, I would swap the MIDI Ports, this looks a bit unexpected to me. In Cubase, the most down Mackie Control device from the Remoter Devices is the most left unit at your desk. So I would expect, Mackie Control 2 is using SSL V-MIDI Port 1. You can verify this by moving the faders. If most left fader moves the fader of channel 1 in Cubase, then it’s correct.

Also verify (by using MIDI Monitor), SSL sends MIDI Notes 46 [A#1 in Cubase] and 47 [B1 in Cubase] to switch the banks, please.

Hi Martin,

I have no issue with banking as previously mentioned. Everything works as expected using a single UF8. The only issue I get with a second hooked up when using the channel visibility option via the ‘fine/^’ and ‘send/plugin’ buttons where you can show only, audio or group, or fx, or VCA channels. Everything else on the second unit works as expected, inc banking etc. Thanks

Hi,

What MIDI Messages are sent, once you press these buttons, please?

I’ll check and report back. Thanks

Hi Martin,
for ‘fine/^’ button
B4

for ‘send/plugin’ buttons 1 to 8
D3,D#3,E3,F3,F#3,G3,G#3,A3

When the second unit is connected pressing the ‘fine/^’ button independently of the ‘send/plugin’ button, B4 is generated.

When the second unit is connected pressing the ‘send/plugin’ button independently of the ‘fine/^’ button, nothing is generated.

Hi Martin, any further update, ideas etc?