X-Touch Compact with automation

I want to use x-touch compact to record automation such as expression CC11 or the mod wheel CC1. The idea being my faders would support each lane in Quick Controls. Typically I have three lanes in place. Ideally I would be able to assign each lane to a different fader. I’ve been able to get each fader assigned to a different VST and use it to automate the volume for instrument. I don’t seem be to be able to get the fader un-tided from the VST and only see the lanes assigned to the instrument that has been select on the client. Unfortunately, the Behringer docs are unclear on how this is done. Actually their un clear about a lot things.

Any help would be appreciated.

Hi,

Switch the X-Touch to the Controller mode. Then assign the MIDI CCs which have been sent by X-Touch to the Quick Controls in Cubase.

Thank you for the quick response Martin.

X-Touch Compact does seem to have ‘Controller mode’. It does support ‘MC Mode’ and ‘Standard’. If I’m in standard, it has a type CC available that I can set CC11 to as well as channel for each fader. On the CB side I have a Mackie Control. Set the the F1, which I assume is Fader 1, to ‘automation’ /‘Write Automation for Select Track’ That doesn’t seem to work. I’ve tried several iterations similar to those settings. At one point I was able to get the fader to connect to VST channels. So each fader controled the volume for each VST channel. So I know that CB and X-T are talking to each other. But that’s not what I want to happen here. Each fader needs to be tied with the Quick Controls channels, or at least a CCn.

What do you think?

Hi,

If you want to assign the faders to the Quick Controls, switch the X-Touch to the Standard mode. Remove Mackie from Cubase and set the MIDI Input at the Quick Controls. In the Quick Controls enable learn. Select QC1 and move fader 1. Select QC2 and move fader 2, etc. until QC8. Now the faders are assigned to the QCs.

Not there yet. I set ‘Learn’, selected QC1, moved the fader. The MIDI Status changed to ‘unknown’ while I was moving the fader. When I released the fader, the status changed to ‘Note On’. When I select QC2, I get the same behavor, except while I’m moving the fader the MIDI channel changes to 2, which is the setting I have in the x-touch editor, and reverts back to 1 when I release the control. This behavior is repeated on each fader, so in the end they are all ‘note on’/Channel 1. Side note, the address is numberic start with 104 and ending 111.

One more note. When I set it up for Mackie Contols, each fader gets assigned to a VST control as expected. The problem is with trying to get assigned to QC channels.

Hi,

Your X-Touch is still set to MC Mode, I guess. Unknown is for PitchBend message. Not Off fits to Fader release in the Mackie protocol. Switch X-Touch to the Standard mode, please.

Still no luck. CB Learn has stopped learning completely. It may be user error in not understanding the XTouch Editor. Unfortunately there’s no supporting documentation for the editor and it’s not as intuitive as I would like. You guys that have been at for awhile get it. We new folks need more experience. For now I’ll see if I can connect through Generic Remote and see if that will get me connected to automation lanes.

Thank you for help. I did learn a lot from the exchange.

Hi,

You can also add a MIDI Track in Cubase, and add MIDI Insert MIDI Monitor. Here you can monitor, what MIDI Messages are the X-Touch faders sending out. And then make the assignment manually in the Quick Controls.

Hi. I have the same problem, just bought the Compact and it’s my first experience with an external hardware in Cubase. I have no idea how to do it. I didn’t found a decent tutorial for it in internet. Watched videos on youtube, but not useful help. Can you describe me, please, every single thing i have to do? I made a post today, about my problem.
Many Thanks. :slight_smile:

I finally figured out the security sauce for getting it to work.

• Open Cubase
• Open the X-touch app and set up your channels on the Compact board.
• CLOSE the x-touch app. For some reason, it never worked for me when that app is open.
• Go to Studio -> Studio Setup -> MIDI Port Setup
Confirm that Compact is included with the device list
• I like to confirm that Cubase is hearing Compact. So I’ll open Track Quick Controllers
◘ Add Compact to the MIDI Input channel
◘ Check the Learn box and test some of the controllers. If you see the settings change when you move the control, you’ve confirmed that Cubase hears the device.
◘ IMPORTANT: Reset MIDI Input to ‘Not Connected.’
◘ I don’t know that this step is necessary. It does confirm the connection.

I’m writing this from memory, so I hope I got it right. You should be good to go. The key for me is step three.

Good luck

Thanks, now i will try. One question: when you say “Important: reset midi input to not connected”, what you mean? The checked box “in all midi” in the midi port configuration window, or the window menu in generic device? But…i have not to use the generic device (instead of Mackie Control)? Just only the Track Quick Controllers?
P.S. so…i have to open the x touch app AFTER opening cubase? No before?

Ok, I tried. Cubase is hearing Compact, but the setting with the X Touch software has no effect. I want to set Compact mapping the faders to control the MIDI CC I want. For example, all the 8 faders with CC11 on 8 different channels. But if I set it in this way, then in Cubase the learn command set the fader to CC101 (the default fader). So, Cubase don’t accept the edited mapping. There’s a way to solve this problem?

Hi, not sure if this is the issue but - because the faders are touch sensitive - if you set Cubase to learn and then touch a fader, you’ll get the ‘touching a fader’ CC. Try touching the fader with something non-conductive, like a pencil.

Hi,

It depends… Cubase doesn’t take the first MIDI CC, but the last one. So if you touch the fader, move the fader, release the fader, Cubase learns the release fader MIDI message. So in this case, you have to:

  • Enable MIDI Learn
  • Touch Fader
  • Move Fader
  • Disable MIDI Learn
  • Release Fader.

No, the problem is: Behringer doesn’t bother to provide detailed manuals for their products. At least for the X-Touch series. With the Compact there is only a meager quick start guide that says absolutely nothing, and the editing software has no explanation as to how it works. Then I remembered that the readme file read "After editing, there are two options: (The preset has to be saved or dumped) 1. SAVE to computer 2. DUMP to the desired layer location A or B on the connected hardware ". But for someone like me who isn’t English or American and doesn’t know English well, it’s hard to understand what that means. Now I understand that once you have edited the commands, you have to “send” the mapping directly to Cubase with the command “Dump A (or B) to hardware”. So finally using “learn” in Cubase, Cubase recognized the Compact with the mapping I wanted. FINALLY !!! But now I’d like to find a detailed manual, or a detailed editing software tutorial, because there are several things I don’t understand, for example the difference between Momentary and Toggle. Also in Cubase I have to understand why after creating a track and creating an expression curve with the Compact, during playback the faders remain stationary and do not move. But … there is time. For me the important thing was to understand if I could work as I wanted. I just bought it and I had to be sure, otherwise I had a few days to be able to proceed with the withdrawal … and even if it is only € 300 of expenditure, for me it is still a lot. :slight_smile:
Thanks so much for your help! :slight_smile:

Yep, in theory, but in practice I always find it easier to use something non conductive when I’m using a midi learn for anything touch sensitive. I’m too clumsy and disorganised to get it right every time otherwise. :slight_smile:

Happy to hear you got it sorted, The Engraver. I too find integrating new hardware troublesome, and English is my first language. It does seem to get a bit easier each time I do it though. I feel I almost understand Cubase’s Generic Remote dialogue now, even though the very sight of it used to fill me with dread. :slight_smile:

I understand you, hehehehhh. One question: what’s tge difference between momentary and toggle, in the editor software?

Momentary is on when you touch it and off when you release it. Toggle is on when you touch it once and off when you touch it a second time. So your buttons can either behave like drum pads or on/off switches.

Wow!! Great. Many thanks!!!

The difference between faders-foot and faders-touch? I think the first is the sliding movement and second is the touch function, right? If i want deactivate the touch? I think there are 2 ways.
1: set channel off on the faders-foot section and set faders-touch section on momentary.
2: set channel off on faders-touch.
Am i right or wrong?