X-Touch (+Extender) MIDI Remote Script (MCU mode)

Same for me: The Stereo Out always appears before any MIDI track on the X-Touch, regardless of the actual track order in Cubase. This is up to Cubase though and nothing I can control in the script :confused:

EDIT: A bit more testing reveals the Cubase track order (M=MIDI, A=Audio track)

  • “M1, M2, Stereo Out, A1, A2, A3” becomes “Stereo Out, M1, M2, A1, A2, A3”
  • “M1, M2, A1, Stereo Out, A2, A3” becomes “M1, Stereo Out, M2, A1, A2, A3”
  • “M1, M2, A1, A2, Stereo Out, A3” becomes “M1, M2, Stereo Out, A1, A2, A3”
  • “M1, M2, A1, A2, A3, Stereo Out” becomes “M1, M2, A1, Stereo Out, A2, A3”

on the X-Touch. @Jochen_Trappe :eyes:

:scream: thanks, Eriberto

Hi Sorry, I think read almost all post but I can’t understand if config Visibility works or not.
If I set up some visibility config, (1-7) if I recall them with xTouch or with mouse the faders don’t follow the window config but are always all as the initial config. Faders, follow visibility only if I manually disable/enable track and visibility… do I miss something?

Cheers, Eriberto

The API option “setFollowVisibility” doesn’t work.

1 Like

Thats really bad!!!
Steinberg needs to apply seriously to all this Remote Devices API, lots of bugs and 13 version had release just few time ago…
Thanks to all.
Cheers Eriberto

1 Like

Thanks! Of course…:man_facepalming:
If I connect both over USB it works miraculously :laughing:

1 Like

Are you saying that both Main and Extender have to be connected to USB to hub and not one each other to make config visibility work? Or are you talking about track order?
But how works the selected Track flag in this case? do I have to choose different midi i/o
Thanks, Eriberto

None of both, I’m afraid – @mat replied to an earlier message:

image

Hello everyone,
I haven’t worked with the (zoom in) and (zoom out) buttons on the x-touch for a long time. I do it with the keyboard G+H
Somehow it was so that you could switch it with the middle button (+) → button then glowed solid blue
Unfortunately he doesn’t do this anymore.
If I go to the arrows at the top bottom right left only works next or previous event or track down or up :frowning:
The middle button only lights up blue as long as it is pressed

Did I miss something ??
I loaded the latest 1.9 version again and redid the mapping file again but it doesn’t make any difference.

That’s strange → does anyone have an idea?

I have X-Touch + 1Extender

greetings Chris

That’s most probably the relict of a prior custom mapping. You can try removing your user mappings.

Hello bjoluc,
I completely deleted the file again
now it works again
Thanks for your quick help

But I haven’t changed anything in a long time

1 Like

I don’t know how old mappings work/interfere with new script versions; I’d assume an old custom mapping screwed up the new version’s mapping here…
Anyway, I’m glad you got it working again!

Hello bjoluc, Hello everyone

Unfortunately, I have now discovered that the old project files still have the problem with the zoom button mentioned above :-((

Newly created projects now work as they should with the zoom button

Something else is saved somewhere else in the project files, which then messes up the script
and the button no longer works??

and I noticed something else strange
After loading an old project and then loading one of the new ones, the zoom button on the new one no longer works.
Only when you close Cubase and reopen it does the button work again until you load an older project

greetings chris