X-Touch Midi Remote Cubase 12

Thanks @Jochen_Trappe , it works if I use Generic remote (as I did in Nuendo 11). I just double checked, and it works when you have selected for example, Mixer>Selected>Monitor. Although the odd thing is, the monitor option itsn’t available to select unless you have an Audio track selected when setting it up. But it then does work for MIDI tracks. Read, Write, Monitor, Solo, Mute and Rec all work that way for MIDI.

Good to hear the issue will be fixed.

Thank you for let us know I got the same problem with Nuendo 12.

I found the same thing. So I just went through and figured out which buttons didn’t have a current function and then made up a custom midi remote and added only those functions. Not perfect but upped the functionality game on the X-Touch in Cubase by quite a bit.

Once you figure out which buttons are available for programming, you could reserve one or two of those to act as a toggle function to go between “mapping pages” and then have multiple layers within your custom remote for each of the buttons available to you.

So there’s not really a shortage of buttons, but I had to leave all the encoders and faders alone, so to add more knobs and faders, I added in a Korg Nanokontrol2 as a cheap alternative until the full functionality of the controllers are available to us. With that you can also have multiple layers available. So a couple controllers go a long way.

1 Like

Basically, if I choose a ‘Selected tack’ command, like Solo, Record Enable or Mute, it only works for Audio and Instrument tacks - it doesn’t’t work for folders or MIDI tracks

Just confirming this is fixed in Nuendo 12.0.40 and works as expected

I just switched from Pro 11 to Pro 12 today.
All my 11 stuff came up on 12 but i was very worried about doing a windows update since I NEVER DO THEM. I went from 1511 to 21H2 so that is quite a jump then I immediately turned window update back off

I am using Mackie control and have 2 x touch controllers linked
They both show up as Remote Devices Legacy in studio set up

Are you saying you have to use remote manager now?
I didn’t do ANYTHING. When I switched over everything came up exactly including the buttons i already mapped

Is there a cubase file yet for these I have 8 buttons on the top row that don’t do anything I was going to try and map solo cancel to in the remote manager but if is going to mess up what I have I’m ok without it.

If you’re considering the X touch I have been using one for the past few years. I found a guy selling one who thought it was a mixer and got the 2nd one for $60!!

Linking them thru USB gave me grief so i use a midi handshake and its great because the pages link ( like when you’re doing EQ) and i can see 16 tracks at a time
I have my control room completely mapped


I’m using xtouch with mackie and it’s fine for super basics :
some knobs, jog shuttle, faders (8 out of 9)
I don’t want to risk to loose this as I have lot of work so never dived into complex customisation. But ht enew midi remote I tried a function I miss a lot that is to be able to control the control room level with fader 9 that is left unused on the surface :man_facepalming:t2:
This thread sounds busy on complex issues. Basically what I want to do is not possible right ?

Yes, you can do this with midi remote. I do it with the Icon Platform M+ midi remote which should work for the mapped controls with the xtouch (the xtouch has more controls). you could also just pull the appropriate code out.

With the MCU protocol in action? + MIDI remote?

No, not with the MCU connection. It’s one or the other because the MIDI remote does all the things the MCU would do (well, all the ones I implemented for the Icon Platform M+). Can’t do two things at once with the same midi connection and CC/Note numbers.

Will this be fixed?

Hi guys,

I found some time to write a Mackie Control replacement script for the MIDI Remote API to fully integrate the X-Touch with Cubase – including colored scribble strips. I posted a link to the GitHub repo in this thread, so feel free to try it out and leave some feedback!

1 Like

Bjoluc really…you made my day! Thank you SOOO much for this! Since I bought the xtouch i rarely used it because of the lack of integration into cubase -and especially the selected track/faderbank problem. Searched every few weeks in hope of any news from behringer oder steinberg and now - bam. This alone made me smile all day. I am currently exploring all the features and I love most of it! One question though - if I use the deep blue as color for the strips - I cant read anything on it. Is it somehow possible to set the contrast or similar? However I just registered on github to give you a star. Thank you again so much!

1 Like

@David_781 So glad to see you mirror my excitement, and thanks for the star of course :blush:

I love to hear that :heart_eyes:

Yeah, the readability on blue is not ideal. It’s still OK on my devices, but it strongly depends on the viewing angle. AFAIK, there’s no way to change contrast via MIDI. I guess you already fine-tuned the contrast in the X-Touch’s setup menu? I set mine to 56%.

Oh yes and how I share that excitement:) First day with a whole new workflow, thx again!! Yes already changed it in the xtouch but still not ideal. However I dont care at all - everything else is so great now.

1 Like

Did you go in to the STUDIO tab at the top of the window and go to top left of popup and hit the plus icon (+) to add the Mackie Control device? After you add it…click on the newly added Mackie Control option on the left under the devices and when you click on it a new screen will come up and the two drop down boxes on top must have xtouch in the boxes. Once you do these steps…you should have complete functionality of your xtouch inside cubase

Never worked for me. Tried for 2 years. Different techies. Forums. Cables etc etc.

Maybe you did something wrong?
Aside from the limited functionality as an MCU device, it’s pretty straightforward.

If the MIDI I/O is present in the OS, there is no reason for not working.

Yeah even my scribble lights are coloured same as tracks now :smiley: