x64 instances of 112db VST's crashing Cubase

Currently I’m demoing 112db’s Big Blue Compressor and Big Blue Limiter and I ran in to some trouble when using the 64 bit versions in 64 bit Cubase (same goes for the 64bit version of their Redline Reverb).

The problem:
When opening the editor (GUI) of Big Blue Compressor, Big Blue Limiter and Redline Reverb in a project with a big memory footprint (>2.5GB) the plugins will cause Cubase to make an error and eventually crashes the DAW.

I’ve contacted the developers (112db) and received some great support. Unfortunately they can’t seem to reproduce the crash I experience. So we decided to open a thread here to see if any other Cubase users are affected or if this problem is system specific (system specs in my sig).

So please, if someone uses these VST’s, would you be so kind to do the following test.
Thanks in advance!

Reproducible steps (important to exactly follow these steps):

  1. Open a project with a high memory footprint (e.g. >2.5 GB, be sure not to stress your system and keep some headroom in your memory usage to avoid crashes caused by heavy system load).
  2. Be sure the Big Blue Limiter or Compressor isn’t or was already present in the project.
  3. Load the Big Blue Limiter or Compressor in an empty non-used insert.
  4. Enter the editor (GUI) of the plugin

Result on my system is a repeating crash (see the videos below).
If it doesn’t crash on your system with the test above it would be very much appreciated it you could drop a line + your systems specs and OS.

The interesting thing is, when I open the Big Blue Limiter or Compressor in an already used slot (by another plugin), it won’t crash the daw.

Another interesting fact is: When I use the 32 bit version (jBridged) the behaviour is normal, so without crashes. When I use the 32 bit version with Cubase’s bit bridge the DAW doesn’t crash either, but the GUI is blank (behaviour we know from Cubase’s 64 to 32 bit bridge).

So it seems it has something to do with Big Blue Compressor, Limiter and Redline Reverb’s 64 bit instance in combination with (high) memory usage in Cubase.

I’ve shot some videos of the behaviour.

112db Big Blue Compressor in Cubase - Crash in unused insert (the video shows Cubase 6.5.2 version, but currently the behaviour on 6.5.3 is the same)

112db Big Blue Compressor in Cubase - Normal behaviour in used insert + crash when used in empty insert.

112db Big Blue Compressor in Cubase - Normal behaviour when All VST are unloaded (Low memory usage)

Additional info:
When I use the Big Blue Compressor or Limiter in another 64 bit host (Machine) with a high memory footprint, it wont crash the host.

When I use the 64 bit version in a Cubase project with a lower footprint (<1.9 GB) the VST doesn’t cause the DAW to crash when opening the GUI (3rd video).

Other plugins never lead to crashes in Cubase projects on my system.

Cubase doesn’t write any info in the Cubase6.LOG, in fact the log file isn’t available in my C:\Program Files\Steinberg\Cubase 6\ directory

Really no one using the fantastic 112db plugs in a x64 enviroment? :open_mouth:

This an ongoing problem with Cubase (Mac) and Redline Reverb since C4. Nice folks, great product, but as soon as I open the GUI, it crashes Cubase. Sometimes if I stop playback and wait a second, then open it, I can get by, but in the heat of battle, I don’t always remember and inevitably, it will crash. Unfortunate and from your post, I’m beginning to think it is a Cubase/112db issue, not Mac or PC specific. Good luck

Thank you for the response btrox, nice to know I’m not alone. And interesting to see it’s not only related to Windows versions.

I’m afraid too this is the case. I have absolutely not a single VST in my collection that show similar behaviour. Normally I avoid plugs that crash the host, but the Big Blue ones do have an unique sound I really would like to add to the plug-in collection. :sunglasses:

I’ve also opened a Steinberg support ticket, unfortunately I haven’t received a response yet.

Any other 112db users feel free to chime in, if everything works as expected it’s good to know either.

Bit limited here. I’d go over to Sound on Sound and try there in a few forum categories and see what you get.
You’ll get more info at least even if no fix and you can go back to support with more ammo / info.
Might be more than just Cubase.

Thanks for the tip, it might be worth a shot too.

It seems the particular problem I have is very much related to the combination of Cubase and the x64 versions of 112db’s VST’s. In my other x64 host (Machine) the VST’s work as expected. This is also what the developer experienced with other hosts.
The only moment they could reproduce crashes on the system running Cubase, was by overloading it (which obvious could lead to crashes).

If the info stays limited here it’s indeed hard to feed it back to support or pinpoint my own systems failure if that’s the case.

:arrow_right: Niles, I have the exact same problem with (original) Redline Reverb (64bit) with larger projects. As soon as I click on the “e” (edit)-button I get this cascading error which not only crashes cubse but freezes my system eventually.

So, what was the outcome?


Thanks for the reply Captain Nemo.

112db was never able to reproduce the problem, so unfortunately they did not investigate it any further AFAIK.
Although I’m 95% sure it isn’t my system because those plugs are the only one’s I’m having trouble with.

I’ll redirect them again to this thread.

There’s also a thread on their own forum, feel free to chime in there.

edit: On the OP of this thread, my sig is attached with system specs, does you system show any similarity?

:exclamation: Thank you, I will do so.

:arrow_right: Yes, my system is more or less the same: i7, Win 7 64 Pro, 16GB Ram, Cubase 6.5.3.

:unamused: Niles, your private messaging seems to be deactivated, so take note:

:arrow_right: There is a problem to register at their (112dB) forum, so I send them an e-mail.

:arrow_right: I requested to register, but also mentioned and confirmed (with reference to your problems)my 64bit-issue with Redline Reverb on larger Cubase Projects.

I hope we can resolve this.


Just got this from 112dB:

:arrow_right: "Thanks for your email. I’ll check the links as soon as possible. Maybe
it will help us to reproduce the problem here. One of our programmers
found recently something in the code that might cause the problem that
you describe. Would you mind testing a new version, as soon as we have
it ready (were working on the MAC OS version at the moment)?

All the best,


Captain Nemo, yes I really hope it will be solved too, really love the 112db stuff.
Nousch did send me the e-mail too. Let’s hope the problem the programmer found is related to the crashes we experience.
Again, thanks for sharing!!

:arrow_right: Yes Niles, thank you for sharing, and doing it so comprehensive and meticulous!

Lets just keep tabs on them.
PS: Still cannot believe that we are the only ones to pic up on this so far…


:arrow_right: 112dB got back regarding a beta-version.

:exclamation: “Nouch” gave a link in order to try it out, but it (the link) does not work.

:question: Did you get any correspondence?

:exclamation: OK, the beta is it’s for Mac-users!


The link I mailed you pointed to the Redline Reverb Windows beta. At that time not officially released because it didn’t work properly in RTAS & Windows XP, but that wasn’t relevant in this case, so I hoped you would be able to check whether the changes we had made to the code would have solved your problem.

I’d like to clarify something I apparently didn’t make clear in my correspondence. What I meant to say is that if we can’t reproduce a problem, it makes it very difficult for us to solve it. The Reverb plugin consists of hundred thousands of lines of program code, almost each of which could be the culprit. Without being able to reproduce the problem here (which would allow for stepwise debugging) or a clear hunch what could be causing it there isn’t any easy way for us to solve it. All in all we spent more than a full day trying to reproduce this problem, and at some point I just have to say: that’s it, we’re out of options. We can’t identify the critical variable. That doesn’t mean we have given up completely. While working on the Reverb code for our latest update we’ve kept it in mind and have tried to identify potential problem areas. However, since like I said, we can’t reproduce the problem here, and as a consequence can’t tell if the changes we made have indeed solved your problem, we kindly ask you guys to try the new beta and report back:


Thanks in advance,