X99 realtime audio dpc tearing hair out

Hi all.

Hoping someone can offer me some help here before I lose my mind and more hours of my life

I upgraded from my old machine to a self build with
X99 gigabyte soc force motherboard
Intel 5930x
Ddr4 vengeance memory
Nvidia gt610 graphics
Samsung evo 840 ssd

I installed my audio hardware consisting of an rme hdspe pcie and 2 uad cards (one quad one octo)

Latency monitor shows up massive hard page faults.
Cubase realtime monitor is peaking and causing crackling on even a modest project at 128 samples.

I’ve put the cards so that none of them share an irq with the gpu
All drivers are up to date and am on nvidia v340 I think
No wifi
In the bios I’ve disabled cpu power enhancements etc. I’ve tried hyper threading on and off.
I’ve tried moving cards into different slots.
Latency monitor is saying the windows services host process is causing the biggest page faults With nvidia card next, storport.sys turns up a bit as does ndis,. I’ve also tried disabling the network port and various other hardware in device manager but nothing helps.
The only thing I can’t find in the bios is a way to disable onboard audio in the bios.
All are running at default speeds… Haven’t even tried over locking yet.
Would manually setting cas latency settings on the memory make any difference?
I can’t believe I’m getting so much trouble with this in 2014.

I have no such problems with a system that is better in some aspects, worse in others (GPU). I read somewhere about performance issues with faulty Nvidea drivers. I myself have an AMD 7970 GPU. I do not have the UAD cards, so those may be causing your issues.

So I also spent my weekend stressing - I noticed it started when I installed the my Nvidea Quadro k4200. My configuration is similar to yours though my audio is the Steinberg UR22 going through USB.
Intel i7 5820K
Asus X99-A (previously Asrock X99 Extreme 4- I thought it was the USB controller on the MB that was causing the problems so I had them switched)
16GB Kingston Predator DDR4
A few Samsung 850 Evo SSDs.

The funny thing is this - the problems started after I installed the Nvidia drivers. I transplanted the graphics card to my old PC with the audio interface- same drivers for each - NO PROBLEMS. So it tells me the graphics driver is not the main culprit. From what I can deduce so far- it is a combination of X99+ Nvidia +usb audio interface - which suggests there is an issue with the X99 USB controller. I am going to pick up a PCI-E - USB controller to see if that bypasses the problems.
So yeah… X99 might be dud?

Have you disabled all the power options in BIOS ? you should. Including C states and Thermal options. And check that you RAM is running at the right settings, more often than not the BIOS uses wrong settings, not that I think that would cause the issues, but you never know.

I also have big problems with my UR824.
I also upgraded my machine to a self build with
X99 gigabyte GA-X-99-UD4 motherboard
Intel 5960x
DDR4 32GB memory
Nvidia gtX980 graphics
Samsung evo 840 ssd
Cubase pro 8.05

All drivers are up to date for all components in computer.

I spent almost 100 euros at an engineer who is studying in all the combinations in computer, reinstall from, to the replacement the various components. Definitely, the problem is in collision drivers Nvidia graphics and UR-generation devices (drivers).Does anyone have a solution?

I have gotten things workable by basically doing every possible tweak there is including the powerstates mentioned above.

What has done the trick moreso is leaving Hyperthreading enabled in the BIOS and using Asio Gaurd. this maked my Realtime meter stay really low. I still have a few quirks to work out but Cubase 8.05 is behaving really snappy and no crashes to speak of in 4 days of busy operation- which is extremely encouraging!

Welcome to the club.

I’ve tried 3 different USB audio interfaces now and all 3, on any of the USB ports, whether they be 2.0, 3.0, Intel, ASmedia, or the other, they all behave the same. Randomly the device will stop responding, make a feedback sound, or buzz, any programs using audio at the time will lock up, tell me the devices is no longer available, or crash.

I had some success making the problem occur less frequently by updating my Intel USB host drivers directly from Intel’s site rather than from MSI’s site, which listed an older version. However, the problem is still there, just much less infrequent.

I also went as far as to order a PCIe to USB 2.0 card, to make sure my USB was indeed 2.0 and not 3.0. The damn thing wouldn’t work, prevented Windows from even booting.

I have formatted/reinstalled more times than I care to mention trying to find the point at which the problem starts in the insallation steps of hardware and drivers. From all the information I can gather we are somewhat screwed because:

A) Audio interface manufacturers do not intend on going to USB 3.0 in the near future
B) All of the get their chipsets from the same guys anyway.
C) USB 2.0 interfaces plain don’t work well with USB 3.0 ports as reported by many many users of all flavors of chipsets.
D) Even though my MB says it offers 4 USB 2.0 ports, the party responsible for its drivers has changed since the big players manufactured the audio interface chipsets and it therefore has problems.

I did research and tried to find an alternative. PCIe Audio cards are much much more money and most link to an external interface through a network cable which offers way more ports than I’ll ever use. Modern motherboards don’t offer Firewire and that is the only other alternative. I could always buy a Firewire card, but I worry that I’ll have the same problem I had trying a USB card in my PCIe slot.

I can only hope that someone will create a viable, well reviewed, cheaper and smaller (4x4) PCIe solution someday soon or that someone will get their drivers in order.

So far the $1000 upgrade from X58 to X99 with its corresponding CPU, RAM, and MB, has hurt me more than made things better.

I googled X99 as I was thinking of going dual 2011-v3

Theres LOTS of usb and other issues with X99 and some peoples boards are actually going up in smoke!

Wait till a rev2 board at least.

No problems here with Asus X99 deluxe… All good.

and which Audio Interface? Is it USB 2.0?

Lynx aes16e x 2. Lots of USB and Ethernet connectivity though… Avid artist stuff via eucon plus cmc remotes

As I suspected :stuck_out_tongue: PCIe.
Yea, most of my USB stuff works, just no audio interface. I think it demands much more than anything else.

There are USB 3 issues related to an Intel driver not compatible with Windows 8.1 I have found. Because I"m using a PCIe RME HDSPe soundcard that particular issue is not affecting me though I can see that users using external USB devices could be affected.

Interestingly (and much to my frustration) i stupidly assumed UAD would be supporting Windows 8 but I’ve since found out that this is not the case. Indeed using Windows Performance Analyser and a lot of studying up and asking at the excellent SysNative forum has led me to the conclusion that the UAD drivers have a bit to do with the problem. Theres a driver process constantly calling within itself for interrupts according to the trace which is hogging the system interrupts.

UAD support have currently nothing to offer me in terms of information of when and if they will ever support Windows 8. Had I known all of this previous to spending 4 days on the new install and test of the studio PC I would have used Windows 7.

I am on 7. I have a feeling you would still be having problems.

Same issues here.

My configuration

  • X99 gigabyte GA-X-99-UD4 motherboard
  • Intel 5960x
  • DDR4 32GB memory
  • AMD Radeon R9 270X graphics
  • Samsung evo 840 ssd 500 GB + 3x Seagate Barracuda 2 TB
  • Win 81
  • RME FF 800 (via Sonnos Allegro PCIe Card)

I tried alternatively an FF 802 and Babyface via USB: no improvement.

I tested with a clean win81 setup, no further programs or drivers installed beside the audio driver for the Interface and VLC for DVD playback. Even a simple playback of a stereo video (from HDD!) generates errors.

Strange: Changing the buffer size (latency) does not have any impact on the issues. I checked all Options between 48 and 2024 samples.

13.3.: Meanwhile the issue is solved. It’s a conflict between mobo and the graphic card. I switched to Nvidia GeForce and so far everything seems to run perfect.


I’ll try to give you some ways to fix your problem. I hope it will help…

1- On MOBO make sure that you are not overclocking right now. Turn off the xmp or just profile 1 not 2…

2- Go to PCIE slot management it must be in PCH, it’s the page you’ll see all pcie slots and you can read their working speeds (x1,x4,x8,x16) etc and gen informations…

3- If your Sound Card’s speed and the slot information don’t match just change the pcie slot you must do it for UAD’s too… My recommendation: Put graphics card to 1st slot, put audio interface to 3rd slot and don’t put UAD’s yet. when you make sure that pc is stabile then you ll add UAD’s…

4- Now go back to BIOS again if you see any ASMEDIA sata_express controller etc, disable them…

5- Go to boot section disable fast booting…

6- Don’t change CPU settings etc. Your problem is nothing to do with hyper threading etc.

7- Boot your pc now. If it stucks in the half way, while the windows logo shows up and it just gets frozen, unplug all of your usb 3.0 ports, plug your keyboard to usb 2.0 then boot again it will work…

8- When you are on windows go to device manager make sure that HD Audio is disabled, if not go to its properties and disable it, don’t uninstall it just disable…

9- Then without putting in UADS check the problem is gone or not?

10- If not solved go BIOS and make sure your soundcard pcie speed and gen is matching. It must be less than x8 I guess… First just change the slots. ıf it doesn’t help manually change the speed to x4 and gen to 2.0. If it crashes just carry the GPU to 3rd x16 slot and put the Soundcard to that little x1-x4 slot.

11- If problem solved now install the UAD’s with their 8.3 update. Not 8.4…

12- after putting the UADs to Mobo then check their speeds. They must be x1… and max gen2.0

13- if it crashes just unplug your usb devices and try again it will boot. If it doesn’t boot then change the UAD slots.

14- By the way I recommend going one by one don’t install all the UADs together

15- after installing and going under windows make sure they are all well from device manager. If there is a not working properly device appeared just search for it if it s not an important device like external thermal sensor etc or bluetooth just disable it…

— Maybe you don’t need to do all of this you must first check the PCIE slots speed and GEN, I think it’s causing the unstable spikes etc…

If al these just don’t work and makes it even worse clear bios

All off you facing these kind of problems you can all try these steps too…

Good Luck…

One last thing : IF YOU CRASH BOOTING Just try to unplug the USB devices…