'y' shortcut in percussion notation

Hi there,

I love the recent 1.2.10 update so far, but I thought, it was going to fix an issue with the well-featured shortcut “y” for note input on the current caret position on unpitched percussion staves. On my german keyboard, ‘y’ and ‘x’ will zoom in and out. So I thought, it might be ‘z’ on a german keyboard layout, but that won’t do anything at all and I don’t know / can’t find the proper funtion to reassign the ‘y’ key to in the settings panel either. I tried to find a thread on this, here in the forum, with no luck. Is there any way to get this feature to work for me?

Thanks a lot for your help!

Sorry for the inconvenience! I don’t remember this issue being reported, so I’m afraid it wasn’t on our radar to fix. It is certainly meant to be “Z” on a German keyboard: that is what is defined in the default German key commands.

It should be easy enough for you to fix, though: open up your keycommands_de.json file from /Users/your-user-name/Library/Application Support/Steinberg/Dorico (Mac) or %APPDATA%\Steinberg\Dorico (Windows) in a text editor (preferably a good one with syntax highlighting and balancing for the JSON format, as it’s very easy to inadvertently mess up a JSON file so that it can no longer be loaded).

Paste in this chunk:

						"context" : "kStepTimeInput",
						"shortcuts" : [
									"NoteInput.Pitch?Pitch=X": [ "Z" ]

If you can already find “kStepTimeInput” in the file (because you’ve overridden another note input key command), then you can just take these lines:

									"NoteInput.Pitch?Pitch=X": [ "Z" ]

and put them in the right place. Put it first in the list after the line “shortcuts”: [.

Replace “Z” with whatever key you think this should use: let me know what you decide to use.

Thanks a lot! That’s why I love this forum and your direct support. Now, it works as expected. For your interest: In my JSON file, it was originally set to “NoteInput.Pitch?Pitch=X”: [ “DELETE:Z” ]

Aha, good, so in fact I think it probably will work for other users with German keyboards out-of-the-box. That’s a relief!

Is there any reason this can’t be changed from the shortcut editor in Preferences? It’s a little scary to have to mess with the JSON-file directly…
I’m using the English version of Dorico, but I had assigned y as a shortcut for something different before 1.2. Since my customized shortcuts are now kept with updates (and thank you for that), I don’t have any key for percussion input.

The only reason it can’t be changed directly within Dorico is a boring technical one, I’m afraid, and one that we will hopefully be able to address in a future update.

I’m still curious why it wasn’t working for me. Other key commands in the JSON file, like Shift+Alt+left/right also have the DELETE prefix, but they work like a charm.

I am trying tu input a note on current caret position on unputched percussion by pressing „y” key. It’s not working. What am I doing wrong?

You’re almost certainly not doing anything wrong. Unfortunately the note pitch shortcuts don’t show up in the Key Commands editor for boring technical reasons, so there’s no easy way for you to go and check what is actually assigned directly in the program. You would need to have a look at the keycommands_en.json file (though your file may have e.g. _de.json at the end if you use a German keyboard) in your Dorico application data folder, and see if the shortcut “Y” is assigned to anything else in there, or indeed if it is shown as “DELETE:Y” in there, in which case that shortcut has somehow been explicitly removed.

I found “keycommands_en.json” and there is a sentence: “NoteInput.Pitch?Pitch=X”: [ “Y” ].
So I suppose the problem is not there, am I right?

Indeed, that looks correct.

So, anyone have idea why “y” command dosen’t work?