Yamaha Digital Piano USB MIDI - Speakers

I am using Yamaha P-105B digital piano as MIDI controller with the latest USB MIDI driver 3.1.3.

When I use this piano with Sonar, its speakers mute automatically once connected with Sonar.
This automatic mute doesn’t happen with Cubase! And it’s annoying because each time I have to turn its volume to zero, otherwise I will hear all my MIDI playing through the piano’s speakers! Moreover if I forgot to turn on the piano “before” opening Cubase, Cubase just doesn’t see it! Sonar didn’t care it will add it even if shut down in the middle of the session and turned on again.

Anyone can help me in this please?

Your piano doesn’t mute when connecting midi to sonar, that doesn’t make any sense. I think what’s happening is you’ve got local control off on your piano and Sonar isn’t set to midi through, while Cubase is. Disable midi through in Cubase and try again.

As for Cubase not detecting USB devices when they are powered on after Cubase is started: yep, that sucks.