Yamaha Steinberg USB Driver 1.10.3 fails to install on Windows 10

I am not sure if this is the right forum, but I cant find out where else to post it. I have the CI2+, so I guess its alright here.

I cannot install the new Yamaha Steinberg USB Driver 1.10.3. It pops up with an error not possible to write the registry value. The previous versions doesn’t have this problem. I have tried running as admin too, but it doesn’t help. I’m on Windows 10 (1809. The problem also happened with the 1803). Here is a screendump of the error message:
Screenshot 2018-11-24 20.02.08.png
There is also an error on the download page, where the wrong version is written. The rest of the text is from the former version too.
Page: https://www.steinberg.net/index.php?id=yamaha_steinberg_usb_driver&L=1

Windows only: The Yamaha Steinberg USB driver V1.10.1 solves a problem in which audio drop-outs may occur on systems that do not generate a proper USB time stamp information. The USB time stamp refers to the USB frame number on the USB data stream. During our tests to reproduce the issues reported by customers, we found several systems on which the USB frame is not being generated reliably.

I see you fixed the text on the download page, but you still haven’t replied to this post about the problem I have?
So when I saw you fixed the text I decided to download the driver again (even though it still says its the same version), and it still doesnt work.

Have you uninstalled the previous version first? Try that, then install 1.10.3.

Yes, I did uninstall the previous version. It doesn’t work on my machine.
I think it installs the files, but it fails to write the settings to the registry.

Hi,
Try installing it as an Administrator. Right click the installer file, choose ‘Run As Administrator’. Does that solve it?

I tried that and that didn’t work. But I just found the solution. A Waves driver was running, so I killed it in taskmanager, and then I could install it.

I’m pleased you found the answer. :smiley:

Just to inform, I ran to the same problem with the driver version 1.10.4 and Windows 10 version 1909.

I managed to fix it by taking ownership of these folders and applying full permissions:
C:\ProgramData\Yamaha_Uninstaller{2938B185-2D57-47B0-9FC8-C90A67BA9277}
C:\ProgramData\Yamaha_Uninstaller{B9ADCE53-BBF4-4F12-BC0C-1B2E150850C7}

Then I ran manually with “Run as Administrator”, (instead of opening it from Control Panel / Sound):
C:\Program Files (x86)\Yamaha\Yamaha Steinberg USB Driver\ysusb_cp.exe