Yamaha Steinberg USB Driver 1.9.5 for Windows 10

Steinberg has released the Yamaha Steinberg USB driver version 1.9.5 for Windows.
The driver now supports Windows 10 and resolves the audio issues.

The updates of the TOOLS for UR44, UR28M, UR824 and UR242 will follow soon but the new driver can also be used with the current TOOLS versions!

The update for the UR12 can be found here.
The update for the UR22 can be found here.

Hi,

Is a driver with 32 samples buffer size provided soon for the UR22 ? It will be very nice !

Hi.

For me there is still problems running in high sample rate. Alot of programs has weird sound problems when running with high sample rate.
The sound gets laggy and distorted. This happened in Google chrome, and alot of other programs.
First i fixed it in chrome with some audio buffer command, but they fixed it in their last update, but its still a problem in other programs.

Anybody with this problem too?

Yes ! i have this problem too ! i run cubase in 88.2 mhz and when i go in YouTube for example, the sound is alterate … slow laggy and distorted too …

Same problem for me (i am using cubase in 88.2 mhz)…

When I click Playback Devices I can’t adjust Default Format (only 2 Chanel, 24bit, 48000 Hz).

Driver Win 10 is error ?

I’m actually having a lot of audio dropouts on Windows Pro 10 64bit with the UR22. Not even a year old. I have the 1.9.5 Win10 driver, but not matter what I use it in (PT10, Firefox, VLC, Musicbee, etc.) I get consistent audio dropouts. Steinberg support doesn’t help me anymore and I’m really at a loss. I’ve tried using an old Focusrite Saffire 6 USB running on a win7 driver and it has no dropout issues whatsoever, but a terribly low output. Any suggestions?

Here is my computer specs:
Intel i5 4690k
16GB RAM
ASUS z97 PRO4 mobo
120GB SSD
3 other HDD’s (One 7200rpm 1TB HDD dedicated for PT useage)

HI,

i’m agree with you, i’ve experienced same problem and steinberg support is awfull, never respond to messages. i’m waiting for response since one month ; i’ve asked if there will be a new driver with 32 buffer size samples planned, because 64 buffer samples size is now ridiculous comparing to other audio interfaces, who offered 32 samples,but no response…

My system is win 10 pro 64 bit. Driver Ur 22 is conflict with usb of allen heath zed 14. The programe I can use with scarlet 2i2. But can’t use with ur 22

Driver is very bad. In my program used Scarlet 2i2 with 32 sample is good. Ur 22 with 192. Disapointed

It would be very useful for us to choose 32 or 48 samples in the driver menu. Please review it in the next driver.

Thank you

I am having the same problem have you found a fix ?

I have 2 channle, 24bit and 44100 Hz set, cannot change it either.

I think it is realted to my finding I have described in another thread: https://www.steinberg.net/forums/posting.php?mode=quote&f=157&p=527248

On Win 10 64 bit here, getting dropouts regularly on lower rates like 44k and 48k, even worse if I am creating content in 96k sometimes the driver straight up crashes (Sometimes when audio is not even playing!) and I have to power down my mixer. This is a brand new system built from the ground up I find it hard to believe it is anything on my end hardware wise besides the mixer and drivers which I probably will have to return now since it won’t even do what it says on the tin. Hopefully Steinberg will figure out the issues with Win10 soon.

Has anybody found a fix to this yet? My DAW is forcing me to work in 44.1 even though my console is built for 192, I can’t change anything in windows or my DAW, its all completely locked out.

Thanks guys.

This post is a little old but I am having an issue with changing the Default Format.

I am using the USB driver for my A-S801 amplifier and in order for Tidal to work correctly I need it to be 16bit, 44.1 CD Quality, however, as mentioned it is set at a higher rate. Has anyone figured out if this can be changed or not? I have installed the newest version of the driver. 1.9.9 and this has not solved anything. Any help would be greatly appreciated!!

I recently had issues getting the PC to change to 48khz to sync with a Yamaha TF3 Sound board. And I found the way to do this by reading the PDF help file.

Go to Windows 10 Control Panel, Hardware and Sound, and then look for the Yamaha Steinberg USB Driver option in the list. Mine was last on the list. Then select the Yamaha TF tab and there you can select 48khz!