Zoom behaviour - Cursor vs. Locators

Hi everyone,

trying to figure out whether this is intended or not. When using Zoom in / Zoom out key commands, Cubase would center the Locator selection ONLY when the Cursor is outside the current screen view.

In other words, once you zoom out to the extend that the cursor becomes visible, it would instantly center and zoom towards it, instead of the Locators selection. I find this pretty annoying, and it behaves differently when using the mouse wheel and modifier. I am using a pen tablet so…

It practically always clips half of my Locator selection outside the screen to the right. See the attached screencaps.

Is there any way to change this behaviour? Thanks in advance.

Hi,

This is the way, how is specified in Cubase.

I know this is all quite vague but I seem to remember having a similar irritation with a previous version of Cubase a while back - if it helps I think I set up a key command to Zoom to selection and then just hit that key to zoom out to the selected part that I was working on, regardless of where the cursor was. Otherwise you could fiddle about with some key command macros, bit of tinkering!

But the way - do you have Autoscroll set up to follow cursor in Preferences, if you turn that off maybe it wont try to lock onto the cursor…

Here’s what I suggest.

  1. Record your tracks
  2. Zoom Full (Shift+F) and select the recorded parts
  3. Select those and hit “P” for Part
  4. Create a Marker Track and create a Cycle Marker for the Part. The cycle marker track has a drop down list for “locate, zoom, cycle” Markers can be named – Intro, Verse, 1st Movement, 2nd Ending, Rehearsal Letter B, whatever you need.

In Preferences, under “Editing” there’s a choice that says, “Cycle Follows Range Selection.” You might want to experiment with that. I keep that off as default, but have used it it seemed better for the kind of editing I was doing.

Make G and H your friends for basic zooming, there’s a macro for zoom to project (Edit, Macros, Zoom to Project). You may assign some Zoom States to key commands or, if you have one, to buttons or pads on a MIDI Controller or other attached controller.

Found it in the manual, it really is specified this way, as Martin noted. Regarding macros for workarounds, I suppose there’s little left of the Cubase’ defaults in my setup, including shortcuts.

I think this could be a (not so) small feature request, as it is quite annoying, at least to me.

Yeah, I don’t like the cursor grabbing the zoom centre, because sometimes I need to zoom just to check something, then zoom right back in again, and this behaviour doesn’t zoom back as I’d like.

A more logical behaviour to me is that zoom centres on the cursor if visible only when I have Auto-Scroll (F) ON. When OFF then it would zoom around the centre of the screen at all times.

(AutoScroll is mentioned above but it doesn’t make any difference it still zooms around the cursor if it’s visible!)

There is a quick way of storing a zoom setting called Zoom MEM, and it’s counterpart to recall the stored setting is Zoom ZAP. These two I think are only available as shortcut key options. So, with these two defined you can MEM the zoom, zoom about, scroll about, etc, then ZAP the zoom back to what it was before.

Mike.