1.1.61 Issue: VL not saving lyrics

I’m not sure if I’m doing something wrong, or there is an issue with VL. Here’s the background:

  1. All of my projects include a “lyrics” track for our singer(s).
  2. Open VL - Select “new project”
  3. File → Import Media Project…
  4. Navigate to: /Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Get Down Tonight/Get Down Tonight.vlsprj
  5. Select the “Create New Song” checkbox and click Open
  6. Select the “Lyrics” tab and confirm lyrics are present.
  7. Import a second media project using steps 2->6
  8. Save the VL project to /Users/ericwentz/Documents/Musical/TTB/VST-Live folder
    9 Quit VL, relaunch and open the project saved in step 8
  9. The lyrics in the first two songs are present.
  10. Import a third media projects using steps 2-6
  11. re-save the VL project
  12. quit and relaunch VL
  13. All the lyrics are gone.

One note, my “Documents” folder is mapped to my iCloud account so all the paths in Finder are:

All the media projects are under the “Rehersal Tracks” folder - these are all Cubase 12 projects.
VL-Test.vlprj.zip (304.9 KB)
Here’s the project file for the above scenario.
Thanks in advance - eric

Your VST Live project expects the following - do these files exsist?

“/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Get Down Tonight/marker/11510045464981094706_1283759950104316059.mprjmarker”
“/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Go Your Own Way/marker/15508578611702288107_9540908927797710056.mprjmarker”
“/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Has Anyone Ever Written Anything for You/marker/3272872905623814909_10703463706598592177.mprjmarker”

I just checked and none of the files you listed exist. Here are the contents of the 3 folders:

/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Get Down Tonight/marker
ericwentz@mini marker % ll
total 40
-rw-r–r-- 1 ericwentz staff 1125 Mar 31 09:47 11510045464981094706_11193122144003116597.mprjmarker
-rw-r–r-- 1 ericwentz staff 1616 Mar 31 09:51 11510045464981094706_1283759950104316059.mprjmarker
-rw-r–r-- 1 ericwentz staff 1606 Mar 28 15:48 11510045464981094706_15844158813351004849.mprjmarker
-rw-r–r–@ 1 ericwentz staff 1606 Mar 31 09:38 11510045464981094706_7051362229145846803.mprjmarker
-rw-r–r-- 1 ericwentz staff 1137 Mar 14 09:28 257630194221991823_1642112853433337446.mprjmarker
drwxr-xr-x@ 2 ericwentz staff 64 Mar 14 09:28 Gig
ericwentz@mini marker % pwd
/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Go Your Own Way/marker
ericwentz@mini marker % ll
total 32
-rw-r–r–@ 1 ericwentz staff 1397 Mar 31 09:38 15508578611702288107_12110392554277195436.mprjmarker
-rw-r–r–@ 1 ericwentz staff 980 Mar 31 09:49 15508578611702288107_12968831015384927468.mprjmarker
-rw-r–r-- 1 ericwentz staff 1397 Mar 28 15:48 15508578611702288107_7637731745507724297.mprjmarker
-rw-r–r-- 1 ericwentz staff 1397 Mar 31 09:51 15508578611702288107_9540908927797710056.mprjmarker
drwxr-xr-x@ 2 ericwentz staff 64 Mar 27 10:55 Gig
ericwentz@mini marker %
ericwentz@mini marker % pwd
/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Has Anyone Ever Written Anything for You/marker
ericwentz@mini marker % ll
total 8
-rw-r–r-- 1 ericwentz staff 1036 Mar 31 09:52 3272872905623814909_10703463706598592177.mprjmarker
drwxr-xr-x@ 2 ericwentz staff 64 Mar 14 13:26 Gig
ericwentz@mini marker %

Hope this helps -e

Confused, you say here are the contents…let’s stick to one of those.
You name folder

and file

But that’s exactly what my first reference was…so what am I missing?

You’re correct - those files do exist. Here’s the interesting thing: Check this out:
ericwentz@mini marker % pwd

/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Get Down Tonight/marker

ericwentz@mini marker % ls 11510045464981094706_1283759950104316059.mprjmarker


ericwentz@mini marker % ls “/Users/ericwentz/Documents/Musical/TTB/Rehersal Tracks/Get Down Tonight/marker/11510045464981094706_1283759950104316059.mprjmarker”

ls: Down: No such file or directory

ls: Tonight/marker/11510045464981094706_1283759950104316059.mprjmarker”: No such file or directory

ls: Tracks/Get: No such file or directory

ls: “/Users/ericwentz/Documents/Musical/TTB/Rehersal: No such file or directory

ericwentz@mini marker %

So, if i just use the file name within the directory, it finds the marker file just fine, but if I use the complete path, something is fishy. If I cut and paste the full path from the posting, I get the error listed above - while, if I build up the path a bit at a time, I can list the file correctly. I looked at the file paths that you posted in your first response with a hex editor and noticed that the double-quote was missing from the string - looks to me like the path quotes may be missing from the marker file?

One more thing: attached is a file that I created using: first, a copy/paste of the path you gave me in your first response and, second: my hand-crafted path. Note that the first one failed while the second one worked. Even though they look the same, the hex dump shows some differences.
files.txt.zip (681 Bytes)

Presumably, this is the same problem as here, so pls give it a try with the next version.

Yes, it sure does. I thought for a minute that it had to do with the fact that I had file names with spaces in them - tried making the change and it didn’t help. Would sure like a fix by Wednesday (4/5/23) as the band is coming over for rehersal & I’d like to be able to demo VL to them. Thanks & as always, good working with you. -ew