[1.4.4]: "Record Main Output to local folder" recording in different scale

I recorded my live playing to wav file with the “Record Main Output to local folder” option.
I played in Em scale, but when I played the recording, its in Gm scale.

1 Like

How do you tell, that is, how do you play back the file?
Can you check if the file has the same sample rate as VST Live was set to when recording?
Thanks!

Sounds, that it was recorded with 44100 and played back with 48000.

So how (with which application) did you play it back? VST Live?

I used vnc player to play back the file. I will try to play the file inside vst live and see…

i tried playing the recorded .wav file with vst live and i still hear its playing in a different scale (Fm) than the one i originally played while recording…

To avoid further confusion i tried recording new audio with Em and played via VNC player and via VST Live, both playing in Fm.

Am playing the audio via the Focusrite USB audio and this is the settings am seeing in windows.
image

image

I tried doing the same kind of recording in Cubase 13 Pro and exported with the below settings and it plays (via VLC player) to the correct scale I played and recorded.

image

no doubt, just wnted to know what the file sample rate is, and what VST Live audio device sample rate was when the file was recorded. Those should match.
Will check what can go wrong.

We finally found the bug. VST Live accidently sets the recorded files’ rate to 48000, no matter what.
If your recordings are vital, there are tools to set the wave file header to 44100. Or use Cubase resample function.
Sorry, and thanks for reporting! Will be fixed with the next version.

1 Like