[1.4.53] Halion Sonic pan positions and levels lost

Caveat: not sure if this is 1.4.53 specific or was already the same before and if this is a Halion Sonic or a VST Live problem ….

Just noticed that pan positions (and sometimes levels) in layers using Halion Sonic are not retained across song changes.

Small example: empty VST Live test project, created a song with a single Halion Sonic layer, three arbitrary sounds layered in there with the same MIDI channel, panned center, hard left and right, different levels:


Then I save the VST Live project.

Then I create a second song, completely empty, does not make a difference which VSTs I use there.

When I switch back to the first song, all Halion channels are now centered:

Maybe VST Live is sending the default pan value of “Center” (which I did not touch) to Halion Sonic?

In this example the levels did not change, sometimes also the levels in Halion Sonic are set to the same value for each sub-channel.

Tried to save the path for song 1 as a multi-program, put this program in a multi-chain and then set up the layer in song 1 to switch to that program in the chain. Still the same behavior. When I open Halion Sonic the program in the multi-chain is shown as selected but pans/levels are wrong. When I manually reselect the multi-program everything is correct again. So whatever messes up the pans happens after the initial program change.

Thanks for your support,

Additional observation:

Seems to work fine (correct pans / levels after song changes) when I assign all sounds in Halion Sonic to MIDI channel 2 and change the layer’s output channel to send on channel 2.

Level and pan are set by the layer. So I think, this will overwrite your settings in Halion, whenever it becames active.

This is what I initially assumed … I did not touch the layer’s level / pan setting but maybe they are always sent.

But then how would I approach using a complex layered sound from Halion Sonic without level balance and pans being messed up by VST Live?

And why does it suddenly work without any mess up when the Halion programs are using MIDI channel 2 (and I route the layer from MIDI 1 to 2)?

Default for MIDI is “NOT SET” (ctrl/click), which means nothing is ever sent.

If set to anything else, that value will be sent whenever the Layers’ Part gets selected.
And if you have 3 Layers all sending to the same MIDI channel, the last one created will probably “win”.

For shared Instruments, when you change MIDI Volume or Pan in one Layer, other Layers sending to the same Instrument instance on the same MIDI channel are linked.

So, just set it all to “NOT SET”, and only change one, if you even have to. I’d rather set it in the Instrument directly, which then keeps it in its settings.

Good hint, indeed this was messing with the Halion settings.

But as I noticed in an empty test project, “NOT SET” seems to be the default only for MIDI volume, not for MIDI pan:

If I leave it this way, it will mess with the Halion pan, I need to expicitly clear out the MIDI pan with a Ctrl-Click:

Maybe it would be good if by default both MIDI volume and pan would not be sent.

It is default for Pan as well. But if you “Save Default Layer” you may have changed that?

1 Like

Indeed, this is where the centered MIDI pan came from :man_facepalming: . No idea when I changed this, normally only using the audio mixer.