1. Layout and 2. Playback

Good evening friends:

I installed and authorized Dorico from the DVDs - smooth experience. Love the GUI and the integration with midi piano roll view.


  1. Layout - please look at the attached screen capture, an XMLimport from Sibelius (Star Wars main theme). In Galley it looks very good, but in Page View it is a mess. See capture 1. Is there an “Optimize View” button to quickly format the entire score, similar to Sibelius? To compare, capture 2 is the Sibelius screenshot.

  2. Playback quality is pretty bad to say the least - even general midi in Sibelius sounds better. I watched the mixer, nothing is moving, did I choose a wrong playback configuration?


Hi Peter,

would have been good if you had made two postings out of this.

For your first question, I’m sure Daniel will say something.

On the second matter, what is actually so bad that you are experiencing? Do you have drop outs? What is the spec of your machine where you try to play back? Could you maybe do an audio export to MP3 and attach here, so we can listen to?


Dorico doesn’t import the page or staff size information from MusicXML files, so you should find that all you have to do is go to the Page Setup page of Layout Options to set the page size to e.g. Tabloid and experiment with changing the space size.

Thanks Daniel and Ulf - about the layout, yes, Daniel, that’s it. Still a few conflicts but after adjusting the page size to tabloid and making the staff size smaller, it looks much better.

About playback, below are links to renders from Dorico as well as a render from Sibelius (can’t attach mp3 files). It’s only the first 30 seconds or so (roughly measure 29). The Dorico mp3 render is different from what I hear when I press the playback button, by the way - playback in real time the music is still recognizable. Playback in Sibelius is using NotePerformer, by the way, and Spaces reverb.

Here is a sound cloud link to the Dorico render:


And here is a link to the sound cloud link to the Sibelius render:


(On a side note, these are private uploads).

Computer specs: Windows 7 64 bit professional, core i7, 24 GB of RAM, three internal drives (this was a laptop custom built by PC Audiolabs several years ago). It can handle quite large film scores and heavy VST (Eastwest Hollywood orchestra etc.) so logically it can’t be the computer - I am assuming I must have something set up incorrectly in Dorico.

Maybe I should recreate all staves and copy and paste the music over? I know in Sibelius you get whacky playback unless you let Sibelius choose the instruments for playback but I don’t know how Dorico works.


ps forgot to say, sound cars is an M Audio projectmix (old model with motorized faders), set to “Cubase”. In Dorico I used the M-audio ASIO driver.

Hi Peter,

when I follow those 2 links to souncloud it says “this track was not found.”

I’ll send you via PM a link to my ftp site, could you please upload to there?


Hi Peter
Could you PM a link to the Dorico score for this? I’m currently looking at playback.

Hi Peter,

I got the audio files now, and true, it does sound very poor. You should definitely get better results.

I suggest you adapt the HALion settings for a bigger number of voices and multi-core usage.
Open up the HALion Sonic window (go to Play Mode, in the instrument list on the right, press the little ‘e’ button left of ‘HALion Sonic SE’), then in the upper part of that window there are 5 buttons: Edit, MIDI, Mix, Effect, Options. Click the Options button and in the ‘Performance’ section you’ll find parameters where you can tweak HALion. First of all, make sure that the Multi-Core setting is set to the maximum, probably 8 in your case. Next, increase the number of Max Voices, it can go up to 1024. You can even fiddle with the numbers while HALion plays back. In the upper right corner of the HALion window, left of the Steinberg logo is a little field just named ‘#’ which shows the currently used number of voices. Especially with orchestral works that use lots of HSO sounds, this number can easily go up to 500 and more. The settings of this Option page apply on a per instance base, so if you have 2 or more HALion instances (windows) make sure you adjust the settings in each of them.

Please play around with those settings and let us know if that gives you the expected playback experience.


Hi Ulf:

I did as you suggested, changing the maximum amount of cores to 8 for both instances of Halion, and the voices to 512. See picture attached. However, playback hasn’t improved.

I also experimented with different drivers for my soundcard (the “generic low latency ASIO driver”, the dedicated driver that comes with the M Audio Projectmix soundcard). Doesn’t make a difference.

Question: if you play back the Dorico file on your computer, do you get the same experience?



There is one thing I discovered, by the way, which is partly responsible for the whacky playback: the tempo is off.

  1. In bar one, instead of quarter note = 108, I have quarter note = 70;
  2. In bar / measure 4, the meter goes from 4/4 to 2/2. In the Sibelius score (and in the Hal Leonard “John Williams signature edition” from which I am transcribing) the indication at this point is L’istesso (meaning quarter note = 108 goes to half note = 108).

I’m trying to figure out how to change the tempo … double clicking on the metronome marking doesn’t do anything. Nothing in the FAQ or the web videos … can’t find anything googling the web, or searching the forum. Can you help me out here?

It’s probably going to take me a while getting up and running with Dorico! :laughing:

For some instruments you need to increase the polyphony for individual instruments from the default 16. The control is on the “Edit” page of the HALion window.

That has a huge effect on some patches - e.g. it turned the solo contrabass patch from the sort of scratchy noises a complete beginner might make, into a contrabass.

I haven’t investigated in detail what a “good” setting is - I just set all the track “polyphony” controls to the max (128) and the max total polyphony to 1024. With plenty of RAM and a fast CPU, there doesn’t seem to be any collateral damage from doing that.

You can see the max polyphony for all the channels displayed near the top of the HALion window - there is a field labelled “#”. There doesn’t seem to be an easy way to get the number for individual tracks (e.g. soloing the track doesn’t work).

For editing the tempo, have you discovered the Properties panel (Ctrl-8) in Write mode yet? Open that, select the tempo mark, and follow your nose.

Thanks Rob - got the tempo sorted out (Shift - T) (though I’d like to move the second metronome mark to the right, it’s now positioned too far to the left - but that’s for later).

About the polyphony, isn’t # the amount of voices? I set the max to 512 and when looking at the voices, it stays well below that (a little over 100 during the busiest passages).

I think the # tells you how much polyphony HALion wants to use. If the “max” limit is lower, samples get skipped or truncated.

Playing a single note on some of the string patches can have several samples for attack, the main note, and the release. I guess the instrument body resonance samples continue to sound after the end of the written note.

The first version of Dorico doesn’t attempt to playback articulations, etc. I don’t know what (if anything) it does importing “MIDI performance data” in MusicXML files, but since different sample libraries use different methods to control playback, even for basic things like dynamics, any data in the MusicXML might not make any sense except with the original sample libraries.

Thanks Rob. The amount of voices used in both instances of Halion is well below the set maximum (512), so it can’t be a polyphony issue.

About MusicXML — I am not sure what exactly is exported from Sibelius, the Sibelius documentation is pretty vague about that.

Well, the Steinberg gurus (Ulf and Paul) have my Dorico and Session files, plus the mp3 exports … given that Steinberg invented the VST standard, I’m pretty sure that they’ll be able to figure it out. I know that the audio engine is still in its early stages and things like technique text is not implemented in terms of playback, but right now the playback is unrecognizable … even to Star Wars fans.

On tempo, I’m still not quite sure that I got that right, either … I got the metronome marking in, but it doesn’t seem to have any effect on playback, and it’s in the wrong place, and different places when I switch back and forth between Write and Engrave mode.