10 crashes in 2 days. Crash Report attached.

Attached is my crash file.
I’d love some help with this.

I was remarking how smoothly Cubase had been running, now I have multiple crashes going on and it’s not something specific.

–Crash loading the GGain plugin.
–crashed three times just initiating the “save as template” command from the menu.
–Crashed clicking the “plugin report”.
–crash when trying to swap a plugin for another one on the same insert slot.

Yesterday, I got the MAC OSX error “your system has run out of application memory”.
I closed everything, restarted ,trashed preferences
(just copied over a few files from my saved prefs, like key commands, etc.)

Recently, I bought and installed some Waves plugins, the latest versions, and loaded a few of those into my project.

I thought this may be a hardware memory issue, but it doesn’t appear to be after some testing.

Please help.
Cubase 10.5_2020-09-14-133442_Macintosh-2.crash (290 KB)

Hi,

The crash is in the VST Prefetch thread, but there is no Cubase or any plug-in mentioned in the thread:

Thread 210 Crashed:: Vst Prefetch Thread 0
0   libobjc.A.dylib               	0x00007fff6dab131c objc_release + 28
1   libobjc.A.dylib               	0x00007fff6dab211a (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 710
2   libobjc.A.dylib               	0x00007fff6dab4e9f (anonymous namespace)::AutoreleasePoolPage::tls_dealloc(void*) + 97
3   libsystem_pthread.dylib       	0x00007fff6f4776ab _pthread_tsd_cleanup + 551
4   libsystem_pthread.dylib       	0x00007fff6f47a655 _pthread_exit + 70
5   libsystem_pthread.dylib       	0x00007fff6f4772f6 _pthread_body + 137
6   libsystem_pthread.dylib       	0x00007fff6f47a249 _pthread_start + 66
7   libsystem_pthread.dylib       	0x00007fff6f47640d thread_start + 13

Do you have the latest Waves version installed, please?

Could you try in Cubase Safe Start Mode [Disable preferences], please?

Thank you, Martin, for your quick help.

Waves central is not indicating that I need to update the plugins, and they were just installed through that interface. I presume they are up to date?

I will try Cubase safe start now and report back shortly… though I did do the trash prefs thing already, just not completely new - I had copied over several of the files. I’m going to hide my Cubase prefs folder, rename it and start fresh. Cubase without 3rd party plugs seemed to act fine, though I wasn’t working it hard with the project I had been working on.

Here’s some data from 2 previous crash reports: (i have several of them)
A common theme is the Exception type, code, and note listed directly below: exc bad access (sigsegv), kern invalid address, exc corpse notify…


Crashed Thread: 55 Baios Processing Thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000010eb28bd8
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [3528]

VM Regions Near 0x10eb28bd8:
VM_ALLOCATE 000000010ea29000-000000010ea2c000 [ 12K] rw-/rwx SM=PRV
–>
dylib 000000010eb4f000-000000010eb9c000 [ 308K] r-x/rwx SM=COW

Thread 55 Crashed:: Baios Processing Thread
0 libobjc.A.dylib 0x00007fff58e3231c objc_release + 28
1 libobjc.A.dylib 0x00007fff58e3311a (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 710
2 libobjc.A.dylib 0x00007fff58e35e9f (anonymous namespace)::AutoreleasePoolPage::tls_dealloc(void*) + 97
3 libsystem_pthread.dylib 0x00007fff5a7f86ab _pthread_tsd_cleanup + 551
4 libsystem_pthread.dylib 0x00007fff5a7fb655 _pthread_exit + 70
5 libsystem_pthread.dylib 0x00007fff5a7f82f6 _pthread_body + 137
6 libsystem_pthread.dylib 0x00007fff5a7fb249 _pthread_start + 66
7 libsystem_pthread.dylib 0x00007fff5a7f740d thread_start + 13

.
.
.
.
.

and here’s the other one:

.
.
.
.
.


Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000001170746d0
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [2327]

VM Regions Near 0x1170746d0:
__LINKEDIT 0000000117025000-0000000117033000 [ 56K] r–/rwx SM=COW /Library/Application Support/Steinberg/*/wavelabexchange.bundle/Contents/MacOS/wavelabexchange
–>
VM_ALLOCATE 00000001170ad000-00000001170ae000 [ 4K] rw-/rwx SM=PRV

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.apple.CoreFoundation 0x00007fff2e5b12bd CFEqual + 49
1 com.apple.CoreFoundation 0x00007fff2e62dd03 __NSCacheKeyEqual + 9
2 libcache.dylib 0x00007fff5a4885ff _entry_get_optionally_checking_collisions + 143
3 libcache.dylib 0x00007fff5a4883a6 cache_get_and_retain + 157
4 com.apple.CoreFoundation 0x00007fff2e628cb3 -[NSCache objectForKey:] + 61
5 libFontRegistry.dylib 0x00007fff2cc064b3 TPurgeableCache::RetainedValueForKey(void const*) + 51
6 libFontRegistry.dylib 0x00007fff2cbd4ed5 TRequestCache::CopyResultForRequest(void const*, unsigned int) + 35
7 libFontRegistry.dylib 0x00007fff2cbef54e TGlobalFontRegistry::CopyFontForName(__CFString const*, TFontQueryOptions const&) const + 68
8 libFontRegistry.dylib 0x00007fff2cbd4bd8 XTCopyFontWithName + 145
9 com.apple.CoreGraphics 0x00007fff2eddaf38 xt_copy_url_for_name + 43
10 com.apple.CoreGraphics 0x00007fff2eaf0034 CGFontFinderCreateFontWithName + 34
11 com.apple.CoreGraphics 0x00007fff2eaefed4 CGFontCreateWithFontName + 44
12 uk.co.gvst.GPlug01.GGain 0x000000011667e467 GVST::GProcFont::GProcFont() + 71
13 uk.co.gvst.GPlug01.GGain 0x000000011667e9b4 GVST::GProcFont::GetFont(char const*) + 52
14 uk.co.gvst.GPlug01.GGain 0x000000011666dfff GVST::GEditorSkinBuilder::createResource(GVST::GEditorSkin*, XP::TokenReader*) + 1487
15 uk.co.gvst.GPlug01.GGain 0x000000011666d2e1 GVST::GEditorSkinBuilder::createSkin(XP::InputReader*) + 1745
16 uk.co.gvst.GPlug01.GGain 0x000000011666cb8d GVST::GEditorSkinBuilder::createEditorFromResource(char const*) + 109
17 uk.co.gvst.GPlug01.GGain 0x0000000116676003 GVST::GEffect* GVST::gvstCreate<GVST::GGain, GVST::GEditorSkinBuilder>(long long ()(AEffect, int, int, long long, void*, float), char const*, char const*) + 195
18 uk.co.gvst.GPlug01.GGain 0x00000001166828e9 VSTPluginMain + 41
19 com.steinberg.VSTPlugManager 0x0000000116ac1b13 0x116a6c000 + 350995
20 com.steinberg.VSTPlugManager 0x0000000116ab986d 0x116a6c000 + 317549
21 com.steinberg.cubase10v5 0x000000010b222e9c 0x10a208000 + 16887452
22 com.steinberg.cubase10v5 0x000000010b239f42 0x10a208000 + 16981826
23 com.steinberg.cubase10v5 0x000000010b243958 0x10a208000 + 17021272
24 com.steinberg.cubase10v5 0x000000010b24659c 0x10a208000 + 17032604
25 com.steinberg.cubase10v5 0x000000010b255763 0x10a208000 + 17094499
26 com.steinberg.cubase10v5 0x000000010a4dc8a5 0x10a208000 + 2967717
27 com.steinberg.cubase10v5 0x000000010a4ee42c 0x10a208000 + 3040300
28 com.steinberg.cubase10v5 0x000000010b707110 0x10a208000 + 22016272
29 com.steinberg.cubase10v5 0x000000010b706862 0x10a208000 + 22014050
30 com.steinberg.cubase10v5 0x000000010be5f746 0x10a208000 + 29718342
31 com.steinberg.cubase10v5 0x000000010b753488 0x10a208000 + 22328456
32 com.steinberg.cubase10v5 0x000000010b3d1184 0x10a208000 + 18649476
33 com.steinberg.cubase10v5 0x000000010a95d069 0x10a208000 + 7688297
34 com.steinberg.cubase10v5 0x000000010a9ad849 0x10a208000 + 8017993
35 com.steinberg.cubase10v5 0x000000010b01c206 0x10a208000 + 14762502
36 com.steinberg.cubase10v5 0x000000010b023de8 0x10a208000 + 14794216
37 com.steinberg.cubase10v5 0x000000010c22df4e 0x10a208000 + 33709902
38 com.steinberg.cubase10v5 0x000000010c22e02e 0x10a208000 + 33710126
39 com.apple.AppKit 0x00007fff2c098384 withWindowOrderingObserverHeuristic + 455
40 com.apple.AppKit 0x00007fff2c098050 -[NSApplication(NSAppleEventHandling) _openURLs:withCompletionHandler:] + 998
41 com.apple.AppKit 0x00007fff2beffd3e __69-[NSApplication(NSAppleEventHandling) _handleAEOpenDocumentsForURLs:]_block_invoke + 886
42 com.apple.AppKit 0x00007fff2beff93d -[NSApplication(NSAppleEventHandling) _handleAEOpenDocumentsForURLs:] + 228
43 com.apple.AppKit 0x00007fff2bbcc6e7 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 764
44 com.apple.Foundation 0x00007fff308a26d0 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 286
45 com.apple.Foundation 0x00007fff308a254d _NSAppleEventManagerGenericHandler + 102
46 com.apple.AE 0x00007fff2f824397 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 1815
47 com.apple.AE 0x00007fff2f823c29 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 41
48 com.apple.AE 0x00007fff2f823b01 aeProcessAppleEvent + 414
49 com.apple.HIToolbox 0x00007fff2d83a8b7 AEProcessAppleEvent + 54
50 com.apple.AppKit 0x00007fff2bbc8a9d _DPSNextEvent + 1935
51 com.apple.AppKit 0x00007fff2bbc746b -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1361
52 com.apple.AppKit 0x00007fff2bbc1588 -[NSApplication run] + 699
53 com.steinberg.cubase10v5 0x000000010c22b588 0x10a208000 + 33699208
54 com.steinberg.cubase10v5 0x000000010c057986 0x10a208000 + 31783302
55 com.steinberg.cubase10v5 0x000000010bc1a131 0x10a208000 + 27337009
56 com.steinberg.cubase10v5 0x000000010bc1dcbb 0x10a208000 + 27352251
57 libdyld.dylib 0x00007fff5a6043d5 start + 1

Thread 1:: CRASH THREAD
0 libsystem_kernel.dylib 0x00007fff5a73926e semaphore_timedwait_trap + 10
1 com.steinberg.cubase10v5 0x000000010bc40902 0x10a208000 + 27494658
2 com.steinberg.cubase10v5 0x000000010b02c221 0x10a208000 + 14828065
3 com.steinberg.cubase10v5 0x000000010bc3fb84 0x10a208000 + 27491204
4 libsystem_pthread.dylib 0x00007fff5a7f82eb _pthread_body + 126
5 libsystem_pthread.dylib 0x00007fff5a7fb249 _pthread_start + 66
6 libsystem_pthread.dylib 0x00007fff5a7f740d thread_start + 13

OK, it just crashed again. Darn. I was simply replacing a VST plugin with another one on the same channel… this time Ozone 9 eq with Neutron 3 eq. I had loaded up my template, a very extensive template, and was working inside it. I was just recreating a plugin chain that I like to have on my Control Room output bus - Abbey Road Studios 3 by Waves, followed by headphone eq… and a few plugins before it.

that crash report is attached.
Cubase 10.5_2020-09-15-084328_Macintosh-2.crash (316 KB)

Hi,

There is definitely one crash, which is clearly in the GVST’s GGain plug-in.

The rest is quite generic, somewhere in the system.

Except that GGain didn’t crash it this time. I’ll remove it from my template, save, and start from scratch again, rebuilding Cubase prefs… I will also remove all Waves plugins from my template and save first before I do this. Again, I’ll report back shortly.

how do I resolve a generic problem? I have the Apple generated crash report that you or someone can also look at. I have several other crash reports. I believe I will need a lot more aid through this process. What other steps can I take. Rebuild the projects and templates from scratch? Also, is there specific tech support I can call to speak with?

What’s the fastest way to get working again… is my main question.

Thank you very much for your help.

Also, re GGain, it didn’t cause any crashes before that I know of. The system had been running smoothly for a good long while UNTIL I added the Waves plugins… and yet there is no indication that Waves plugs are causing the issue.

OK, it crashed again.
Gosh, I really need some high level help with this. I’m 2 days of troubleshooting in, and losing work…
Can you please advice on next steps? I’m at a loss.
Is there someone you can refer me to who can extract more detail from these crash reports? Someone I can talk to?

I trashed prefs completely, and opened up a completely empty project, and then when swapping in one VST plugin for another, in this case it was Slate Digital Virtual Rack… poof, crash.

I only had one Waves plugin loaded, and it wasn’t turned on.

My crash report is attached. It is the same type of error again:

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000058
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [4916]

I also just tried this again, removed the Waves plugin… and then tried to add the Slate Digital Virtual Rack, and it crashed again.

But it has nothing to do with Slate Digital Rack, or GGain, Ozone / Neutron… since all this crashing just started happening and it happens at weird times, again it even happened when I was just trying to “save as template” 3 separate times. And it has nothing to do with Cubase prefs…

Something is wrong at the foundation level of either Cubase or my computer or both.

Hi,

Try to reinstall Cubase, please. Make sure you:

  • Download the Full Installer.
  • Unpack the ZIP file and install from the unzipped folder.
  • Install from the setup.exe.
  • Install as administrator.
  • Install to the system © drive.

If this doesn’t help, I would recommend to install clean system, sorry.

I will reinstall Cubase, yes.
Martin, there’s a lot of detail in those crash reports. I would like to speak with someone who can interpret them in depth.
Who can I contact?

Hi,

I’m sorry, I’m not Windows guy.

which Waves version? And which bundle?

Martin, my system is Mac Mojave… (as it says in my profile).
Again, who can I contact for help with this?

st10ss… it’s not Waves, or any plugins. That’s been narrowed down now.

Hi,

Oh, sorry… I’m sorry, I don’t know.

I want to thank you for your help, Martin. Reinstallation appears to have worked. In 22 years of using Cubase, I’ve never had to reinstall it to fix an error. I always thought trashing prefs would fix it, or disabling plugins. This time it had everything to do with the moment my system said it was out of application memory and the crashed the program, I think. Something bjorked the program files and they needed to be reinstalled.

Thanks again!