2.0.0 Automation bug

I/O’s of an automation track are not saving in the project. After recalling previousli saved project they are empty
Screenshot 2024-04-19 at 12.53.12

… what was your input?

Thank you,
Michael.

1 Like

Octavox

… we already fixed various sources. Sorry. And Octavox was loaded … where? Just to get sure that it will working with the next update.

Thank you,
Michael.

It’s on Stacks

… thank you, @AntonVorozhtsov. That problem has been fixed, but it did not make it the current Pre-Release. But it will be ready with the next one.

Please be patient for one more moment,
Michael.

1 Like

Thank you!

image
Looks like now it works, thank you!

Using v2.0.6

Hi,
I tried to automate the DRIVE and VOLUME of Steinberg’s Ampsimulator.
This works fine but after reload of the project the plugin
Automation Init


is not saved.
So you have to select the plugin manually everytime.
I also notice that if you do this and exit VST Live 2, you are not asked to save the project. So the change has not been recorded by VST Live 2.

Paul

Where do you load the Plug-Ins?

/Michael.

… oh, I see. I guess you have loaded it to your Audio Track (“Track 1”). Sorry, we’ll fix it. Meanwhile you could create a STACK and load the AmpSimulator there. Then use it in an Automation Track. This works fine.

/Michael.

Yes, that’s what I did loaded Ampsimulator as a stack. Track 1 is a backing track.
I’m using two automation tracks.

Tried this meanwhile with Guitar rig 7 as a stack and it seems to be the same.

Paul

… macOS or Windows?

/Michael.

Windows 11

Paul

I am trying to get it reproduced.

  1. Start VL
  2. Select STACKS and add a Stack
  3. Load AmpSimulator to Slot_1
  4. Select TRACKS
  5. Add Audio Track
  6. Add Automation Track
  7. Select “Stacks / Stack 1 / Slot 1 / AmpSimulator” as an Input for the Automation Track
  8. Save Project
  9. Close VL
  10. Start VL, Load Project
  11. Everyting will be reconnected

Where is the missing bit? Can you help me?
Michael.

… and can you please get sure that 2.0.6 was successfully installed? Check the About view (Menu / Help / About)

/Michael.

Well, I do exactly all that.
But obviously point 11 is not working because after reload I have to select Ampsimulator again manually because it’s not there anymore.

The recorded automation data is still there and works fine.

Version 2.06.112 correctly installed.

Paul

… ah, found it. Use “File / Preload Parts …”, then the connection will be established.

If you tick “Always preload” …


… save project, then it will work directly when you load the project.

Michael.

Michael,

yes, that indeed works. :+1:t2:

However, if “Always preload” is not selected it’s still a bug, no?

Thanks.
Paul

… yes, we’ll check. Thank you for pointing to that one!

Michael.