[2.0.3] RTZ assigned to MIDI controller not working

RTZ-function has stopped working when assigned to MIDI controller. I tried to re-learn RTZ to another controller button, learn seems OK but RTZ still doesnt work.

… and thank you again for reporting, @Turmis. We’ll check that, too!
Michael.

Works fine here (2.0.4). What exactly do you do? Tried Learn, On/Off, cc#3, no problems.


Still same problem in 2.0.6. It worked very well with these settings in versions 1.4.xx etc.

My settings in attached image. Keyboard shortcuts work well, but there’s something with MIDI in RTZ… all other functions work properly.

I have Start & stop assigned in same controller, using latch function… as I have a on/off light in my midi controller (when #CC107 value is 127 → light on). I have noticed when I click stop button on the screen, and do that again, RTZ seems applied. In current setup I cant do that with my controller, as my start/stop buttons latches between 0 and 127 → I cant “push stop button” (have value 0 in #CC107) 2 times in a row.

Not a show stopper and I can live with it, but as it worked before as I wanted, maybe there’s some glitch there.

E: Strange, suddenly it works like charm, I can’t recall anything specific I did. Had 2 hours break doing other stuff… well I created a test project from scratch and did some testing with another anomaly (mixer track ordering, another thread) and didnt find any special there… suddenly I return my own project file and rtz works.
Well, its good for now.

And next day after doing some playing etc, I realize that MIDI-controlled RTZ is broken again.
All other functions work flawlessly, re-learn doesn’t help, even with another CC’s.

I found out that it isn’t dependable on project file. Maybe deleting/resetting preferences data would help, I’ll check out and report here later.

Actions and Shortcuts are saved locally as well as with a project.
Maybe try “Help/Remove all User Data”, you will have to re-create some settings though.
And there is absolutely no special treatment of RTZ with actions. Maybe some clash with stop/stop, which is also causing RTZ as you already pointed out?

User data removal didn’t help.
Sometimes the RTZ works, but most of the time it doesn’t. I’ll try to catch if there’s something that triggers its (mal)functionality.

I’ll notify here if I find something new about this.