2 Problems with condensing: not working on horns // 2 player labels shown

While condensing works with clarinets and bassoons, it does not with horns. I tried with and without “Custom condensing groups”. The 4 horn voices are a result of manually splitting up 2 horn voices that each held 2 horns. So I wonder: when I moved down the 2nd resp. 4th horn to their new staves, did they keep their “voice indictor” (as in “2nd voice” or “downstem voice”) and could thisin consequence cause the problem? If so, how can I tell Dorico to change the “voice number” of horn 2 and 4?

In places, where condensing works, double player labels appear:

Bildschirmfoto 2022-12-20 um 14.37.03

Here I have absolutely no idea, what the reason could be.

(BTW: I did read the manual and also watch “Discover Dorico”'s episode on “Condensing Tips”.)

I just found out that groupings of “hrn 1 +3” and hrn 2+4" DO work. But groups of “hrn 1+2” and “hrn 3+4” do not work.

I use horn condensing for 1+2 and 3+4 all the time. There must be something in your horn parts preventing it.
Make sure all music in the four horn parts is in upstem voice 1 only. Make sure dynamics, slurs etc. are exactly the same between the parts that have to condense. Even a barely visible difference in dynamic grouping will matter.
I’m not sure instruments can belong to more than one custom condensing group.

@PjotrB Thank you! Any idea how I can make sure that the notes are in the 1st upstem voice?

Double-clicking a note show the input indicator with a stem up:

Also any ideas why there are 2 instrument labels?

IIRC If one wants horns 1 & 2 together on some systems and 1 & 3 on others, one needs to start the work with all 4 horns in the default condensing group and then use manual changes to regroup the horns as desired.

You can select notes and choose Change to voice… > Up-stem voice 1 from the right-click menu. But this might accidentally leave some items like dynamics unselected. You could use the System Track (grey ribbon above the staff, make visible with Option-T/Alt-T) to be sure you select bars with everything inside. After selecting a bar, press Shift-Cmd-A/Shift-Ctrl-A a few times to Select More. Then choose the change voice command.
[Edit:] The system track selects the whole system. If you use this do it in the horn part, not the score.
In any case, if you turn on voice colouring (View menu), it’s easier to see if there are notes in an unwanted voice. You might check in the separate horn parts, then it’s easier to spot.

I think the labels are staff-specific. The 1. is the first on that staff. I’m not working on my Dorico machine right now, so I can’t check for myself if this is always the case, and how to change it into 3. or something else.

Of course… Thanks Derrek. I’m pretty sure that will also take care of the numbering.

@Derrek: Thanks for your feedback! Just to clarify: Condensing 1+2 and 1+3 ist not, what I want to do. I wrote that the combination of horns 1+3 and 2+4 works, but 1+2 and 3+4 does not condense. If you mean something else, can you please clarify?

@PjotrB Thank you – the “change to Up-stem voice” did the trick!

I am still confused by the double player labels, which are not very well visible in the screenshot above. Therefore here another one:

Bildschirmfoto 2022-12-20 um 14.37.03

Any idea what is going on here?

It might help to see the actual project (which I can examine when I’m home), but I think it’s because there are 2 separate condensing groups. In each group, there is a 1st and a 2nd horn. These separate groups don’t know you’d like to call them horn 3+4 or whatever.

But if you create a custom condensing group containing all 4 horns, Dorico will know how to number them from 1 to 4. If you use condensing changes to create 2 staves with 2 horns each, they’ll still be one group, and the numbering will be OK.

Slightly off-topic: I often adjust the default placement and padding of the small part numbers, because such a small digit 1 practically disappears in the barline. It’s somewhere in Engraving Options.

1 Like

I have to apologise for causing needless confusing due to my screenshots. The screenshot with the circled 1s actually does NOT show horns, but clarinets and bassoons. I really should have mentioned that! Again: sorry!

So it is not a problem that "1"s are shown (because it is indeed the 1st clarinet and the 1st bassoon playing in the shown excerpt). But I wonder why there is a small “1” right in the barline and a big “1” right above the dynamic? That I do not understand. Is that a problem with my XML import? Is the big “1” probably just text? (This just came to my mind while writing… checking now…)

Yes, of course! The larger number is simply text that remains there due to XML import. And yes, enlarging the player label number is necessary (there is a Paragraph Style called “Player label” in addition to the Engraving options you mentioned.)

Thank you again all of you for your help! I learned a lot today! :slight_smile:

1 Like

One confusion remains, though: I see a player label AND rests for the silent 2nd instrument, even though I have selected “Show rests and omit labels” in “Notation Options => Condensing”. Do I have to check another option somewhere else, too? (Haven’t found one yet…)

I think you should upload the project if possible.

1 Like